Jump to content

RX 6800 Monitor Energy Saving not working properly

Hi everybody,

I've recently bought an AMD RX 6800 to swap out my old GTX 1070 and had some trouble with some weird behaviour. Now this one, I'm honestly out of ideas on how to fix it short of reinstalling my OS which I want to avoid.

Some context about my System:

- I have 3 Monitors and an Oculus Rift S connected to that GPU. One Monitor is connected via HDMI, the others and the Rift are connected via DisplayPort. Only those 2 Monitors have issues. The Setup was the same with my GTX 1070 which never had any issues with this.

- GPU Drivers of the old NVidia card where uninstalled using DDU in Save Mode

- Cables are all good, Connectors on the GPU seem to be good aswell

- I'm using Windows 10

- Drivers are up to date

- The main screen uses FreeSync but seems to have the issue regardless of it being turned on or off

So here is my problem:

Whenever my PC turns off my Monitors to save energy, all the connected Monitors via Displayport seem to have issues turning off. HDMI never had any issues.

There seem to be 3 different options on what happens when they turn off:

1. Both Monitors will go to sleep but keep waking up regulary (I'm talking about every minute) just to show "No Signal" and going back to sleep again in a loop.

2. One of the Monitors (always the same) will turn off properly, but the main screen will never turn off its backlight. It does show "No Signal" for a while but will never actually turn off (this btw also happens sometimes when I turn off the PC completly)

3. Both screens actually do turn off properly and will not wake up randomly. When I wake up the system though, all Apps running on the second screen will now be displayed on the main screen, all desktop icons from other Monitors (including the HDMI one) will be thrown on the main screen and all desktop backgrounds will be set to the same image even though I do have setup one for each indiviual screen.

The way I've ordered these 3 Options is by their likelihood to occur when shutting down. So 1. does happen the most and 3. almost never happens.


I've tried many solutions, none of which worked, googling it didn't yield any useful returns, also tried chatGPT, which told me it is impressed by my technical knowlegde but wasn't able to find any working solution either, which was fun 馃槃

Does anybody have any idea on how to fix this issue or ran into it?

What I do not want to see:

- NVidia shills who try to tell my AMD is all garbage

Link to comment
Share on other sites

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now