Jump to content
ALERT - Linus Tech Tips, Tech Quickie, Tech Linked Youtube Channels Hacked ×

Dual channel problem

Hi. Just bought a pair of 2x8GB RAM stick. Installed on A2 and B2 slot but windows 10 and BIOS read as 16GB but only 8GB utilized. When I installed it on A2 and B1 slot it work normally. And another problem is that when I enable XMP with both installed way it refused to work and pc boot and reboot 3 times before it return to stock speed at 2133mhz. Tried everything included update Bios to latest.

My pc specs:

Ryzen 7 1700

Apacer Nox 2x8GB Ram

Asrock B450m pro f bios ver 7.4



Link to comment
Share on other sites

Link to post
Share on other sites

For utilization it should be an easy fix. type in system configuration, go to the [boot] tab, and choose [advanced setup], check the box marked [max memory], if it's already checked, uncheck and re-check it. hit apply, then OK... and you should get notice to reboot IIRC, if not manually reboot and should be fixed now.

For the speed, have you tried setting it manually to the desired speed? also, it may need more voltage... but can't advise on that side of it as I'm not running AMD systems at the moment and can't remember.

Please quote my post, or put @paddy-stone if you want me to respond to you.

  • PCs:- 
  • Main PC build  https://uk.pcpartpicker.com/list/2K6Q7X
  • ASUS x53e  - i7 2670QM / Sony BD writer x8 / Win 10, Elemetary OS, Ubuntu/ Samsung 830 SSD
  • Lenovo G50 - 8Gb RAM - Samsung 860 Evo 250GB SSD - DVD writer
  • Displays:-
  • Philips 55 OLED 754 model
  • Panasonic 55" 4k TV
  • LG 29" Ultrawide
  • Philips 24" 1080p monitor as backup
  • Storage/NAS/Servers:-
  • ESXI/test build  https://uk.pcpartpicker.com/list/4wyR9G
  • Main Server https://uk.pcpartpicker.com/list/3Qftyk
  • Backup server - HP Proliant Gen 8 4 bay NAS running FreeNAS ZFS striped 3x3TiB WD reds
  • HP ProLiant G6 Server SE316M1 Twin Hex Core Intel Xeon E5645 2.40GHz 48GB RAM
  • Gaming/Tablets etc:-
  • Xbox One S 500GB + 2TB HDD
  • PS4
  • Nvidia Shield TV
  • Xiaomi/Pocafone F2 pro 8GB/256GB
  • Xiaomi Redmi Note 4


  • Unused Hardware currently :-
  • 4670K MSI mobo 16GB ram
  • i7 6700K  b250 mobo
  • Zotac GTX 1060 6GB Amp! edition
  • Zotac GTX 1050 mini



Link to comment
Share on other sites

Link to post
Share on other sites

What is the speed of the RAM?


First gen Ryzen often had issues with RAM speeds faster than DDR4-3000. Sometimes it could only handle speeds as low as DDR4-2666, which is the rated spec for that generation of chips. So if you have DDR4-3200 or DDR4-3600, it's very possible that your R7 1700 just won't work with the RAM clocked at that speed.


You can try enabling XMP, and then (before leaving the BIOS) manually setting the speed to something lower, like DDR4-2933. That might let you boot.


As for the dual-channel issue, we need to figure out if the slot on the motherboard is the problem. Can it boot correctly with just 1 stick installed in slot B2?


Also, does it work with the RAM installed in A1 and B1? That is also a valid dual-channel config, even if it's not what you're "supposed" to use, according to the manual.

Link to comment
Share on other sites

Link to post
Share on other sites

tried everything so far including msconfig, enable XMP and change bus speed manually. Tried both ram stick individually and each work perfectly normal with XMP on

Link to comment
Share on other sites

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now