Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

i7 3770 motherboards??

hey guys
i wanted to get a little help
so i have a minecraft server
it has an fx 4300, 12 gb of ram and a rx 560 4gb (ik its stupid its just the only extra card i had so i figured may as well) and i only use it for minecraft
i also have an i7 3770 laying around and thats a lot better then an fx 4300
so i figured may as well switch right
but the motherboard i have for the i73770, i think it has water damage or something idk, i got it to turn on but it would randomly flash colors or shut off. I tried using the rx 560 instead of the integrated and instead of flashing colors it would just freeze or turn off
i think its the motherboard thats broken
i am sure its not the ram
and it boots into windows
so i dont think its the cpu
and i can visably see damage on the motherboard
so i think its that
so i figure my only option is to replace it right'
well lga 1155 motherboards are annoying and i cant find any for cheap like sub $30 i dont wanna spend a lot of money preferable sub $20 so i think ill have to end up going with a motherboard from a prebuilt
any suggestions on what i should buy?
i found this but idk if itll work with my cpu
but really all i need is something that has a standard psu 24 pin and stuff
preferably some form of atx so i can put it in my server case and if its possible i doubt it but just maybe if it had 4 ram slots
any suggestions on what i should get?
Link to post
Share on other sites

It'll work, but chances are it'll have custom front panel connectors and nasty power limits, meaning no turbo on your i7. I've experienced this on an HP board I bought recently... damn you, HP.

Link to post
Share on other sites
21 minutes ago, brian105 said:

It'll work, but chances are it'll have custom front panel connectors and nasty power limits, meaning no turbo on your i7. I've experienced this on an HP board I bought recently... damn you, HP.

damn yea the motherboard i have rn for it honestly isnt bad at all its an itx board and it works but then it just bugs out on me its super annoying

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×