Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

Power Limit Throttling at 800Mhz? Not sure what's happening here.

Go to solution Solved by unclewebb,

image.png.469fcd553729de39de8531986d24ec99.png

 

What seems to be happening on these laptops is that either the BIOS or some Asus software is incorrectly setting the turbo power limits to only 5 Watts for both the long and short term limit. This results in massive throttling. Setting these to 45W for long and 60W for short and then using the ThrottleStop Lock option will prevent these power limits from accidentally changing back to 5W.

 

If you ever need to change or unlock these power limits, exit ThrottleStop, delete the ThrottleStop.INI configuration file, and shut down your computer so the CPU can reset itself. When your start ThrottleStop, it will create a new ThrottleStop.INI configuration file. This will allow you to start again with everything at default settings.

 

Hopefully this stupidity from Asus is not by design. That is what a Dell rep recently claimed when they got caught with the same sort of power limit throttling issue.

 

Edit - The source of this power limit problem might be Armoury Crate. 

Hi all,

 

I've been unable to find anyone with the same problem so far so I figured I'd just post.

 

I have an Asus Tuf fx505 with an i5-9300h and a GTX 1650. As of 2 days ago I am having severe power limit throttling issues. Both in games and idle or doing basic web browsing my CPU is stuck at around 800Mhz when it normally runs 3500-4000Mhz under load.

 

I've monitored this with XTU and in-game with Afterburner and it's very consistent. My performance is absolute garbage. XTU stress test told me it's power limit throttling and not thermal.

 

To fix it I've rebooted several times, changed my power profile several times, unplugged and plugged back in. I'm not really sure what else to try.

 

Any assistance is greatly appreciated.

 

Edit: It looks like as soon as I put it under load my processor cache frequency drops from about 2.1Ghz to 0.8Ghz almost instantly and my maximum core frequency follows a few seconds later? Weird that it can idle at normal frequencies but as soon as I put it under load everything plummets.

 

Edit 2:

SOLVED!!!

 

Apparently something (most likely armoury crate) set my turbo power limits to 5W. I just manually set different values and everything is back to normal.

Big shout out to Unclewebb and Threecakes for figuring this out and providing instructions on how to fix it!
 

Link to post
Share on other sites

I guess it could be a power saving feature, but it shouldn't throttle down when put under load.. Have you tried resetting the BIOS?

Link to post
Share on other sites

I'm assuming you have the fx505gt because I have the same issue happening that started around 3 days ago. I have tried resetting the bios to default settings, draining the CMOS battery, restarting, flashing the latest bios, and hard resetting but nothing works.

 

I contacted Asus support two days ago and the person said to send in images, videos, and feedback so their engineers can solve the issue. So far, they have not replied.

Link to post
Share on other sites

THANKS TO UNCLEWEBB FOR THE HELP

Here's a solution to fix the Power Limit Throttling issue:

 

Download ThrottleStop and look at the settings below.

 

Image 1-Turbo Boost Limits (TPL) Window

1. Check both Turbo Boost Long Power Max and Short Power Max boxes.

2. Change Long Power Max to 45 and Short Power Max to 60.

3. Check the Lock box then Apply the new settings and click OK.

(OPTIONAL) Look for Speed Shift and change Max to a different number if you do not like the temperatures you see.

Screenshot_36.png.95ac88c17e9ea62011ae827fdabe1737.png

 

Image 2-FIVR Window

1. Check Disable and Lock Turbo Power Limits box then Apply the new settings and click OK.

Screenshot_37.png.1aa4e0118cc08f08345da23435a93ea5.png

 

Image 3-ThrottleStop Main Window

1. Uncheck Disable Turbo box and Save

Screenshot_38.png.ac48dc3d578f438a232dd77549b17e91.png\

 

Image 4-Options Window

1. Check Start Minimized and Minimized on close

(OPTIONAL) Asus set the PROCHOT Offset value to 8 so the CPU will throttle when it hits 92C. Change this value if you want the CPU to throttle at a different temperature.

 Screenshot_39.png.e0f8fd37e4eed2a9370d5405c5e0ec60.png

Link to post
Share on other sites

image.png.469fcd553729de39de8531986d24ec99.png

 

What seems to be happening on these laptops is that either the BIOS or some Asus software is incorrectly setting the turbo power limits to only 5 Watts for both the long and short term limit. This results in massive throttling. Setting these to 45W for long and 60W for short and then using the ThrottleStop Lock option will prevent these power limits from accidentally changing back to 5W.

 

If you ever need to change or unlock these power limits, exit ThrottleStop, delete the ThrottleStop.INI configuration file, and shut down your computer so the CPU can reset itself. When your start ThrottleStop, it will create a new ThrottleStop.INI configuration file. This will allow you to start again with everything at default settings.

 

Hopefully this stupidity from Asus is not by design. That is what a Dell rep recently claimed when they got caught with the same sort of power limit throttling issue.

 

Edit - The source of this power limit problem might be Armoury Crate. 

Link to post
Share on other sites

Hi guys. Thanks for the help. So my brother's laptop started giving this problem recently. I ran throttlestop and did fix the power limiters to 45w and 60w as mentioned. But since the TDP of this chipset is at 45w, is it dangerous that we are setting it to 45w and 60w? I understand that since we won't be using the CPU on full load during gaming, so it shouldn't draw maximum power, but still just out of curiosity wanted to know. Also probably some recent update has messed things up, so if anyone does come across some driver patch, would request you to post it here. Thanks once again guys!

Link to post
Share on other sites

Intel recommends that the long term turbo power limit should be set equal to the TDP. If you have a processor with a 45W TDP, setting this to 45W is appropriate.

 

For the short term turbo power limit, Intel recommends to set this value 25% higher than the rated TDP. 45W + 25% = 56.25W. Setting a power limit higher than the rated TDP for a short period of time is normal for all Intel mobile and desktop CPUs. If you think 60W is too high, use 56W instead. If you want your laptop to run cooler, you can reduce these values below the rated TDP. You will lose full load performance as you go lower. The CPU will be forced to power limit throttle. Someone at Asus that decided to set both of these limits to 5W got a little carried away and has obviously gone too far. It was not an "accident" that two different limits both got set to the same 5W value.

 

On the 6 core mobile CPUs, it is not unusual for people to set the turbo power limits way beyond the 45W rated TDP. 70W and 90W are typical values. As long as the heatsink can handle the extra heat, setting the turbo power limits a little higher is not a problem.

4 hours ago, Szcz said:

probably some recent update has messed things up

It might have been an update to the Asus Armoury Crate software. 

Link to post
Share on other sites
On 10/24/2020 at 5:16 PM, Deadeyes117 said:

Hi all,

 

I've been unable to find anyone with the same problem so far so I figured I'd just post.

 

I have an Asus Tuf fx505 with an i5-9300h and a GTX 1650. As of 2 days ago I am having severe power limit throttling issues. Both in games and idle or doing basic web browsing my CPU is stuck at around 800Mhz when it normally runs 3500-4000Mhz under load.

 

I've monitored this with XTU and in-game with Afterburner and it's very consistent. My performance is absolute garbage. XTU stress test told me it's power limit throttling and not thermal.

 

To fix it I've rebooted several times, changed my power profile several times, unplugged and plugged back in. I'm not really sure what else to try.

 

Any assistance is greatly appreciated.

 

Edit: It looks like as soon as I put it under load my processor cache frequency drops from about 2.1Ghz to 0.8Ghz almost instantly and my maximum core frequency follows a few seconds later? Weird that it can idle at normal frequencies but as soon as I put it under load everything plummets.

I had a similar issue on an HP Omen 15. It can be solved with a BIOS reinstall. Beware! Doing a BIOS update improperly might kill your laptop. It solved this problem for me though.

Link to post
Share on other sites
On 10/24/2020 at 8:38 AM, boggy77 said:

What are your temperatures though?

Temps are really low, like 48C.

I know for sure this laptop can run up to 94C because of an older issue I had with airflow.

Link to post
Share on other sites
On 10/24/2020 at 2:48 PM, ThreeCakes said:

I'm assuming you have the fx505gt because I have the same issue happening that started around 3 days ago. I have tried resetting the bios to default settings, draining the CMOS battery, restarting, flashing the latest bios, and hard resetting but nothing works.

 

I contacted Asus support two days ago and the person said to send in images, videos, and feedback so their engineers can solve the issue. So far, they have not replied.

Please let me know if you find a solution!

Link to post
Share on other sites
On 10/24/2020 at 9:41 PM, ThreeCakes said:

THANKS TO UNCLEWEBB FOR THE HELP

Here's a solution to fix the Power Limit Throttling issue:

 

Download ThrottleStop and look at the settings below.

 

Image 1-Turbo Boost Limits (TPL) Window

1. Check both Turbo Boost Long Power Max and Short Power Max boxes.

2. Change Long Power Max to 45 and Short Power Max to 60.

3. Check the Lock box then Apply the new settings and click OK.

(OPTIONAL) Look for Speed Shift and change Max to a different number if you do not like the temperatures you see.

Screenshot_36.png.95ac88c17e9ea62011ae827fdabe1737.png

 

Image 2-FIVR Window

1. Check Disable and Lock Turbo Power Limits box then Apply the new settings and click OK.

Screenshot_37.png.1aa4e0118cc08f08345da23435a93ea5.png

 

Image 3-ThrottleStop Main Window

1. Uncheck Disable Turbo box and Save

Screenshot_38.png.ac48dc3d578f438a232dd77549b17e91.png\

 

Image 4-Options Window

1. Check Start Minimized and Minimized on close

(OPTIONAL) Asus set the PROCHOT Offset value to 8 so the CPU will throttle when it hits 92C. Change this value if you want the CPU to throttle at a different temperature.

 Screenshot_39.png.e0f8fd37e4eed2a9370d5405c5e0ec60.png

Wow this sounds like exactly what's happening. So weird to me that it idles normally then drops like a rock when boosting. This would explain that behavior!!

 

Thank you so much! I was having such a hard time finding info on this, but this sounds like it really may work!

 

I'll give it a shot today

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×