Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

Throttlestop won't let me enable "disable and lock turbo limits"

Hi,

I recently purchased a laptop that's running an Intel Core i7-8750H. It ran decent out of the box, but I made some changes to better my thermals and performance using Throttlestop. Now, I am running an undervolt of -125 mV on both the core and cache of the CPU as that's no risk and a safe undervolt to go with. I also have "disable and lock turbo limits" enabled. It all worked fine until a few days ago. I am now getting an error notification: error creating service: (null) whenever I login to Windows. This is related to having Throttlestop start with Windows (task scheduler). Whenever I uncheck disable and lock turbo limits, no error notification appears. When I then check that box again to enable it and press OK, it immidiately shows the error again. This leads me to think something is not right with the Dwdrv.sys file you have to install to tweak the power limit of the CPU. I have tried to reinstall the file multiple times, even completely deleting Throttlestop and resetting all its settings just to install it again with the same results. This means I cannot change my CPU power limits. For information, HWiNFO64 clearly says my CPU power limits are unlocked. Does anyone know is causing Throttlestop to not want to enable the disable and lock turbo limits option?

HWiNFO64.jpg

Throttlestop Error.jpg

Throttlestop Folder.jpg

Link to comment
Share on other sites

Link to post
Share on other sites

Are you using ThrottleStop 8.70.6

 

There was a recent Windows 10 Update that can prevent the RwDrv.sys driver from being installed.  What version of Windows 10 are you using?  I think this problem was first reported with a recent Windows 10 Insider Preview version 18342.8

 

Are you using Windows Defender?  

Link to comment
Share on other sites

Link to post
Share on other sites

11 hours ago, unclewebb said:

Are you using ThrottleStop 8.70.6

 

There was a recent Windows 10 Update that can prevent the RwDrv.sys driver from being installed.  What version of Windows 10 are you using?  I think this problem was first reported with a recent Windows 10 Insider Preview version 18342.8

 

Are you using Windows Defender?  

I am using Throttlestop 8.70.6. My Windows version is 17763.316 (Windows 10 Home). And I am also using Windows Defender.

Link to comment
Share on other sites

Link to post
Share on other sites

Probably a Windows Defender issue.  It tends to be overly eager to block things, even the useful stuff.  I use the free version of Avast and I am not having any issues with the RwDrv.sys file being installed.  You might be able to tell Defender to ignore this file.

Link to comment
Share on other sites

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share


×