Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

Windows wont boot after trying to enable ACHI.

luddomack
 Share

I was trying to enable AHCI on my SSD, by following the steps on the first comment in this post.

 

I only made it to step 6, then the PC crashed or something happend. Now when I start the PC I get to automatic repair, and can't boot Windows anymore. I can't even get Windows to boot in safe mode. 

 

The logfile in automatic repair says "F:\Recovery\WindowsRE\Winre.wim\System32\Logfiles\SrtTrail.txt".

 

I have googled the message and tried every potential "fix" there is for it. But nothing works.

 

Sorry for creating a new post about this instead of commenting the original post, but its looks dead and I need help fast.

 

So, if I could get help that would be fantastic.

 

Thanks!

Link to comment
Share on other sites

Link to post
Share on other sites

Try to get a bootible flash-drive of windows.

I'm gonna go find my own tech support...

with BLACKJACK and HOOKERS!

(Welcome to LTT Forums)

Link to comment
Share on other sites

Link to post
Share on other sites

See if somehow you can edit the registry to restore it. 

You'll have to be creative ?

I'm gonna go find my own tech support...

with BLACKJACK and HOOKERS!

(Welcome to LTT Forums)

Link to comment
Share on other sites

Link to post
Share on other sites

You can't just enable AHCI and reboot and expect it to work. You need to set a registry flag BEFORE switching on AHCI in the BIOS, or Windows won't boot. Set your SATA mode back to IDE or whatever it was set as before and retry.

PC Specs - AMD Ryzen 5 5600X MSI B550M Mortar 16GB Crucial Ballistix DDR4-3600 @ CL15 - RX5700XT 660p 1TBGB & 256GB 600p Fractal Define Mini C CM V550 - Pop!_OS 20.04

 

Link to comment
Share on other sites

Link to post
Share on other sites

2 minutes ago, NelizMastr said:

You can't just enable AHCI and reboot and expect it to work. You need to set a registry flag BEFORE switching on AHCI in the BIOS, or Windows won't boot. Set your SATA mode back to IDE or whatever it was set as before and retry.

Hmm okey. I actually did not change anything in BIOS.

Link to comment
Share on other sites

Link to post
Share on other sites

6 minutes ago, Dubious Gaming: bl4z3 said:

See if somehow you can edit the registry to restore it. 

You'll have to be creative ?

Alright, I will se what I can do.

Thanks.

Link to comment
Share on other sites

Link to post
Share on other sites

3 minutes ago, luddomack said:

Hmm okey. I actually did not change anything in BIOS.

??? AHCI is a BIOS setting, not a Windows setting.

PC Specs - AMD Ryzen 5 5600X MSI B550M Mortar 16GB Crucial Ballistix DDR4-3600 @ CL15 - RX5700XT 660p 1TBGB & 256GB 600p Fractal Define Mini C CM V550 - Pop!_OS 20.04

 

Link to comment
Share on other sites

Link to post
Share on other sites

20 minutes ago, luddomack said:

Hmm okey. I actually did not change anything in BIOS.

Well that’s your problem, you can’t just change the windows setting without changing the corresponding BIOS setting...also that guide in OP only works if you have IRST installed.

 

the easiest way way to change the SATA mode after Windows is installed is to set the system to boot to safe mode when you change the SATA mode.

16 minutes ago, NelizMastr said:

??? AHCI is a BIOS setting, not a Windows setting.

It’s both a Windows setting and BIOS setting 

ლ(ಠ益ಠ)ლ
(ノಠ益ಠ)╯︵ /(.□ . \)

Link to comment
Share on other sites

Link to post
Share on other sites

Just now, SSD Sean said:

It’s both a Windows setting and BIOS setting 

It's not a Windows setting if you configure your BIOS properly, beforehand, though :D 

PC Specs - AMD Ryzen 5 5600X MSI B550M Mortar 16GB Crucial Ballistix DDR4-3600 @ CL15 - RX5700XT 660p 1TBGB & 256GB 600p Fractal Define Mini C CM V550 - Pop!_OS 20.04

 

Link to comment
Share on other sites

Link to post
Share on other sites

Just now, NelizMastr said:

It's not a Windows setting if you configure your BIOS properly, beforehand, though :D 

It is so. ? if you want to change it to RAID or IDE you need to change it in both the BIOS and Windows still lol

ლ(ಠ益ಠ)ლ
(ノಠ益ಠ)╯︵ /(.□ . \)

Link to comment
Share on other sites

Link to post
Share on other sites

1 minute ago, SSD Sean said:

Well that’s your problem, you can’t just change the windows setting without changing the corresponding BIOS setting...

 

the easiest way way to change the SATA mode after Windows is installed is to set the system to boot to safe mode when you change the SATA mode.

Okey, I will keep that in mind.

Thanks.

Link to comment
Share on other sites

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share


×