Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
Pc Foundry Josh

Asus ROG GL503GE Screen Displaying Low Quality Image

Recommended Posts

Posted · Original PosterOP

Hi Guys,

 

First post on here and its partly because im at my whits end!

 

I just bought a brand new Asus ROG GL503GE Scar Edition Laptop and anytime I try to watch youtube, or Netflix or really any type of video even though everything is set to 1080p Quality it displays like its running in 360p.

 

In display settings the screen is set to 1920 x 1080 , 120HZ , 125% scaling ( recommended ).

 

It has a 1050TI which has the latest GeForce drivers Plus it has UHD I GPU which has the latest intel driver.

 

I've tried messing with all the settings in the Nvidia Control Panel, and the Intel control Panel, I've done all the latest windows updates plus a Bios Update.

 

I plugged the hdmi cable from my TV in to see if it was just the display on the laptop but it was also displaying in low quality on my TV as well.

 

I also tried tethering the internet off my phone as well thinking maybe it was slow internet and it was playing poor quality even though it says 1080p, but that didn't make a difference either.

 

So it has to be a config issue. ive read nothing but good reviews of this laptops screen, including the one linus did.

 

The laptop itself has a I7 8750H 6 core CPU and a GTX 1050TI 4GB, Has an NVME Boot Drive and an SSHD Storage drive. so its no slouch for day to day work loads.

 

Any suggestions? Maybe a complete re install of windows to get rid of the OEM asus version? I want to edit videos on this thing with premiere pro so I need to fix it.

 

Thank You

 

 

20180817_171941.jpg

Link to post
Share on other sites
Posted · Original PosterOP

I took this screen shot in Geforce Experience, the video isn't playing its just a preview.

 

But look in here headphones and behind her head, that's how everything is displaying on the screen, even if I open pictures they all look super low quality. this has got me stumped!

Untitled.png

Link to post
Share on other sites
On 8/17/2018 at 6:03 PM, Pc Foundry Josh said:

Hi Guys,

 

First post on here and its partly because im at my whits end!

 

I just bought a brand new Asus ROG GL503GE Scar Edition Laptop and anytime I try to watch youtube, or Netflix or really any type of video even though everything is set to 1080p Quality it displays like its running in 360p.

 

In display settings the screen is set to 1920 x 1080 , 120HZ , 125% scaling ( recommended ).

 

It has a 1050TI which has the latest GeForce drivers Plus it has UHD I GPU which has the latest intel driver.

 

I've tried messing with all the settings in the Nvidia Control Panel, and the Intel control Panel, I've done all the latest windows updates plus a Bios Update.

 

I plugged the hdmi cable from my TV in to see if it was just the display on the laptop but it was also displaying in low quality on my TV as well.

 

I also tried tethering the internet off my phone as well thinking maybe it was slow internet and it was playing poor quality even though it says 1080p, but that didn't make a difference either.

 

So it has to be a config issue. ive read nothing but good reviews of this laptops screen, including the one linus did.

 

The laptop itself has a I7 8750H 6 core CPU and a GTX 1050TI 4GB, Has an NVME Boot Drive and an SSHD Storage drive. so its no slouch for day to day work loads.

 

Any suggestions? Maybe a complete re install of windows to get rid of the OEM asus version? I want to edit videos on this thing with premiere pro so I need to fix it.

 

Thank You

 

 

20180817_171941.jpg

I'm having the same issue. Any update on this?

Link to post
Share on other sites

I figured it out. I recently bought this laptop and i love watching shows but the video quality was awful and it made no sense considering how great its graphics card is. So i went to the intel graphics command center. I will walk you all through it if you still need the answer. just thought you all might need it too.

Open Intel Graphics Command Center.

Go to the option "Video" 
there you will see 2 video settings (Brighten and darken) along with default.

Click on Brighten and then click custom settings. Cuz both those settings dont fix it but something in the middle does and i figured it out after alot of tampering. 

They used to have a 3rd one and if any of u have a third option (If you havent updated windows it should still be there) then click on that 3rd one and your video quality will be back to normal.

To those who went and did what i did (Update), Put these settings (in the pictures below) as your custom ones and restart your laptop.

Hope it works. Worked for me! 
 

 

Screenshot (1).png

Screenshot (3).png

Screenshot (4).png

Screenshot (5).png

Screenshot (6).png

Link to post
Share on other sites
On 5/7/2019 at 9:44 PM, Zunaira said:

I figured it out. I recently bought this laptop and i love watching shows but the video quality was awful and it made no sense considering how great its graphics card is. So i went to the intel graphics command center. I will walk you all through it if you still need the answer. just thought you all might need it too.

Open Intel Graphics Command Center.

Go to the option "Video" 
there you will see 2 video settings (Brighten and darken) along with default.

Click on Brighten and then click custom settings. Cuz both those settings dont fix it but something in the middle does and i figured it out after alot of tampering. 

They used to have a 3rd one and if any of u have a third option (If you havent updated windows it should still be there) then click on that 3rd one and your video quality will be back to normal.

To those who went and did what i did (Update), Put these settings (in the pictures below) as your custom ones and restart your laptop.

Hope it works. Worked for me! 
 

 

Screenshot (1).png

Screenshot (3).png

Screenshot (4).png

Screenshot (5).png

Screenshot (6).png

I have same laptop and same problem. I used your settings but it ended over saturating and over brightening. 

 

Model: GL503ElGE-EN169T

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×