Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
ArkTheYO

FTP Server

Recommended Posts

Posted · Original PosterOP

Hey All,

 i have created a FTP server which seems to work all fine on all the devices on my network but doesnt seem to work on devices outside the network, please help!

P.S.: I have done all the other necessary steps like port forwarding(creatinng port 21 and 20 on my router) and shutting down my antivirus as well as windows firewall! Even created port 21 on firewall ! please please help!

Link to post
Share on other sites

It must be down to your routers firewall, its the only thing that could block it externally (if you have checked with Windows Firewall disabled)

 

Make sure you've forwarded port 21 (no idea why your forwarding 20?) to the IP of the machine that's hosting the server for both outbound and inbound traffic (Generally outbound is allowed via router but I like to do it just to be sure).


Main Rig:-

Ryzen 7 3800X | Asus ROG Strix X570-F Gaming | 16GB Team Group Dark Pro 3600Mhz | Corsair MP600 1TB PCIe Gen 4 | Sapphire 5700 XT Pulse | Corsair H115i Platinum | WD Black 1TB | WD Green 4TB | EVGA SuperNOVA G3 650W | Asus TUF GT501 | Samsung C27HG70 1440p 144hz HDR FreeSync 2 | Windows 10 Pro X64 |

 

Server:-

Intel NUC running Server 2019 + Synology DSM218+ with 2 x 4TB Toshiba NAS Ready HDDs (RAID0)

Link to post
Share on other sites
Posted · Original PosterOP
1 minute ago, Master Disaster said:

It must be down to your routers firewall, its the only thing that could block it externally (if you have checked with Windows Firewall disabled)

 

Make sure you've forwarded port 21 (no idea why your forwarding 20?) to the IP of the machine that's hosting the server for both outbound and inbound traffic (Generally outbound is allowed via router but I like to do it just to be sure).

Hey first of all thanks a lot for replying,

 well yeah i have setup the port with the ip of the machine to that of the host machine, coming onto the the routers firewall i have disabled everything like mac, ip and url filtering, but still it doesnt seem to work when i enter ftp://"the wanip" .

Link to post
Share on other sites
Posted · Original PosterOP
26 minutes ago, Master Disaster said:

It must be down to your routers firewall, its the only thing that could block it externally (if you have checked with Windows Firewall disabled)

 

Make sure you've forwarded port 21 (no idea why your forwarding 20?) to the IP of the machine that's hosting the server for both outbound and inbound traffic (Generally outbound is allowed via router but I like to do it just to be sure).

Hey sorry i know i am causing trouble for u but please please help!

Link to post
Share on other sites
43 minutes ago, ArkTheYO said:

Hey first of all thanks a lot for replying,

 well yeah i have setup the port with the ip of the machine to that of the host machine, coming onto the the routers firewall i have disabled everything like mac, ip and url filtering, but still it doesnt seem to work when i enter ftp://"the wanip" .

What server are you using? Are you sure it's set to port 21?


Main Rig:-

Ryzen 7 3800X | Asus ROG Strix X570-F Gaming | 16GB Team Group Dark Pro 3600Mhz | Corsair MP600 1TB PCIe Gen 4 | Sapphire 5700 XT Pulse | Corsair H115i Platinum | WD Black 1TB | WD Green 4TB | EVGA SuperNOVA G3 650W | Asus TUF GT501 | Samsung C27HG70 1440p 144hz HDR FreeSync 2 | Windows 10 Pro X64 |

 

Server:-

Intel NUC running Server 2019 + Synology DSM218+ with 2 x 4TB Toshiba NAS Ready HDDs (RAID0)

Link to post
Share on other sites
Posted · Original PosterOP
16 minutes ago, Master Disaster said:

What server are you using? Are you sure it's set to port 21?

I created this FTP server using IIS, yes i am sure about it!

Link to post
Share on other sites
Posted · Original PosterOP
34 minutes ago, Master Disaster said:

What server are you using? Are you sure it's set to port 21?

hey sorry but u think any solution?

Link to post
Share on other sites
9 minutes ago, ArkTheYO said:

hey sorry but u think any solution?

No, sorry but I'm not familiar with IIS at all. 


Main Rig:-

Ryzen 7 3800X | Asus ROG Strix X570-F Gaming | 16GB Team Group Dark Pro 3600Mhz | Corsair MP600 1TB PCIe Gen 4 | Sapphire 5700 XT Pulse | Corsair H115i Platinum | WD Black 1TB | WD Green 4TB | EVGA SuperNOVA G3 650W | Asus TUF GT501 | Samsung C27HG70 1440p 144hz HDR FreeSync 2 | Windows 10 Pro X64 |

 

Server:-

Intel NUC running Server 2019 + Synology DSM218+ with 2 x 4TB Toshiba NAS Ready HDDs (RAID0)

Link to post
Share on other sites

http://www.canyouseeme.org/

^^^

Do your external IP and use port 21.

 

If you get 'I could not see your service...', double check the following:

 

  • Local Server
    • IIS Console -> Select your server -> Scroll down the features until you see 'FTP Firewall Support'. Double click it
      • Enter the range of ports you want to accept from the firewall (use something like 49152-65535)
      • Leave the External IP of Firewall blank
    • IIS Console -> Select your FTP Site -> Double click 'FTP Firewall Support'
      • Enter your external IP in there and save
    • Windows Firewall
      • Ensure that on the Private and Public profiles, you have enabled port 21
  • Router
    • Ensure you are forwarding port 21 to the correct IP of your server (FTP non-SSL)

http://www.iis.net/learn/publish/using-the-ftp-service/configuring-ftp-firewall-settings-in-iis-7

 

Another thing to try if you've got all of the above is the following command:

telnet yourExternalIP 21

 

If you receive a connection successful message then the FTP server is set correctly, so could be your FTP client.

 

If that doesn't work, try connecting with FileZilla and then post the console output when you try to connect (the bit under the address/username/password fields)

Link to post
Share on other sites
Posted · Original PosterOP
1 hour ago, BabyPandaaa said:

http://www.canyouseeme.org/

^^^

Do your external IP and use port 21.

 

If you get 'I could not see your service...', double check the following:

 

  • Local Server
    • IIS Console -> Select your server -> Scroll down the features until you see 'FTP Firewall Support'. Double click it
      • Enter the range of ports you want to accept from the firewall (use something like 49152-65535)
      • Leave the External IP of Firewall blank
    • IIS Console -> Select your FTP Site -> Double click 'FTP Firewall Support'
      • Enter your external IP in there and save
    • Windows Firewall
      • Ensure that on the Private and Public profiles, you have enabled port 21
  • Router
    • Ensure you are forwarding port 21 to the correct IP of your server (FTP non-SSL)

http://www.iis.net/learn/publish/using-the-ftp-service/configuring-ftp-firewall-settings-in-iis-7

 

Another thing to try if you've got all of the above is the following command:

telnet yourExternalIP 21

 

If you receive a connection successful message then the FTP server is set correctly, so could be your FTP client.

 

If that doesn't work, try connecting with FileZilla and then post the console output when you try to connect (the bit under the address/username/password fields)

hey if i have to enter my ext. ip address then it shows the message could not connect to the server and connection timeout

Link to post
Share on other sites

Test your ports here:

 

http://www.yougetsignal.com/tools/open-ports/

 

Check what ports are blocked and then make sure your router is configured properly. 

 

Things that could block ports are:

 

A. Windows Firewall - Check

B. Router's Firewall

C. Antivirus

D. ISP port blocking -- some ISPs block ports on purpose.


"Rampage IV" - Gaming PC

Cooler Master HAF 932 Advanced    EVGA GeForce GTX 980                            ASUS VE278H 27in LED Monitor x 3

ASUS Rampage IV Black Edition         G.Skill Trident X 16GB DDR3 2400Mhz     Cooler Master Silent Pro Gold - 1000W

i7 4930k - Overclocked @ 4.5GHz     Samsung 850 SSD 250GB x2 RAID 0           Western Digital Blue 1TB

Logitech G930 Wireless Headset      Razer Naga 2012 MMO Gaming Mouse      Logitech G710+ Mechanical Keyboard

 

"EMCMS-ESXI" - Server

HPZ800 Workstation Chassis           Seagate 4TB NAS Drive x 4 RAID Z           48GB ECC Elpida DDR3 SDRAM

Xeon E5620 @ 2.66GHz x 2             PNY CS2211 240GB SSD                          HP 80 PLUS Silver APFC PSU - 1110W

LSI 9211-8i SAS in IT Mode

Link to post
Share on other sites
Posted · Original PosterOP
2 hours ago, Sevilla said:

Test your ports here:

 

http://www.yougetsignal.com/tools/open-ports/

 

Check what ports are blocked and then make sure your router is configured properly. 

 

Things that could block ports are:

 

A. Windows Firewall - Check

B. Router's Firewall

C. Antivirus

D. ISP port blocking -- some ISPs block ports on purpose.

OK so I have disabled both the antivirus and the windows firewall, the router is provided by the ISP itself and the routers firmware is all the ISP Branding and design and as mentioned above has option for FTP on port forwarding page. Please help up 

Link to post
Share on other sites
11 hours ago, ArkTheYO said:

hey if i have to enter my ext. ip address then it shows the message could not connect to the server and connection timeout

 

Did you follow the rest of the steps I put in my post?

Link to post
Share on other sites
Posted · Original PosterOP
7 minutes ago, BabyPandaaa said:

 

Did you follow the rest of the steps I put in my post?

Yes i did! Perfectly all of them!

Link to post
Share on other sites
Posted · Original PosterOP
10 hours ago, Sevilla said:

Test your ports here:

 

http://www.yougetsignal.com/tools/open-ports/

 

Check what ports are blocked and then make sure your router is configured properly. 

 

Things that could block ports are:

 

A. Windows Firewall - Check

B. Router's Firewall

C. Antivirus

D. ISP port blocking -- some ISPs block ports on purpose.

Well i checked all of them and the result was that all of them were closed :(

Link to post
Share on other sites
5 hours ago, ArkTheYO said:

Well i checked all of them and the result was that all of them were closed :(

So one thing you can test is connect directly to your modem to your PC. This completely takes the router out of the equation. If you can connect through port 20/21, then your router still is blocking it. If you cannot then you should call your ISP and find out if they block out that port.


"Rampage IV" - Gaming PC

Cooler Master HAF 932 Advanced    EVGA GeForce GTX 980                            ASUS VE278H 27in LED Monitor x 3

ASUS Rampage IV Black Edition         G.Skill Trident X 16GB DDR3 2400Mhz     Cooler Master Silent Pro Gold - 1000W

i7 4930k - Overclocked @ 4.5GHz     Samsung 850 SSD 250GB x2 RAID 0           Western Digital Blue 1TB

Logitech G930 Wireless Headset      Razer Naga 2012 MMO Gaming Mouse      Logitech G710+ Mechanical Keyboard

 

"EMCMS-ESXI" - Server

HPZ800 Workstation Chassis           Seagate 4TB NAS Drive x 4 RAID Z           48GB ECC Elpida DDR3 SDRAM

Xeon E5620 @ 2.66GHz x 2             PNY CS2211 240GB SSD                          HP 80 PLUS Silver APFC PSU - 1110W

LSI 9211-8i SAS in IT Mode

Link to post
Share on other sites
Posted · Original PosterOP
32 minutes ago, Sevilla said:

So one thing you can test is connect directly to your modem to your PC. This completely takes the router out of the equation. If you can connect through port 20/21, then your router still is blocking it. If you cannot then you should call your ISP and find out if they block out that port.

ohk so the device prvided by th ISP  is actually both a modem and a router, so should i connect it directly to my PC using the ethernet cable though even i suspect tht the ISP is blocking the port 21 even though they have provided the facility to enable it!

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×