Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
nMeCri

Laptop Power Throttle

Recommended Posts

Posted · Original PosterOP

Last week a friend of mine gave me her Lenovo Laptop for cleaning. So I got this Lenovo V2000 Laptop from 2014 with following specifications:

  - Lenovo Lancer 5A5 Motherboard (Bios Ver. 9BCN29WW from 20th October 2014) [Northbridge: Intel Haswell-ULT IMC, Southbridge: Intel Lynx Point-LP]

  - Intel i7-4510U (2.0 to 3.1 Ghz, 15W TDP)

  - Nvidia GeForce 840M, 4GB Graphics 

  - 1 TB WD HDD 5400RPM

  - Samsung DDR3 1600 8GB Ram

  - Windows 10 Home, Version 2004

 which are quite ok for Zoom meeting and working purposes. So I opened the Laptop, cleaned all the dust, re-paste the CPU and GPU with Arctic MX-4 and changed the thermal pads on the VRAM. 

After all the cleaning I ran some benchmark (Cinebench R20 and XTU Stresstest) to test the machine, but I noticed the Laptop is working strange. 

The CPU temperature under load never go above 70 °C, and power usage stuck at max. 25 Watts, frequency keeps at 2.5-2.6 Ghz, never reached the maximum turbo boost frequency of 3.1 Ghz.

So I downloaded Intel XTU and found out I can not raise the Turbo Boost Power Max above 25 Watts, the adjust bar maxed out at 25 Watts. 

So the CPU is always Power Throttling. 

I tried to look into the BIOS (InsydeH20 Rev 3.7) but I could find nothing which could relate to CPU performance, there's also no "ADVANCED" Tab.

In ThrottleStop I could not change the maximum power settings also.

Is there any method to solve this problem that could apply a higher maximum power to the CPU? 

Some friends told me I could use a 90w power adapter (65W now) or upgrade the HDD to a SSD which demand less power, but I don't think these are relevant to CPU settings.

Link to post
Share on other sites

* Thread moved to the Troubleshooting section *


If you need help with your forum account, please use the Forum Support form !

 

VPN server guide

Introduction to Mechanical Keyboard

Spoiler

My Gaming Rig - Motherboard: MSI Z370-A PRO CPU: i7-8700 RAM: 32GB DDR4 2400(4x8GB) GPU: Gigabyte GTX 1060 3GB OS SSD: 240GB Avexir E100 Storage: 2x 1TB Seagate PSU: Seasonic G650 OS: Windows 10 Pro 64bits Monitor: Acer 21in G205H + Lenovo 21in

 

Link to post
Share on other sites
1 hour ago, nMeCri said:

I noticed the Laptop is working strange.

Your laptop seems to be working correctly. The 4510U is a low power CPU with a 15W TDP rating. Power limit throttling is more common than thermal throttling and is completely normal.

 

The maximum 3.10 GHz turbo speed is only available when 1 core is active. When 2 cores are active, the maximum drops down to 2.80 GHz.

 

Did you try checking the ThrottleStop FIVR - Disable and Lock Turbo Power Limits option? Did you try increasing the Long and Short turbo power limits in the TPL window? Many 4th Gen low power U series CPUs are hard locked to 15W. If you can run at 25W, you are doing better than most.

 

 

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×