Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
lolimpol

MSI RX470 no display

Recommended Posts

Posted · Original PosterOP

I recently bought an MSI RX470 4G, used. I replaced my GT645, but I got no display, I did get display when switching back to the GT645, even with the RX470 in the top PCI-E slot.

 

The fans don't spin but the lights do go on

I tried a different PCI-E slot,

updated the BIOS (MSI 990FXA gaming),

tried resetting the CMOS,

removed all but one RAM stick,

Disabled fast boot,

Tried a different PCI-E-power cable,

 

Something to mention is that the card does the exact same thing without the PCI-E power plugged in, as well as the seller said that it doesn't make contact sometimes, but I've wiggled it about a 100 times :) (connector isn't loose though)

 

My PSU is a Corsair CX600

 

What could be going on here?

Possibly defective DVI?


Specs and peripherals:

Spoiler

Main pc:

Peripherals

Spoiler

2X Acer k222HQL | Logitech G19 | Logitech G300/Logitech MX Master | Logitech X-230 | SONY MDR-RF 810R

Specs:

Spoiler

AMD fx 8350 | 8gb 1600mhz  Crucial Sport | GT 210 <_<,with a gtx 645 | red / black NZXT. S340 | CM seidon 120V V.2 | corsair cx600 | wd 1TB blue X2|

 

Other stuff:

Spoiler

 

Link to post
Share on other sites

It's dead jim or the card cannot load up on that motherboard.


Ryzen 3600 4.33ghz . CM Hyper 212 Turbo. MSI X470 Gaming Plus Max. Crucial Ballistix Sport LT 3200 @ 3200 CL 15 (OC). Powercolor RX 5700XT Red Dragon. FD Meshify S2. Crucial P1 M.2 1TB. Corsair Vengeance 650W 80+ Silver.

 

Core 2 Duo 3.4ghz . WenjuFeng cooler . ASUS P5G41C-M LX . Crucial 1066mhz 3GB DDR2 . Gainward Golden Sample HD 4850 . Coolermaster Elite 430 . Seagate 160GB IDE 7200RPM . BeQuiet System Power 9 400w 80+ Bronze

Link to post
Share on other sites
Posted · Original PosterOP
1 minute ago, F77 said:

It's dead jim or the card cannot load up on that motherboard.

Dead jim?


Specs and peripherals:

Spoiler

Main pc:

Peripherals

Spoiler

2X Acer k222HQL | Logitech G19 | Logitech G300/Logitech MX Master | Logitech X-230 | SONY MDR-RF 810R

Specs:

Spoiler

AMD fx 8350 | 8gb 1600mhz  Crucial Sport | GT 210 <_<,with a gtx 645 | red / black NZXT. S340 | CM seidon 120V V.2 | corsair cx600 | wd 1TB blue X2|

 

Other stuff:

Spoiler

 

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×