Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
YaNoWatDaSayBigDaddyBig...

Keyboard recognizes a held down key as being pressed repeatedly

On 5/15/2019 at 10:32 PM, SydneySideSteveSomewheres said:

Hi @YaNoWatDaSayBigDaddyBig...,

 

It seems that the QuickFire part of the CM Storm can be enabled by pressing the F5-F8 keys and the 'stuttering' you refer to is called the repeat rate, probably yours is set at 8x speed! 🤣🤣🤣

Does it change when you change the profile the keyboard is in with the P1-P4 (dedicated profile) keys?

Does it stop if you select the default profile by pressing the Function and Escape keys?

Does holding Function and F5 and Q for three seconds fix it?

 

Link

How to reset the Quick Fire XTi

 

hope this helps

Nope wasn't the problem. It was set to 1x speed. I think I  have figured it out though if anyone else is having the same problem

If you download the coolker master portal and go into key board settings / light configuration there is a fairly obvious button that allows you to disable Key Repeat Rate. Seemed to fix it for me but ill leave thread open. 

Recommended Posts

Posted · Original PosterOP

So I'm got this problem where when I hold down a key in my new keyboard it acts as if I'm spamming the key. This results in problems in-game when there's a button to display the leader broad and I'm trying to hold down the key to see it but the keyboard acts if I'm spamming the key and so you start to see flickering in the leader broad (as if you were repeatedly pressing the leaderbroad key rather than just holding it down). Similar issues occurs when you need to hold down a the key to speak in-game. 

If I press onthyer key for example w then a w will fix its self and stop stuttering so long as I hold it down.

 

Happens on all keys not just one, drivers are up to date, its not any thing to do with fn+f5 - fn+f8, f+f11 doenst work, not unique to one game.

Not sure any help.



Keyboard: CM Storm QuickFire XTi Mechanical Gaming Keyboard

Link to post
Share on other sites
13 minutes ago, YaNoWatDaSayBigDaddyBig... said:

<snip>

 

Keyboard: CM Storm QuickFire XTi Mechanical Gaming Keyboard

 

Hi @YaNoWatDaSayBigDaddyBig...,

 

It seems that the QuickFire part of the CM Storm can be enabled by pressing the F5-F8 keys and the 'stuttering' you refer to is called the repeat rate, probably yours is set at 8x speed! 🤣🤣🤣

Does it change when you change the profile the keyboard is in with the P1-P4 (dedicated profile) keys?

Does it stop if you select the default profile by pressing the Function and Escape keys?

Does holding Function and F5 and Q for three seconds fix it?

 

Link

How to reset the Quick Fire XTi

 

hope this helps


Those who deny freedom to others deserve it not for themselves (Abraham Lincoln,1808-1865; 16th US president).

Link to post
Share on other sites
Posted · Original PosterOP · Best Answer
On 5/15/2019 at 10:32 PM, SydneySideSteveSomewheres said:

Hi @YaNoWatDaSayBigDaddyBig...,

 

It seems that the QuickFire part of the CM Storm can be enabled by pressing the F5-F8 keys and the 'stuttering' you refer to is called the repeat rate, probably yours is set at 8x speed! 🤣🤣🤣

Does it change when you change the profile the keyboard is in with the P1-P4 (dedicated profile) keys?

Does it stop if you select the default profile by pressing the Function and Escape keys?

Does holding Function and F5 and Q for three seconds fix it?

 

Link

How to reset the Quick Fire XTi

 

hope this helps

Nope wasn't the problem. It was set to 1x speed. I think I  have figured it out though if anyone else is having the same problem

If you download the coolker master portal and go into key board settings / light configuration there is a fairly obvious button that allows you to disable Key Repeat Rate. Seemed to fix it for me but ill leave thread open. 

Link to post
Share on other sites
On 5/18/2019 at 10:51 AM, YaNoWatDaSayBigDaddyBig... said:

Nope wasn't the problem. It was set to 1x speed. I think I  have figured it out though if anyone else is having the same problem

If you download the coolker master portal and go into key board settings / light configuration there is a fairly obvious button that allows you to disable Key Repeat Rate. Seemed to fix it for me but ill leave thread open. 

Good to hear you have the issue sorted out now.


Those who deny freedom to others deserve it not for themselves (Abraham Lincoln,1808-1865; 16th US president).

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×