Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
IsaacThePooper

Graphics card better all the sudden?

Recommended Posts

Posted · Original PosterOP

So I built a system with an RX 570 and it was struggling to run the dumbest games like Roblox and Insurgency, then my friend gave me his GTX 1080 because he was waiting for the rest of his PC to ship. So I popped in it and it worked great! But a few days later I had to give it back to him and put in my old RX 570 back into my system, but this time it was running better than it has ever before! Definitely not as fast as the GTX 1080 but it ran Roblox and Insurgency like a champ!

 

Keep in mind I ran DDU and installed the latest GPU drivers on all 3 graphics card swaps. The RX 570 has been on the same driver version since I built it. 

 

So what happened?

Link to post
Share on other sites
9 minutes ago, IsaacThePooper said:

So what happened?

I don't know hard to say, there's so many things that could've happened to mess up your performance, you should've been aware of the RX 570 performance and tried to diagnose it, but since it's already fixed you'll never know what was causing it

Link to post
Share on other sites

Your PC didn't want to disappoint you after the 1080 gave you high standards.

/S

 

the ol' "unplug and plug it back in" strategy has helped throughout time, usually solving the unknown reasons why hardware doesn't behave. there could be any number of reasons as to why your 570 it wasn't doing what it was supposed to.


I WILL find your ITX build thread, and I WILL recommend the SIlverstone Sugo SG13B

 

Primary PC:

i7 8086k (won) - EVGA Z370 Classified K - G.Kill Trident Z RGB - Force MP500 - Jedi Order Titan Xp - The venerated Hyper 212 Evo (with RGB Riing flair) - EVGA G2 650W - Black and green theme, Razer branwashed me.

Draws 400 watts under max load, for reference.

 

Linux Proliant ML150 G6:

Xeon X5560 - 24GB ECC DDR3 - Asus DirectCU GTX 760 - old Seagate 1.5TB HDD - Dark moded Ubuntu (and Win7, cuz why not)

Link to post
Share on other sites
Posted · Original PosterOP
Just now, _Syn_ said:

I don't know hard to say, there's so many things that could've happened to mess up your performance, you should've been aware of the RX 570 performance and tried to diagnose it, but since it's already fixed you'll never know what was causing it

I just thought it was a slow low-end card that I only payed 100 bucks for.

Link to post
Share on other sites
Posted · Original PosterOP
1 minute ago, Origami Cactus said:

One time i mounted my gpu poorly, and it got like 10fps, then i remounted it properly and all was fine.

Just now, fasauceome said:

the ol' "unplug and plug it back in" strategy has helped throughout time, usually solving the unknown reasons why hardware doesn't behave.

Yeah It's probably just the GPU not sitting right on the PCIe slot, especially since the motherboard is a cheap Chinese "X79" board paired with a $30 Xeon lol

Link to post
Share on other sites
1 minute ago, IsaacThePooper said:

I just thought it was a slow low-end card that I only payed 100 bucks for.

RX 570 is not a low end card, it's a midrange card, and as for Roblox the RX 570 should tear it apart like it's nothing.

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×