Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
PaulVarghese

NIC Teaming Windows 10 (Works)

Recommended Posts

Posted · Original PosterOP

Hi Guys, 

 

So I was able to enable teaming of multiple NIC cards by typing in the following command in Windows PowerShell.

This command was implemented on a Windows 10 Pro 1809 Build (x64bit).

 

The command I used was as follows:

New-NetSwitchTeam -Name "SwitchTeam01" -TeamMembers "Ethernet","Ethernet 2", "Ethernet 3"

Where I replaced "SwitchTeam01" with a name that refers to the teaming of multiple NIC cards and replaced: "Ethernet", "Ethernet 2" etc... with the name of my NIC's as seen on "Control Panel\Network and Internet\Network Connections". 

 

Previously I tried the following commands: 

New-NetLbfoTeam -Name "Team1" -TeamMembers "NIC1","NIC2"
New-NetLbfoTeam -Name "Team1" -TeamMembers "NIC1","NIC2" -TeamingMode LACP

But wasn't able to implement the NIC teaming within the cards as I would constantly receive the following error: 

New-NetLbfoTeam : The LBFO feature is not currently enabled, or LBFO is not supported on this SKU.
At line:1 char:1
+ New-NetLbfoTeam
+ ~~~~~~~~~~~~~~~
    + CategoryInfo          : NotSpecified: (MSFT_NetLbfoTeam:root/StandardCimv2/MSFT_NetLbfoTeam) [New-NetLbfoTeam],
   CimException
    + FullyQualifiedErrorId : MI RESULT 1,New-NetLbfoTeam

Form this I understood that LBFO is not supported in "Windows 10 SKU" but only in "Windows Server". 

Another way to enable NIC Teaming could be to use the "Intel Network Connections Application" and enable Teaming. Unfortunately since I do not have a Intel Network Card this option wast possible for me to test out. 

 

Since I have a Realteck NIC I first uninstalled the drivers and then reinstalled the NIC's with the latest drivers form Realteck. 

Next I checked out the Network Properties of my NIC cards and made sure that "Realtek Teaming Protocol Driver (NDIS 6.40)" was installed. 

 

After this was done I executed the above mentioned command in Power Shell which in turn resulted in the creation of my Teamed NIC Adapter to be visible in "Control Panel\Network and Internet\Network Connections". 

 

Finally the end result of this was that I was able to create on "Microsoft Network Adapter Multiplexor Driver" Adapter that was able to connect to all my other NIC cards at the same time and hence enabling me to have a solid 3Gb/s internet connection. 

 

Teaming.png.18995eaeb9442eff0f99e3d679b336fc.png

 

* Do note that I have removed my DNS name and IPv4 & IPv6 address as I do not want to make that info public but if you carry out the same steps as mentioned above you should end up with the same result. Also note that the box marked in "red" show the network connection speed of the network adapter. 

 

  • This newly created network adapter can then be used for your VM in Hyper-V also. 
  • This will also enable for you to have one static IP address for all your NIC's.
  • Although If you'd prefer to have different static IP addresses for each NIC then its better that you do not follow the above mentioned steps as you will not be able to set individual IP-addressees for each card. 

 

Link to post
Share on other sites

Very cool. I'm assuming this 3Gb/s is either for testing purposes just to say you can, or for moving files on your local network quicker?

Link to post
Share on other sites
Posted · Original PosterOP

Yup its mainly for moving files quicker through my network but also helps me in having a redundant network in the case that something fails. This solution also help me to connect to my VM's quicker while managing their resources remotely and enable me to have a higher local data bandwidth for applications and services that I would like to run locally.

 

I currently have a 1Gb/s UP & DW fiber-optic internet connection hence it also allows for external users to connect the VPN and Servers quicker while allowing them to access their resources even faster. Hence making the average latency between users less than 7ms.

 

So if someone wishes to access large files, system backups quicker or run graphic intensive applications, games or simulations etc.. on the VM's this will enable them to do so with hardly any network lag. 

 

Currently I am using this solution with 1Gb/s NIC but the same can also be done with 10Gb/s, fiber-optic network cards etc... Hence allowing for more bandwidth and higher network speeds between  servers, media solutions, backup servers, remote hosts & clients, vm's, storage solutions, graphic and simulation intensive workloads. 

Link to post
Share on other sites

Hello i am trying to do the same on Windows 10 1809 but with no luck until now.

i get the same error as you

New-NetLbfoTeam : The LBFO feature is not currently enabled, or LBFO is not supported on this SKU.

i have installed Realtek Teaming Protocol Driver (NDIS 6.40) (its NDIS 6.20 in my case) but when i run the command

New-NetSwitchTeam -Name "SwitchTeam01" -TeamMembers "Ethernet","Ethernet 2","Ethernet 3","Ethernet 4","Ethernet 5"

i get the error

New-NetSwitchTeam : The parameter is incorrect.
At line:1 char:1
+ New-NetSwitchTeam -Name "SwitchTeam01" -TeamMembers "Ethernet","Ether ...
+ ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
    + CategoryInfo          : NotSpecified: (MSFT_NetSwitchTeam:root\StandardCimv2\MSFT_NetSwitchTeam) [New-NetSwitchT
   eam], CimException
    + FullyQualifiedErrorId : Windows System Error -2147024809,New-NetSwitchTeam

 

Any other ideas what to do ?

Link to post
Share on other sites
Posted · Original PosterOP

Hi Dantech, 

 

Can you put up a screenshot of your: "Network Adapters" form "Device Manager" and of your Network Connections form: Control Panel\Network and Internet\Network and Sharing Centre and then click on "Change Adapter Settings". 

 

With regards to the code: 

New-NetSwitchTeam -Name "SwitchTeam01" -TeamMembers "Ethernet","Ethernet 2", "Ethernet 3"

You need to run it as an admin on Windows PowerShell where: 

  • SwitchTeam01 = is the name of the NIC team (You can name it anything you want). 
  • "Ethernet","Ethernet 2", "Ethernet 3 = is the name of the name of your Ethernet Adapters (by default they will be named Ethernet, Ethernet 2, Ethernet 3, Ethernet 4 ect ... to the number of NIC's you have installed on your system). 

Also, can you confirm with me that the five Ethernet NIC's you are trying to team are actual physical NIC's and not virtual NIC's, for if they are virtual NIC's it might be better to create a network bridge. Also, you cannot create a team with a NIC if that NIC is already assigned to a virtual switch.

 

Kind Regards, 

Paul 

Link to post
Share on other sites
On 3/7/2019 at 3:33 PM, PaulVarghese said:

Hi Dantech, 

 

Can you put up a screenshot of your: "Network Adapters" form "Device Manager" and of your Network Connections form: Control Panel\Network and Internet\Network and Sharing Centre and then click on "Change Adapter Settings". 

 

With regards to the code: 


New-NetSwitchTeam -Name "SwitchTeam01" -TeamMembers "Ethernet","Ethernet 2", "Ethernet 3"

You need to run it as an admin on Windows PowerShell where: 

  • SwitchTeam01 = is the name of the NIC team (You can name it anything you want). 
  • "Ethernet","Ethernet 2", "Ethernet 3 = is the name of the name of your Ethernet Adapters (by default they will be named Ethernet, Ethernet 2, Ethernet 3, Ethernet 4 ect ... to the number of NIC's you have installed on your system). 

Also, can you confirm with me that the five Ethernet NIC's you are trying to team are actual physical NIC's and not virtual NIC's, for if they are virtual NIC's it might be better to create a network bridge. Also, you cannot create a team with a NIC if that NIC is already assigned to a virtual switch.

 

Kind Regards, 

Paul 

Hello and thanks for your quick response.

Here are the screenshots you asked for

My hardware is the onboard nic of my motherboard and the other is a RTL8111G with 4 gigabit ports on pcie

I run the Powershell as admin.

I tried with and without the VM software installed

If i bridge the nics do i get the same result ? i want to achieve a 5gpbs lan communication with my server where i have the same pcie nic and one onboard that runs Windows Server 2019 and i successfully managed to do nic teaming to.networkadapters.jpg

networkadapters2.jpg

Link to post
Share on other sites
Posted · Original PosterOP

Hi Dantech, 

 

Yha bridging the network adapter should give you the same result, but I am not a 100% sure about that. From your pics, I can't seem to figure out what the issue could be ...

 

I don't know if its an option for you to check the RTL8111G NIC on another PC just to make sure that it works.

 

Secondly, you could also try to remove all the drivers associated with the NIC and try the steps again without installing any drivers to do this you can follow the steps: 

 

1. Go to Device Manager 

2. Select one of the Realtek PCIe GBE Family Controllers 

3. Click on the "X" button at the top bar that says "Uninstall Device".

4. Do this for each of your NICs including you onboard NIC. 

5. Click on the "search of hardware" icon.

6. Try the PowerShell steps again. 

 

Yha do let me know if this works. 

 

Kind Regards,

Paul 

Capture.PNG

Link to post
Share on other sites

Thanks for this, i havent yet tried it as i have never done nic teaming before. My questions is: does hyper v have to be enabled to do this? I have read somewhere that such command would need Hyper V to be enabled. Also as a back up, what do i do if the teaming fails and i want to revert/remove the teaming? is Remove-NetSwitchTeam -Name "x" for that purpose? 

 

Hyper V enabling btw: https://docs.microsoft.com/en-us/virtualization/hyper-v-on-windows/quick-start/enable-hyper-v

Link to post
Share on other sites

I tried this. In network status says it has 2gbps (I use only 2 NICs for teaming, picture below). Also, I have activated LAG on those 2 ports on my Netgear gt784ts switch.

It doesn't work... At all... I have tried two 1 gigabit transfer simultaneous and it capped at ~970mbps, so the speed of the 2 transfers between 2 separate 1 gigabit devices connected directly on the switch halved. 

Did anyone tested this and got positive results?

image.png.d3e0a8647ad99c9e823696dfcc5944de.png

Link to post
Share on other sites

Hey Paul well I am running 1903 it is working fine for me as well. I could not get the team function to show up in Device Manager and I have 2 Intel NICS. Tell your guys to make sure they are in Administrator Power Shell

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×