Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
ZacoAttaco

Screen Flickering in Ubuntu

49 minutes ago, Lukyp said:

That is an old post where amdgpu did not have proper hardware support

I figured it out! I saw a thread suggesting someone to rollback their version of Ubuntu, I restarted the system and then went to advanced start-up, from version:

xxxx.39 -> xxxx.20 and booted the system and everything worked fine straightaway, 0 flicker. Does this mean the latest version of Ubuntu has some issues with certain drivers? Is this common? Thanks for all the help too!

 

EDIT: Wow even all the audio drivers straight up work fine, this seems to be a more stabled version of Ubuntu so I don't know why it served my the 'buggy' version.

 

The highlighted selection is the version I am now running Ubuntu, with Linux 4.15.0-20-generic.

 

So this was a little inconvenient but I'm glad I got it fixed and I'm looking forward to using Ubuntu more.

 

UbuntuRollback.jpg.0bf074aebddf2a22f67fa0b4ad9dec66.jpg

 

EDIT: This suggested fix from @Lukyp worked too.

Quote

"radeon.si_support=0 amdgpu.si_support=1"
You'll need to put those in /etc/default/grub as sudo with an editor you like, like I did in there in GRUB_CMDLINE_LINUX_DEFAULT

 

Recommended Posts

Posted · Original PosterOP

Hey all,

 

EDIT: I'm no longer having issues installing Ubuntu, my main issue is the screen flickering on one of my monitors, I have 3 monitors, 2x on dedicated graphics (R9 280) (HDMI/DVI) and 1 integrated graphics (Intel HD) (VGA). Flickering is occurring on DVI screen, all three work fine in Windows. Scroll to see a more recent post.

 

I've been trying for the last few days to install Ubuntu on a small partition on one of my drives. I'm using a bootable USB and then installing from there.

  • Install has straight up failed multiple times, and then I worked I needed to create a small EFI boot partition because the current partition had no prior operating system.
  • I'm running an R9 280 and the screen flickers through the DVI output but strangely not the HDMI output. So I've been trying to install dedicated AMD Radeon drivers through AMDs website.
  • I would install and then "sudo reboot" but then on restart I run into a command line error.
    • Started GNOME display manager... and deal with any system changes..p link was shut down...

The suggested solution was to now install lightdm as 'temporary solution' as it is a known bug.

 

Something isn't right here, I must be mis

sing something because Linux or at least Ubuntu this distro, wouldn't be as popular as it is if were always buggy and hard to install, so I must be missing something.

 

I'll walk you through my install process.

  1. Boot into Windows and partition my drive to have around 20GB unallocated space.
  2. Use my Ubuntu Bootable and select 'Use Ubuntu without Installing' and then proceed to click install Ubuntu. At this stage the DVI monitor is flickering so I drag relevant windows to my secondary HDMI monitor.
  3. When I arrive at the drive install screen I:
    1. Click "+" and add a 512mb EFI system partition as a Primary file
    2. Click "+" and add a roughly 20GB ext4 file partition with mount point "/"
    3. I select Boot loader as the drive itself
    4. Continue.
  4. Install proceeds and is successful and tells me to reboot. Success!

I run into issues when I try and restart, if the screen is flickering I try and install Radeon Drivers and then I run into issues, doesn't want to boot up properly. This latest changes.pp link was shut down just threw me through a loop. If anyone can help me, I've had about 6 or 7 failed installs in the last 3 days. I don't think they're 'bugs' but just mistakes in the way I'm installing it.

 

I'm calling on the Linux faithful, please help me, before the October updates claims another victim 😮

Sincerely the Resident Linux Noob - Zac.

Link to post
Share on other sites

I'll explain that briefly, the R9 280 defaults on Ubuntu to the old and not supported anymore open source radeon driver (for questionable reasons) and the one you downloaded is the old proprietary fglrx which today is not supported and maintained yet, and won't work unless you use some stone-age Linux distros, you'll probably need to downgrade X.org if you really want to use it, but the better solution is to use the new amdgpu, it's a nonsense they don't use that by default tbh 

The steps required are a bit tricky but I'll try to explain.
If I don't get wrong your is an AMD from the Souther Islands family, and the required kernel parameter to enable the correct amdgpu driver are "radeon.si_support=0 amdgpu.si_support=1"
You'll need to put those in /etc/default/grub as sudo with an editor you like, like I did in there in GRUB_CMDLINE_LINUX_DEFAULT
image.png.f390b487a1db9fbe6c1dabdc155ae9cc.png
(Don't mind the other kernel parameters I have, just put the ones you need separated by spaces)
Then do update-grub as sudo
Be sure also to have installed the linux-firmware package, the xserver-xorg-video-amdgpu package, and absolutely delete the amd driver you installed before!

Now, I can't however know if this is gonna work or not. I don't have an amd gpu since ages but if that won't work anyway is probably because the radeon driver is still loaded, if that still happens try modifying /etc/initramfs-tools/modules and add amdgpu in a line, and radeon in the line after. Then do the update-initramfs -u command as root then reboot.
 If still that doesn't work, try removing the radeon line and do another update-initramfs -u and reboot.

Link to post
Share on other sites
Posted · Original PosterOP
33 minutes ago, Lukyp said:

I'll explain that briefly, the R9 280 defaults on Ubuntu to the old and not supported anymore open source radeon driver (for questionable reasons) and the one you downloaded is the old proprietary fglrx which today is not supported and maintained yet, and won't work unless you use some stone-age Linux distros, you'll probably need to downgrade X.org if you really want to use it, but the better solution is to use the new amdgpu, it's a nonsense they don't use that by default tbh

I have an update, successful install on Ubuntu on third drive no problems.

 

I installed it with only the HDMI plugged in. Now when I plugged in DVI and my integrated gpu on VGA all three displays come up but DVI display is still flickering. If I then in Ubuntu, disable all other displays and only leave DVI display it works fine! Then I add both other ones back and is still works fine!

 

So for some reason, on boot, it can't handle all three display at once, but if you start with only one display, the problem display and then add others it works fine. So I have found 'work around' but it's really not ideal and makes me wonder if it is a driver issue or something else...

Link to post
Share on other sites
6 minutes ago, ZacoAttaco said:

I have an update, successful install on Ubuntu on third drive no problems.

 

I installed it with only the HDMI plugged in. Now when I plugged in DVI and my integrated gpu on VGA all three displays come up but DVI display is still flickering. If I then in Ubuntu, disable all other displays and only leave DVI display it works fine! Then I add both other ones back and is still works fine!

 

So for some reason, on boot, it can't handle all three display at once, but if you start with only one display, the problem display and then add others it works fine. So I have found 'work around' but it's really not ideal and makes me wonder if it is a driver issue or something else...

It probably is, radeon has never been a good driver, on the other and you might give amdgpu a try, it makes a noticeable difference in games

 

https://www.phoronix.com/scan.php?page=article&item=amdgpu-radeon-415&num=3

Link to post
Share on other sites
Posted · Original PosterOP
6 minutes ago, Lukyp said:

It probably is, radeon has never been a good driver, on the other and you might give amdgpu a try, it makes a noticeable difference in games 

 

https://www.phoronix.com/scan.php?page=article&item=amdgpu-radeon-415&num=3

Ok, at some stage I will try the above fix and when I do I'll get back to you with the results. Also, how do I delete the old, pre-existing Radeon drivers?

Link to post
Share on other sites
2 minutes ago, ZacoAttaco said:

Ok, at some stage I will try the above fix and when I do I'll get back to you with the results. Also, how do I delete the old, pre-existing Radeon drivers?

Don't know exactly but if it's working then you shouldn't worry about it 

 

https://askubuntu.com/questions/78675/how-do-i-remove-the-fglrx-drivers-after-ive-installed-them-by-hand

 

Here they say to use the script and apt

Link to post
Share on other sites
14 hours ago, ZacoAttaco said:

Ok, at some stage I will try the above fix and when I do I'll get back to you with the results. Also, how do I delete the old, pre-existing Radeon drivers?

If your retrying to the old free driver, just blacklist it.  If you installed fglrx- you should uninstall that. 

Link to post
Share on other sites
Posted · Original PosterOP

Well, to update again, this morning I've tried to boot into Ubuntu, I'm granted with:

 fsck exited with status code 8

and before that I see error code

Invalid PCI ROM header signature: expecting 0xaa55, got 0xffff

The above sources indicate that the PCI ROM header error is a 'bug' and the first one is solved with reinstalling, I have reinstalled multiple times and still see this error...

 

EDIT: Is Ubuntu one of the more buggy distros? Is there another operating system that would be better to start out with?

 

What's funny is I run Ubuntu in VMware as a Virtual Machine and it runs flawless but when it try and fully install I'm running into issues. I guess it's something to do with the VMware translation layers being so great.

Link to post
Share on other sites

@ZacoAttaco Ubuntu is generally a very stable distro, but if your hardware doesn't care for it; I recommend Mageia or OpenSuse Leap.  If you want to stay debian based, there's SolydX/K

 

I run Fedora myself

Link to post
Share on other sites
Posted · Original PosterOP

Thanks @jpenguin , I'm persevering with Ubuntu for the time being, as you say it is one of the more stable distros.

 

Ok, so I've reinstalled again and I'm wondering if I'm maybe making a mistake by editing the label through MiniTool Partition Wizard. I've been trying to organize my partitions by labeling them butt they could be messing with the boot partitions. So I'm going to leave that and see how I go.

 

Still experience issues with multiple monitors running out of the R9 280 but that's something I can workout as long as the system remains stables and will actually boot. So all being well I can then tackle the display issues.

 

So far so good.

Link to post
Share on other sites
Posted · Original PosterOP

Ok so I worked out my issue with the

fsck status code 8

this was because I was editing the labels for the EFI partition and the ext4 partition. Silly me.

 

So I'm actually typing this post in Ubuntu! Now it's just this annoying secondary display.

 

Here's my set up:

  • LG TV Monitor running HDMI (works/dedicated graphics)
  • VGA Generic Lenovo (works/integrated graphics)
  • DVI Generic Lenovo (not working/dedicated graphics)

Could it be a PSU issue? It doesn't like displaying more than one monitor out of the 280. With the LG disabled, the DVI works mostly fine, although it will flicker every 2 minutes or so. My PSU is an Aerocool VX-650W, so it's not great. But it works fine in Windows so it could be some driver issues.

 

When I tried @Lukyp's solution, I went to /etc/default but it said grub/: Not a directory

 

Sorry, I'm sure it seems like we're going in circles here but progress is happening, thanks.

Link to post
Share on other sites

I would recommend trying kernel parameters from within grub (the e key), before putting them in /etc/default/grub

 

When you confirmed that they work, the command you want is

sudo nano /etc/default/grub

 

Side note: enable SSH

Link to post
Share on other sites
Posted · Original PosterOP
On 11/27/2018 at 11:40 AM, Lukyp said:

If I don't get wrong your is an AMD from the Souther Islands family, and the required kernel parameter to enable the correct amdgpu driver are "radeon.si_support=0 amdgpu.si_support=1"
You'll need to put those in /etc/default/grub as sudo with an editor you like, like I did in there in GRUB_CMDLINE_LINUX_DEFAULT

I tried this, unfortunately I'm still seeing issues, Ubuntu install is working fine, just having trouble with multiple monitors, the DVI is the problem because I see no flickers on the HDMI screen.

On 11/28/2018 at 2:26 PM, jpenguin said:

I would recommend trying kernel parameters from within grub (the e key), before putting them in /etc/default/grub

 

When you confirmed that they work, the command you want is

 


sudo nano /etc/default/grub

 

 

Side note: enable SSH

Not sure what you mean by 'kernel parameters' sorry.

 

I can run the sudo nano command but I don't want to until I'm sure I know what I'm doing.

Link to post
Share on other sites
4 minutes ago, ZacoAttaco said:

I tried this, unfortunately I'm still seeing issues, Ubuntu install is working fine, just having trouble with multiple monitors, the DVI is the problem because I see no flickers on the HDMI screen.

Not sure what you mean by 'kernel parameters' sorry.

 

I can run the sudo nano command but I don't want to until I'm sure I know what I'm doing.

type "lspci -vv | grep amdgpu" to ensure the driver is loaded correctly 
 

Link to post
Share on other sites
Posted · Original PosterOP
1 minute ago, Lukyp said:

type "lspci -vv | grep amdgpu" to ensure the driver is loaded correctly 
 

Where am I typing this, within grub or just a standard terminal window?

Link to post
Share on other sites
1 minute ago, ZacoAttaco said:

Where am I typing this, within grub or just a standard terminal window?

Terminal window, I don't know what you did currently but you should also have updated grub via "update-grub" 

Link to post
Share on other sites
Posted · Original PosterOP
3 minutes ago, Lukyp said:

Terminal window, I don't know what you did currently but you should also have updated grub via "update-grub" 

Yes I did, I ran:

sudo update-grub

I found this thread helpful but it didn't solve my problem unfortunately.

https://askubuntu.com/questions/1029517/amd-rx480-screen-flicker-after-update-to-18-04

Link to post
Share on other sites
Posted · Original PosterOP · Best Answer
49 minutes ago, Lukyp said:

That is an old post where amdgpu did not have proper hardware support

I figured it out! I saw a thread suggesting someone to rollback their version of Ubuntu, I restarted the system and then went to advanced start-up, from version:

xxxx.39 -> xxxx.20 and booted the system and everything worked fine straightaway, 0 flicker. Does this mean the latest version of Ubuntu has some issues with certain drivers? Is this common? Thanks for all the help too!

 

EDIT: Wow even all the audio drivers straight up work fine, this seems to be a more stabled version of Ubuntu so I don't know why it served my the 'buggy' version.

 

The highlighted selection is the version I am now running Ubuntu, with Linux 4.15.0-20-generic.

 

So this was a little inconvenient but I'm glad I got it fixed and I'm looking forward to using Ubuntu more.

 

UbuntuRollback.jpg.0bf074aebddf2a22f67fa0b4ad9dec66.jpg

 

EDIT: This suggested fix from @Lukyp worked too.

Quote

"radeon.si_support=0 amdgpu.si_support=1"
You'll need to put those in /etc/default/grub as sudo with an editor you like, like I did in there in GRUB_CMDLINE_LINUX_DEFAULT

 

Link to post
Share on other sites
17 minutes ago, ZacoAttaco said:

I figured it out! I saw a thread suggesting someone to rollback their version of Ubuntu, I restarted the system and then went to advanced start-up, from version:

xxxx.39 -> xxxx.20 and booted the system and everything worked fine straightaway, 0 flicker. Does this mean the latest version of Ubuntu has some issues with certain drivers? Is this common? Thanks for all the help too!

 

EDIT: Wow even all the audio drivers straight up work fine, this seems to be a more stabled version of Ubuntu so I don't know why it served my the 'buggy' version.

Uhm... I don't know exactly whats going on so I can't tell

"advanced startup" actually has different kernels on it, there is no downgrade

Try again the newer kernel, maybe the driver was not loaded before? 

Link to post
Share on other sites
Posted · Original PosterOP
1 minute ago, Lukyp said:

Uhm... I don't know exactly whats going on so I can't tell

"advanced startup" actually has different kernels on it, there is no downgrade

Aren't I now running an older version of the kernel though?

Link to post
Share on other sites
2 minutes ago, ZacoAttaco said:

Aren't I now running an older version of the kernel though?

Yes but the changes are very minor, I doubt an huge issue or bug comes out from nowhere, just to be sure try starting that other kernel again from advanced options 

Link to post
Share on other sites
Posted · Original PosterOP
5 minutes ago, Lukyp said:

Yes but the changes are very minor, I doubt an huge issue or bug comes out from nowhere, just to be sure try starting that other kernel again from advanced options 

Well dang, you're right. The issues are now gone on my 4.15.0-39 generic Install...

 

The grub still has the fix you mentioned so I'm guessing that had a part to do with the fix.

On 11/27/2018 at 11:40 AM, Lukyp said:

"radeon.si_support=0 amdgpu.si_support=1"

So now I don't really know how it was fixed...

Link to post
Share on other sites
11 minutes ago, ZacoAttaco said:

Well dang, you're right. The issues are now gone on my 4.15.0-39 generic Install...

 

The grub still has the fix you mentioned so I'm guessing that had a part to do with the fix.

So now I don't really know how it was fixed...

Yea is as I imagined... 
Maybe you forgot to run update-grub for some reason? or amdgpu.dc=0 solved the issue? 

That kernel parameters are for enabling the new amdgpu driver and disable the old radeon one, which had the "flickering" issues you mentioned before, don't know this last one.

If you now run games, you will notice they'll run so much better and faster.

To see the currently running kernel parameters: "cat /proc/cmdline" on a terminal
 

Link to post
Share on other sites
Posted · Original PosterOP
3 minutes ago, Lukyp said:

Yea is as I imagined... 
Maybe you forgot to run update-grub for some reason? or amdgpu.dc=0 solved the issue

That kernel parameters are for enabling the new amdgpu driver and disable the old radeon one, which had the "flickering" issues you mentioned before, don't know this last one.

If you now run games, you will notice they'll run so much better and faster.

To see the currently running kernel parameters: "cat /proc/cmdline" on a terminal
 

Well I manually restarted Ubuntu and I ran sudo reboot but I think you're right I must have just not restarted it correctly to implement the changes, because when it loaded version 0-20 it worked. I'm still very new to Linux so I probably made the mistake.

 

I don't plan on running games on Ubuntu at the moment but I'll keep this mind.

 

Thanks for all the help, very appreciated 😄

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Buy VPN

×