Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

Problems with windows 10 time

 Share

Hello, I saw a Linus video on YouTube recently about windows 10 computers and how they set their time. As I have been having issues recently with my own computers time and no one else has been able to do anything about it, I thought I might as well try here. So when ever I try to set my windows 10 machine to "set time automatically" it jumps my time about 12 hours forward than my actual EST time. It also automatically set my time zone to Beijing, China, even though I live in the south east United States, and have never taken my computer out of country. I believe it is doing this due to a network issue, as the same problem has happened to every other windows 10 device that connects to this internet. We tried replacing the router, but the replacement does the same thing. What I guess I'm asking is does anyone know how to make my computer realise that it is not actually in China, because when I access certain sites, like my online school for example, it thinks I'm 12 hours ahead and I lose my chance to submit my papers. I have my time set manually now, but the network seems to affect where websites think I am. I realise I started rambling a bit in this post, so if there is anything you need me to clear up, I would be more than happy to. Thank you for any help.

Link to comment
Share on other sites

Link to post
Share on other sites

The method that various services, including Windows's clock-thingy, use to determine where you are located is called "geolocation." There's not much you can do about it, it's your ISP's job: you should contact them, explain that all geolocation-services, including Windows's own, think you are located in China instead of the U.S., and you'd like for them to examine why this is. It could be related to the recent news about how a lot of U.S.- and Canada-traffic has been routed through China.

Hand, n. A singular instrument worn at the end of the human arm and commonly thrust into somebody’s pocket.

Link to comment
Share on other sites

Link to post
Share on other sites

@Day Fish try checking your "Outlook" settings.

 

Outlook controls calender and emails, see what servers it is referring to and if you cant you may need to talk to microsoft support to fix it. 

current main system:

motherboard : AMD FX 8320

ram : 16Gig

OS : Linux Mint 20 xfce kernel 5.4.0-26

Video Card : RX 550 4 GIG

Monitor: BENQ 21 inch

 

Desperately needs an updated system :(

Link to comment
Share on other sites

Link to post
Share on other sites

Thanks for the tip, M.Yurizaki, but that site tells me my IP is going through D.C, which should be right, it is just the other websitesand my computer that seem to be getting it wrong. I will look into my outlook settings, and if that doesn't work, I guess I will just have to talk with my ISP again. Thanks for the tips.

Link to comment
Share on other sites

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share


×