Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

RTX 2080 BF1 LOW FPS

Cemil2565
 Share

I have gigabyte Windforce rtx 2080 but bf1 50fps max settings cpu i5 7600,8gb ram 2666,ssd860evo 500gb, what do i need to upgrade?

Link to comment
Share on other sites

Link to post
Share on other sites

your cpu and ram aren't quite on par with that gpu

but check what the actual bottleneck is first

Link to comment
Share on other sites

Link to post
Share on other sites

18 hours ago, Daniel644 said:

FPS numbers are meaningless if they aren't explained with RESOLUTION and graphics settings.

Agreed.

 

50 fps might mean a CPU bottleneck but at higher resolution, it may not be the case.

 

Have you tried running Display Driver Uninstaller and doing a fresh install of drivers to see if anything changes? It's free and easy.

Link to comment
Share on other sites

Link to post
Share on other sites

On 10/16/2018 at 7:01 AM, Daniel644 said:

FPS numbers are meaningless if they aren't explained with RESOLUTION and graphics settings.

Exactly! TS, please let us know what res and ingame setting you have set. IF you're playing at 1080P, try 720P and see if you gain any frames, if not, then it's possible that your CPU's the bottleneck (seriously doubt this tho). 

Rig 1: AMD AM4 R9 3900X (12C/24T) + Tt Water 3.0 ARGB 360 AIO | Gigabyte X570 Aorus Xtreme | 16GB Patriot Viper RGB 3600CL17 | Sapphire Nitro+ RX 6900 XT | 256GB Sabrent Rocket NVMe PCIe M.2 (OS) | 4TB Samsung 860 EVO SSD + 2TB 860 QVO SSD + 2x 1TB 850 EVO + 6TB WD Black HDD | CoolerMaster H500M | Corsair HX1000 Platinum | Ducky Shine 4 69 Fire + Logitech G703 | iFi Micro iDSD Black Label | LG SL8YG | C49HG90DME 49" 32:9 144Hz Freesync 2 | Omnidesk Pro 2020 48" | 64bit Win10 Pro

Rig 2: Intel i7 3960X (6C/12T) | Asus R4E | 16GB Corsair Dom Plat 2133mhz | PC RX VEGA 64 Red Devil | iOppo HA-1 | Philips HTL9100 | Caselabs M8 | Seasonic X-1250 | Mistel Barocco MD770 RGB + Logitech G402 | Samsung Acer XR341CK 21:9 75Hz Freesync | 64bit Win10 Pro

HTPC Rig: Intel i7 4770K (4C/8T) | MSI Z87 G45 Gaming | 16GB RipJawsZ 1600mhz | Leadtek GTX 1080 Hurricane OC | Fostex HPA4 | Philips B97/98 | Tt View 31 | Corsair HX-1050 | Logitech G613 + G603 | Panasonic 65" UHD TV | 64bit Win10 Pro

 

 

 

 

 

Link to comment
Share on other sites

Link to post
Share on other sites

On 10/15/2018 at 6:03 PM, Cemil2565 said:

max settings

Your first issue for just 50 fps.

On 10/15/2018 at 6:03 PM, Cemil2565 said:

cpu i5 7600

Your issue with max settings.

On 10/15/2018 at 6:03 PM, Cemil2565 said:

8gb ram 2666

Your necessary upgrade is right here. Add 1 stick of 8GB ram to total 16GB of ram. This will help out tremendously with that i5 and no, you do not need to upgrade your CPU. I run BF1 flawlessly with an i5 weaker than yours and a GTX 1070 GPU. But I also optimize not only the games I play, but my PC in general.

 

If you want a quick boost to your fps, just turn down the following settings in BF1. And trust me, you won't lose much visual fidelity from doing this in BF1.

 

Motion Blur - 0%

Weapon DOF - OFF

Chromatic Abberation Effect - OFF

Film Grain - OFF

Lens Distortion Effect - OFF

DX12 Enabled - OFF

 

Lighting Quality - Low

Post Process Quality - Low

Antialiasing Post - TAA

Ambient Occlusion - OFF

 

Everything else you can leave on ULTRA.

 

Here are a few more things you can do right now to get much better performance.

 

  • Go into Origin and right-click Battlefield 3, then select properties and uncheck the box to eliminate Origin In-Game Overlay.
  • Click on the Start menu in the bottom left hand corner of your PC and go into your settings. Then click on Power & Sleep. Then click on Additional Power Settings. Then click on High Performance. Apply the setting if given the option. Close out everything.
  • Right click on your desktop and click on NVidia Control Panel. Then click on Manage 3D Settings. Under Global Settings, look for Power Management Mode. Click on it and then click on Prefer Maximum Performance. Apply the setting(wait about 3-10 seconds after the click). Close out everything.

Let me know what fps you are getting from this if you can. It should be well above 50 fps. Especially if you are running the game in 1080p. Once you know the fps you're getting with these settings, it's wise to cap your frames with MSI Afterburner to keep your CPU from bottlenecking. I get a little over 100 fps in 1440p with my rig so I choose to cap my fps at 85-90 to keep my CPU from bottlenecking. It also keeps it cool as a cucumber.

Link to comment
Share on other sites

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share


×