Jump to content

Driver for my Printer

LawrenceBarnes2013
 Share

it's an Epson CX4300, i googled it but the results were conflicted the least to be said, it says it's a driver zipped file but during the setup, Vergin mega store setup comes in and the setup is done, but the driver ain't installed, if someone could just give me link or something for where i can get a proper Driver

 Crust : Intel Core i5 4690K @ 4.4Ghz 1.45v  |  MotherboardMSI Z97 MPower  |  Fruity FillingMSI GTX 960 Armor 2Way-SLI |  CoolingNoctua NH-D15  |  RAM : 16GB Corsair Vengeance 1600Mhz | Storage : 2xSamsung 840 EVO 500GB SSDs Raid-0  |  Power Supply : Seasonic X-Series 1250W 80+Gold  |  Monitor : Dell U2713HM 27" 60Hz 1440p  |                                                                                                                                           

Link to comment
Share on other sites

Link to post
Share on other sites

NEW PC build: Blank Heaven   minimalist white and black PC     Old S340 build log "White Heaven"        The "LIGHTCANON" flashlight build log        Project AntiRoll (prototype)        Custom speaker project

Spoiler

Ryzen 3950X | AMD Vega Frontier Edition | ASUS X570 Pro WS | Corsair Vengeance LPX 64GB | NZXT H500 | Seasonic Prime Fanless TX-700 | Custom loop | Coolermaster SK630 White | Logitech MX Master 2S | Samsung 980 Pro 1TB + 970 Pro 512GB | Samsung 58" 4k TV | Scarlett 2i4 | 2x AT2020

 

Link to comment
Share on other sites

Link to post
Share on other sites

As @Enderman said, we would need to know your OS to find you a driver.

Did you try any of the drivers from the link above yet? what exactly is the problem you encountered?

"PSU brands are meaningless, look up the OEM."

Link to comment
Share on other sites

Link to post
Share on other sites

ther very site i got the conflicted driver from, sorry man, any other ideas

 Crust : Intel Core i5 4690K @ 4.4Ghz 1.45v  |  MotherboardMSI Z97 MPower  |  Fruity FillingMSI GTX 960 Armor 2Way-SLI |  CoolingNoctua NH-D15  |  RAM : 16GB Corsair Vengeance 1600Mhz | Storage : 2xSamsung 840 EVO 500GB SSDs Raid-0  |  Power Supply : Seasonic X-Series 1250W 80+Gold  |  Monitor : Dell U2713HM 27" 60Hz 1440p  |                                                                                                                                           

Link to comment
Share on other sites

Link to post
Share on other sites

ther very site i got the conflicted driver from, sorry man, any other ideas

did you choose the right (32 or 64 bit ) OS and picked the top driver?

NEW PC build: Blank Heaven   minimalist white and black PC     Old S340 build log "White Heaven"        The "LIGHTCANON" flashlight build log        Project AntiRoll (prototype)        Custom speaker project

Spoiler

Ryzen 3950X | AMD Vega Frontier Edition | ASUS X570 Pro WS | Corsair Vengeance LPX 64GB | NZXT H500 | Seasonic Prime Fanless TX-700 | Custom loop | Coolermaster SK630 White | Logitech MX Master 2S | Samsung 980 Pro 1TB + 970 Pro 512GB | Samsung 58" 4k TV | Scarlett 2i4 | 2x AT2020

 

Link to comment
Share on other sites

Link to post
Share on other sites

As @Enderman said, we would need to know your OS to find you a driver.

Did you try any of the drivers from the link above yet? what exactly is the problem you encountered?

i'm using WIn7, yes i did, epson support was the first tha popped to mind, but, something is wrong withe the driver from there

 Crust : Intel Core i5 4690K @ 4.4Ghz 1.45v  |  MotherboardMSI Z97 MPower  |  Fruity FillingMSI GTX 960 Armor 2Way-SLI |  CoolingNoctua NH-D15  |  RAM : 16GB Corsair Vengeance 1600Mhz | Storage : 2xSamsung 840 EVO 500GB SSDs Raid-0  |  Power Supply : Seasonic X-Series 1250W 80+Gold  |  Monitor : Dell U2713HM 27" 60Hz 1440p  |                                                                                                                                           

Link to comment
Share on other sites

Link to post
Share on other sites

did you choose the right (32 or 64 bit ) OS and picked the top driver?

Yes .

 Crust : Intel Core i5 4690K @ 4.4Ghz 1.45v  |  MotherboardMSI Z97 MPower  |  Fruity FillingMSI GTX 960 Armor 2Way-SLI |  CoolingNoctua NH-D15  |  RAM : 16GB Corsair Vengeance 1600Mhz | Storage : 2xSamsung 840 EVO 500GB SSDs Raid-0  |  Power Supply : Seasonic X-Series 1250W 80+Gold  |  Monitor : Dell U2713HM 27" 60Hz 1440p  |                                                                                                                                           

Link to comment
Share on other sites

Link to post
Share on other sites

ther very site i got the conflicted driver from, sorry man, any other ideas

Depending on your OS you may be able to extract the files from inside the setup (WinRAR or 7Zip will work, I just tested these) then install the driver from Device Manager, as in this guide:

http://www.sevenforums.com/tutorials/97061-driver-install-device-manager.html

Navigate to the main folder when it asks where the drivers are and it should probably detect them and install them.

"PSU brands are meaningless, look up the OEM."

Link to comment
Share on other sites

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share


×