Jump to content

AsRock B450M Steel Legend boots back to UEFI with CSM Disabled

Ok guys, i tried to disable CSM on my mobo in order to enable Above 4G decoding and RE-Sizable BAR, something i did many times before on other similar boards, but this time it doesn't want to boot into Windows and brings me back straight to the main page of the UEFI w/o me pressing F2 or DEL. I tried disabling it, then enabling both option, then enabling CSM again, but when i boot into Windows, SAM on my RX 6900 XT is "unavailable". GPUz says that these option are disabled in BIOS. When i go back to BIOS they stay enabled, but they are grayed out like inactive options, until i disable CSM again. BIOS is the latest version and i have done this exact thing many times before on other B450 and B550 motherboards and never had any problem logging into Windows with CSM disabled. What is going on?

P.S

Ok i think i found out the culprit. For some reason my system drive is on MBR instead of GPT and for even weirder reasons, i can't convert it. Looks like another full system install is incoming 馃槙

| Ryzen 7 5800X3D | EVGA CLC 280 RGB | AsRock B450M Steel Legend聽|

| 2x8GB A-Data 3200MHz CL16 |聽Sapphire Nitro+ RX 6900 XT |聽Seasonic Focus GX-1000|

| 512GB A-Data XPG Spectrix S40G RGB |聽4TB WD Caviar Black+250GB Samsung Evo 870 Cache |聽Deepcool Matrexx 70 |

Link to comment
Share on other sites

Link to post
Share on other sites

Google it, there should be plenty of tools to convert to GPT without a full reinstall.

Link to comment
Share on other sites

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now