Jump to content

Logitech HD Webcam C270 seems DEAD. What can I do to verify this, test it? Help?

Logitech HD Webcam C270

LOGITECH's own website seems to be no help at all. They seem to only offer firmware and software for cameras bought recently. I've tried the Logitech HD Webcam C270 in VLC as a capture device and no image appears.

 

Can someone tell me of other software that I can try to see if this Logitech HD Webcam C270 works?

Or some troubleshooting, or just a clue?

 

Thanks yaw:old-sad:

Link to comment
Share on other sites

Link to post
Share on other sites

30 minutes ago, RaputerXpert said:

Logitech HD Webcam C270

LOGITECH's own website seems to be no help at all. They seem to only offer firmware and software for cameras bought recently. I've tried the Logitech HD Webcam C270 in VLC as a capture device and no image appears.

 

Can someone tell me of other software that I can try to see if this Logitech HD Webcam C270 works?

Or some troubleshooting, or just a clue?

 

Thanks yaw:old-sad:

What does device manager show? Or windows built in Camera app?

Link to comment
Share on other sites

Link to post
Share on other sites

21 minutes ago, Blue4130 said:

What does device manager show? Or windows built in Camera app?

Tell me where/how about Windows built in camera app?

Link to comment
Share on other sites

Link to post
Share on other sites

Open the start menu and scroll to the app called camera. 

Link to comment
Share on other sites

Link to post
Share on other sites

12 hours ago, RaputerXpert said:

Can someone tell me of other software that I can try to see if this Logitech HD Webcam C270 works?

Or some troubleshooting, or just a clue?

I have several of these, and they just work in Linux. If you want to try and eliminate Windows / Drivers / Software issues, you could boot something like Linux Mint from a USB, then install something like Cheese from Synaptic Package manager. If the camera works in Cheese, it's a Windows issue. 

Link to comment
Share on other sites

Link to post
Share on other sites

  • 2 weeks later...

Google searched. Found a Registry entry and added it. Immediately the Camera was recognized, and this was without the need for new drivers or anything else.

Amazing how that registry is like the fountain of youth.

 

Thanks to all who took the time to help me🤗

Link to comment
Share on other sites

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share


×