Jump to content

Problems getting Blender to actually use my GPU during rendering

I've set my engine to GPU compute and changed preferences so that blender should be running with optix on my 3090TI and yet Blender seems to enjoy continually torturing my CPU with upwards of 60% utilization during renders while my GPU sits at 20% and my vram usage is at 3% max. Is this the best that blender can do with my hardware or am I missing some steps/settings/drivers here? Also, is there some way to force Blender to use my GPU instead of my CPU when it's building proxies?

Current PC:

  • CPU
    Intel i9-12900KS
  • Motherboard
    Asus Rog Maximus Z690 Hero
  • RAM
    G.Skill Trident Z5 DDR5-6400; 2 x (16GB x 2); CL32-39-39-102; 1.40 V
  • GPU
    Aorus Xtreme Waterforce RTX 3090 TI
  • Case
    Corsair 7000D Airflow
  • Storage
    2 x 2TB WD Black sn850 SSDs
  • PSU
    EVGA Supernova 1600W P2, Fully Modular
  • Display(s)
    34" 1900R Alienware AW3418DW Black, 32" Samsung Odyssey G7 240Hz
  • Cooling
    Arctic Liquid Freezer ii 420, Built in 360mm gpu rad, 7 x 140mm Noctua NF-A14's (4 used as full case fan set, 3 used to upgrade CPU rad fans), 4 x 120mm Noctua NF-F12's (3 used to upgrade GPU rad stock fans, 1 used to fill last remaining case fan slot)
  • Keyboard
    Fidio Mechanical Gaming Keyboard
  • Mouse
    Asus Rog Spatha X
  • Sound
    SteelSeries Arctis Pro + Game DAC Wired Headset
  • Operating System
    Windows 11 Pro
  • PCPartPicker URL

 

Link to comment
Share on other sites

Link to post
Share on other sites

Using optix my 3090 ti is at 94% and 5900x is at 13%.

 

I just have optix selected in preferences and under denoise viewport and denoise render. 

 

I am not a Blender expert since I mainly used 3DMax in my work. I just have it on the system for testing.

RIG#1 CPU: AMD, R 9 5900X| Motherboard: X570 AORUS Master | RAM: Corsair Vengeance RGB Pro 32GB DDR4 3200 | GPU: EVGA FTW3 ULTRA  RTX 3090 ti | PSU: EVGA 1000 G+ | Case: Lian Li O11 Dynamic | Cooler: EK 360mm AIO | SSD#1: Corsair MP600 1TB | SSD#2: Crucial MX500 2.5" 2TB | Monitor: LG 55" 4k B9 OLED TV

 

RIG#2 CPU: Intel i9 11900k | Motherboard: Z590 AORUS Master | RAM: Corsair Vengeance RGB Pro 32GB DDR4 3600 | GPU: EVGA FTW3 ULTRA  RTX 3090 ti | PSU: EVGA 1300 G+ | Case: Lian Li O11 Dynamic EVO | Cooler: Noctua NH-D15 | SSD#1: SSD#1: Corsair MP600 1TB | SSD#2: Crucial MX300 2.5" 1TB | Monitor: LG 55" 4k B9 OLED TV

 

RIG#3 CPU: Intel i9 10900kf | Motherboard: Z490 AORUS Master | RAM: Corsair Vengeance RGB Pro 32GB DDR4 4000 | GPU: MSI Gaming X Trio 3090 | PSU: EVGA 1000 G+ | Case: Lian Li O11 Dynamic | Cooler: EK 360mm AIO | SSD#1: Crucial P1 1TB | SSD#2: Crucial MX500 2.5" 1TB | Monitor: LG 55" 4k C1 OLED TV

 

RIG#4 CPU: Intel i9 9900k | Motherboard: AORUS Z390 Ultra | RAM: Ripjaws V Series 32GB DDR4 3200 | GPU: EVGA XC3 Ultra 3080 ti  | PSU: EVGA 1000 G+ | Case: Cooler Master H500 | Cooler: Noctua NH-D15 | SSD: Crucial P2 1TB  | SSD#2: Samsung 860 QVO 2TB | Monitor: LG 38" 3840 X 1600 75hz monitor.

Link to comment
Share on other sites

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share


×