Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

Monitors improperly or failing to respond on wake

 Share

I'll start with my current rig:

 

Windows 10

Motherboard: Rog Strix Z390-E Gaming

Processor: Intel(R) Core(TM) i7-9700K CPU @ 3.60GHz (8 CPUs), ~3.6GHz
Memory: G.Skill Ripjaws V Series 32GB (2 x 16GB)

Card name: GIGABYTE NVIDIA GeForce RTX 3070 Ti

Dual Monitors: ASUS ROG XG279Q

 

When I first got me system setup, I was using DisplayPort, but I ran into an issue where whenever I would wake my machine up, the monitors would start to wake up, fail, and then state there was no connection. My computer was awake and responsive (as proven by audio still coming through the speaker) and the only way I could get out of this state was to manually restart my system. This wasn't workable and after combing through forums, I read that this is a common-ish issue with DP, and that since I didnt have 4k monitors, HDMI wouldn't have this issue and I wouldn't loose anything I didnt already have (namely 144hz and HDR).

 

So, I switched to HDMI but NOW I have a new set of issues. Firstly, my main monitor will at least once a day, just blink out for about 3 seconds and then come back. I've double checked all my connections, cables, and drivers, as well as Windows Event Logs and cannot see any reason why this would happen. Secondly, anytime my monitors go to sleep, unlike before they do actually wake up now, however all of my windows are shoved to my main monitor and have been resized.

 

I've spent a fair amount of time combing through forums trying to solve this issue and have narrowed down what I _think_ the issue is but don't have a solution. It seems that all of this is related to Deep Sleep mode. However, my monitors dont have a method to disable Deep Sleep. I've tried all the other voodoo superstitious methods people have claimed to help (I disabled any phantom monitors in my device manager, I've updated the monitor specific drivers, I even updated my Samsung NVMe drivers) and nothing as fixed it.

 

In my research this issue has presented itself for almost a decade with no one ever having anything conclusive to offer. I've recently found myself setting my lock screen to a pure black image so that I can just disable any power saving but that seems like a crappy solution to my newly upgraded machine.

 

I'm currently staring at my RegEdit since some people have found success manually editing the Computer\HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\GraphicsDrivers keys, but wanted to check here first to see if anyone has any info or could provide assistance that is less drastic.

 

Appreciate any help anyone can provide!

Link to comment
Share on other sites

Link to post
Share on other sites

Nothing other than I second your worry about regedit.  

Life is like a bowl of chocolates: there are all these little crinkly paper cups everywhere.

Link to comment
Share on other sites

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share


×