Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

PSU Fan weirdly loud

So my PSU fan has randomly all of a sudden become loud. I am not sure of what is the issue. It's only a year old. It's from thermaltake 650 W Bronze.

Link to comment
Share on other sites

Link to post
Share on other sites

Full PC specs

Do you overclock? 

Did you get any new hardware recently? 

 

Have you begun to play a new game recently? 

There's no place like 127.0.0.1 💙

 

Expand for setup details:

 

MOBO: ASUS ROG STRIX Z370-F Gaming  

CPU: Intel Core i7-8700K@4.7GHz, -0.095mV (Custom CNP-IHS + LM) 

CPU COOLER: CORSAIR Hydro Series H100x + 2x CORSAIR 120LL RGB

GPU: ASUS ROG STRIX RTX 3080 Ti OC LC@2115MHz + GDDR6X 20Gbps OC 

RAM: G.SKILL TridentZ RGB 4x8GB@3700MT/s, 16-16-16-36, 1.35V (XMP Profile + 100MHz)

PCIe USB-A BOARD: ST Lab PCI-e 3.0 USB 3.1 (4x USB-A ports)

NVMe SSD: Samsung 970 EVO Plus 1TB 

#1 SATA SSD: Crucial MX500 2TB (1.05TB Partition RAID 0 striped with #2 SATA SSD: MX300)

#2 SATA SSD: Crucial MX300 1.05TB (RAID 0 striped with 1.05TB Partition on #1 SATA SSD: MX500)

PSU: CORSAIR HXi Series HX1200i (1200 Watt 80-PLUS Platinum)

CASE: CORSAIR iCUE 7000X RGB TG

CASE FANS: 4x CORSAIR SP140 RGElite, 2x CORSAIR 120LL RGB

#1 MONITOR: Samsung 49" Odyssey CRG9 QLED (32:9, 5120x1440p@120Hz, 8bit RGB, HDR1000)

#2 MONITOR: Philips 34" 346B1C (21:9, 3440x1440p@100Hz, 8bit RGB) [used on Svive Racing D1 SIM Cockpit]

SPEAKERS: CORSAIR SP2500 + FX Audio DAC-X6

 

Full specs and setup details on my profile-page

Link to comment
Share on other sites

Link to post
Share on other sites

11 minutes ago, CasperLaGhost said:

thermaltake 650 W Bronze.

Most Thermaltake Bronze units are pretty bad that you have to replace anyway. What's the exact model.

 

What's your CPU and GPU?

Link to comment
Share on other sites

Link to post
Share on other sites

Ryzen 5 3600

3200 mhz ram16 gb

1050ti

650 w psu mounted to the bottom to pull in freah air

2 intake 1 exhaust 2 exhaust through aio liquid cooler for cpu. 

1 m.2 ssd

B450 gaming f from asus MoBo

 

 

 

Link to comment
Share on other sites

Link to post
Share on other sites

Very weird. It's not consistant. The fan is completely fine now.

Link to comment
Share on other sites

Link to post
Share on other sites

On 5/23/2022 at 7:32 PM, CasperLaGhost said:

Very weird. It's not consistant. The fan is completely fine now.

Can you see if the fan is spinning under load? Because mine stopped working (tt hamburg) and I also saw one review reporting the same thing maybe yours is also affected

Link to comment
Share on other sites

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share


×