Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

Did I damage my 6600xt?

ezio313
 Share

Hi, so I bought power color 6600xt today. I only connected the 8 pins port to the card, didn't notice the 6pins port. The colors were on but fans didn't work and it showed no display. I connected the 6pins and it worked, but Could this potentially have damaged the card?

Link to comment
Share on other sites

Link to post
Share on other sites

nope.

mY s YsTeM iS Not pErfoRmInG aS gOOd As I sAW oN yOuTuBe. WhA t IS a GoOd FaN CuRVe??!!? wHat aRe tEh GoOd OvERclok SeTTinGS FoR My CaRd??
 HoW CaN I foRcE my GpU to uSe 1o0%? BuT WiLL i HaVE Bo0tllEnEcKs? RyZEN dOeS NoT peRfORm BetTer wItH HiGhER sPEED RaM!!dId i WiN teH SiLiCON LotTerrYyOu ShoUlD dEsHrOuD uR GPUmy SYstEm iS UNDerPerforMiNg iN WarzONEcan mY Pc Run WiNdOwS 11 ?woUld BaKInG MY GRaPHics card fIX it?
 MultimETeR TeSTiNG!! aMd'S GpU DrIvErS aRe as goOD aS NviDia's YOU SHoUlD oVERCloCk yOUR ramS To 5000C18

 

Link to comment
Share on other sites

Link to post
Share on other sites

I remember the day i didn't plug the 6pin in to my friends BFG 8800GTS 640MB he'd let me borrow for a couple of days.  The buzzer going off full bore and the sheer panic that hit me while scrambling for the PSU rocker

 With all the Trolls, Try Hards, Noobs and Weirdos around here you'd think i'd find SOMEWHERE to fit in!

Link to comment
Share on other sites

Link to post
Share on other sites

No damage done. The card just refused to boot properly without the proper power connected.

Link to comment
Share on other sites

Link to post
Share on other sites

Hi, system :i5 10400, 16gb ram. 1tb ssd and g700 gold

so I bought a used 6600xt yesterday, ran uningine benchmark twice on it and results were significantly lower (95fps) than online benchmarks(115fps), I ran msi afterburner and gpu usage was 99% most of the time.

I also ran novabench and gpu score was in bottom 94th percentile. What's the deal?

image.thumb.png.b4279f705daa1af94b392e455bd933ea.png

 

image.thumb.png.440d9fc95c4474a5781cd21e98eed669.png

 

image.thumb.png.53f6bd83e52ca204147400de931261c6.pngimage.thumb.png.6427036fc43603c23184b2a47a3b2488.png

Link to comment
Share on other sites

Link to post
Share on other sites

Download free version of 3dmark and run the benchmark. Random youtube videos are not great for comparisons. 3dmark is more reliable and comparable.

mY s YsTeM iS Not pErfoRmInG aS gOOd As I sAW oN yOuTuBe. WhA t IS a GoOd FaN CuRVe??!!? wHat aRe tEh GoOd OvERclok SeTTinGS FoR My CaRd??
 HoW CaN I foRcE my GpU to uSe 1o0%? BuT WiLL i HaVE Bo0tllEnEcKs? RyZEN dOeS NoT peRfORm BetTer wItH HiGhER sPEED RaM!!dId i WiN teH SiLiCON LotTerrYyOu ShoUlD dEsHrOuD uR GPUmy SYstEm iS UNDerPerforMiNg iN WarzONEcan mY Pc Run WiNdOwS 11 ?woUld BaKInG MY GRaPHics card fIX it?
 MultimETeR TeSTiNG!! aMd'S GpU DrIvErS aRe as goOD aS NviDia's YOU SHoUlD oVERCloCk yOUR ramS To 5000C18

 

Link to comment
Share on other sites

Link to post
Share on other sites

Just now, Levent said:

Download free version of 3dmark and run the benchmark. Random youtube videos are not great for comparisons. 3dmark is more reliable and comparable.

issue is that I had msi 6600xt on this pc and got 115 at same settings. The reason I replaced the msi mech 2x is that I was suffering from frame time issues and thought that maybe changing the gpu will solve the issue

Link to comment
Share on other sites

Link to post
Share on other sites

1 minute ago, ezio313 said:

issue is that I had msi 6600xt on this pc and got 115 at same settings. The reason I replaced the msi mech 2x is that I was suffering from frame time issues and thought that maybe changing the gpu will solve the issue

Changing a graphics card with the same one is not going to fix frame time issues. You did all that for absolutely nothing.

mY s YsTeM iS Not pErfoRmInG aS gOOd As I sAW oN yOuTuBe. WhA t IS a GoOd FaN CuRVe??!!? wHat aRe tEh GoOd OvERclok SeTTinGS FoR My CaRd??
 HoW CaN I foRcE my GpU to uSe 1o0%? BuT WiLL i HaVE Bo0tllEnEcKs? RyZEN dOeS NoT peRfORm BetTer wItH HiGhER sPEED RaM!!dId i WiN teH SiLiCON LotTerrYyOu ShoUlD dEsHrOuD uR GPUmy SYstEm iS UNDerPerforMiNg iN WarzONEcan mY Pc Run WiNdOwS 11 ?woUld BaKInG MY GRaPHics card fIX it?
 MultimETeR TeSTiNG!! aMd'S GpU DrIvErS aRe as goOD aS NviDia's YOU SHoUlD oVERCloCk yOUR ramS To 5000C18

 

Link to comment
Share on other sites

Link to post
Share on other sites

1 minute ago, Levent said:

Changing a graphics card with the same one is not going to fix frame time issues. You did all that for absolutely nothing.

Yea I know but I was desperate since all software fixes didnt work. Anyways I ran nova bench and it showed a severely low gpu score (743 compared to 1221arvg) while my cpu showed similar score to avrg.

image.thumb.png.d09ce16e5c9299fc9b88b842b58b695b.png

Link to comment
Share on other sites

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share


×