Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

Can't enable secure boot or UEFI Mode

Go to solution Solved by Pandur,

That does sound weird. What can happen is that your bios reset at some point. There is an AUTO CLR_CMOS option, in bios, that can be enabled. That will do that if your computer fail to boot/load os enough times. Cmos battery could be failing, and it is cheap to replace. But also easy to check by removing power to your computer and check if it has reset after a few minutes.

 

To have proper uefi with secure boot enabled on that motherboard, you need to do as follows: (according to the manual)

 

Go to Advanced menu in the bios. Make sure Windows 10 WHQL Support is enabled in Windows OS Configuration menu. This should enable the Secure Boot sub-menu, make sure this is enabled and standard keys are loaded. Also applies to W11 even if it says W10. Idiot manufacturer should have just written Windows WHQL Support, but I digress.

 

In the Boot menu, Boot Mode Select need to be UEFI (only). This should happen automatically when you enable the above options.

 

In the Trusted Computing menu, Security Device Support should be enabled and AMD fTPM switch set to AMD CPU fTPM (unless you have a dedicated TPM module installed).

 

Your drives need to be GPT formatted.

 

If you are still unable to install Windows 11 then there is something seriously wrong.

 

Also worth checking for any updated bios versions while you are at it.

So ive been using Windows 11 for a couple of months now and so far everything went well. I had no issues whatsoever. Today i turned my Computer on and all i got was a blue screen. (No text. Nothing. I will attach a Foto if possible) I opened my Pc and disconnected and reconnected all my drives (1 M.2 and 1 Sata Sdd) but still nothing. Both drives are showing up in the bios just like they did before. I still had my USB Drive with the Windows 11 install lying around and tried reinstalling it. It than told me that my Pc doesnt meet the requirements which is obviously a bit odd because ive been using Windows 11 for a couple of months now. So i went back into the bios to check if tpm and secure boot were still enabled. It turns out that secure boot was disabled (tpm was still on). So i turned it back on wich also required to enable uefi boot. Than i tried booting into windows but i just got the same blue screen again. I also tried running chkdsk but no luck there. So i downloaded a Windows 10 install and tried to install that with uefi boot enabled but same blue screen. I had to disable it and convert the drives to mbr in order to actually get into windows 10. No Windows updates in the last week. No new bios update. I changed absolutely nothing during the last couple of weeks. Iam out of ideas here.

 

System:

Msi B450 A Pro

Ryzen 7 2700x

Rtx 2070

16 Gb Ram

C463C2C6-C849-4C3E-88AF-83D61BDF2071.jpeg

Link to comment
Share on other sites

Link to post
Share on other sites

That does sound weird. What can happen is that your bios reset at some point. There is an AUTO CLR_CMOS option, in bios, that can be enabled. That will do that if your computer fail to boot/load os enough times. Cmos battery could be failing, and it is cheap to replace. But also easy to check by removing power to your computer and check if it has reset after a few minutes.

 

To have proper uefi with secure boot enabled on that motherboard, you need to do as follows: (according to the manual)

 

Go to Advanced menu in the bios. Make sure Windows 10 WHQL Support is enabled in Windows OS Configuration menu. This should enable the Secure Boot sub-menu, make sure this is enabled and standard keys are loaded. Also applies to W11 even if it says W10. Idiot manufacturer should have just written Windows WHQL Support, but I digress.

 

In the Boot menu, Boot Mode Select need to be UEFI (only). This should happen automatically when you enable the above options.

 

In the Trusted Computing menu, Security Device Support should be enabled and AMD fTPM switch set to AMD CPU fTPM (unless you have a dedicated TPM module installed).

 

Your drives need to be GPT formatted.

 

If you are still unable to install Windows 11 then there is something seriously wrong.

 

Also worth checking for any updated bios versions while you are at it.

Link to comment
Share on other sites

Link to post
Share on other sites

13 minutes ago, Pandur said:

That does sound weird. What can happen is that your bios reset at some point. There is an AUTO CLR_CMOS option, in bios, that can be enabled. That will do that if your computer fail to boot/load os enough times. Cmos battery could be failing, and it is cheap to replace. But also easy to check by removing power to your computer and check if it has reset after a few minutes.

 

To have proper uefi with secure boot enabled on that motherboard, you need to do as follows: (according to the manual)

 

Go to Advanced menu in the bios. Make sure Windows 10 WHQL Support is enabled in Windows OS Configuration menu. This should enable the Secure Boot sub-menu, make sure this is enabled and standard keys are loaded. Also applies to W11 even if it says W10. Idiot manufacturer should have just written Windows WHQL Support, but I digress.

 

In the Boot menu, Boot Mode Select need to be UEFI (only). This should happen automatically when you enable the above options.

 

In the Trusted Computing menu, Security Device Support should be enabled and AMD fTPM switch set to AMD CPU fTPM (unless you have a dedicated TPM module installed).

 

Your drives need to be GPT formatted.

 

If you are still unable to install Windows 11 then there is something seriously wrong.

 

Also worth checking for any updated bios versions while you are at it.

I will try this tomorow because iam tired and kinda pissed (Been trying to fix this for hours now). Anyway thx for the input.

Link to comment
Share on other sites

Link to post
Share on other sites

It worked after a updating to the newest bios. Thx for the Help!

Link to comment
Share on other sites

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share


×