Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

Sapphire HD 3850 AGP not booting.

AshleyKitty123
 Share

Hey Everyone. 

Today the HD 3850 AGP card in my retro gaming pc stopped working, with no apparent reason why. Visually, there doesn't seem to be anything wrong with it (like caps or anything), voltages seem to be present, it is detected as it halts the boot and core is getting hot. The fan does spin up for a few seconds then turns back off. 

How should i go about troubleshooting it further?

Thanks in advance! 

 

IMG_20211130_150811.jpg

IMG_20211130_150834.jpg

IMG_20211201_005910__01__01.jpg

IMG_20211130_145838.jpg

Link to comment
Share on other sites

Link to post
Share on other sites

30 minutes ago, AshleyKitty123 said:

How should i go about troubleshooting this further?

swap cards, if it still doesn't boot, then the AGP slot is bad.

If it does boot, then the card is bad

Can you get into safe mode? (that usually doesn't tax the hardware)

So rise up, all ye lost ones, as one, we'll claw the clouds

Link to comment
Share on other sites

Link to post
Share on other sites

1 minute ago, Radium_Angel said:

swap cards, if it still doesn't boot, then the AGP slot is bad.

If it does boot, then the card is bad

Can you get into safe mode? (that usually doesn't tax the hardware)

The card is the problem, the pc worked just fine with a different GPU. 

Was asking how to troubleshoot the card further. 

Link to comment
Share on other sites

Link to post
Share on other sites

17 minutes ago, AshleyKitty123 said:

The card is the problem, the pc worked just fine with a different GPU. 

Was asking how to troubleshoot the card further. 

How good are you electronic component replacement skills? Likely the card has simply died of old age, and isn't worth repairing.

 

So rise up, all ye lost ones, as one, we'll claw the clouds

Link to comment
Share on other sites

Link to post
Share on other sites

15 minutes ago, Radium_Angel said:

How good are you electronic component replacement skills?

Good enough to replace basic components and some fine work, but cant do bga rework.

 

15 minutes ago, Radium_Angel said:

Likely the card has simply died of old age, and isn't worth repairing.

It doesn't seem like it tho. It suddenly refused to post after reinstalling the drivers.

Link to comment
Share on other sites

Link to post
Share on other sites

18 minutes ago, AshleyKitty123 said:

Good enough to replace basic components and some fine work, but cant do bga rework.

 

It doesn't seem like it tho. It suddenly refused to post after reinstalling the drivers.

Can you boot into safe mode and uninstall the drivers and then let Windows handle finding them?

So rise up, all ye lost ones, as one, we'll claw the clouds

Link to comment
Share on other sites

Link to post
Share on other sites

5 hours ago, Radium_Angel said:

Can you boot into safe mode and uninstall the drivers and then let Windows handle finding them?

No, This card doesn't even get through post. 

Link to comment
Share on other sites

Link to post
Share on other sites

1 hour ago, AshleyKitty123 said:

No, This card doesn't even get through post. 

If it won't even post, then it's dead for good

So rise up, all ye lost ones, as one, we'll claw the clouds

Link to comment
Share on other sites

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share


×