Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

This purple line appeared on my laptop screen

This line appeared on my laptop screen after i went out to buy something, i didn't do anything, and i don't have any pets or siblings, (so i don't think it took any physical damage) it just appeared, is my screen broken? Or it's something else?

IMG_20210611_143101~2.jpg

Link to post
Share on other sites

Got the same line on my phone, looks like physical damage to your screen.

ASUS ROG STRIX B350-F Gaming | AMD Ryzen 3600 at 4GHz/1.2vMasterLiquid ML360R RGB | PNY Geforce RTX 2080 Super OC 8GB Gaming | Corsair Vengeance RGB 16GB DDR4 (2x 8GB) 3000 MHz | Fractal Design 750w Integra M | Intel 600p - 256 GB (M.2) | Samsung EVO 850 - 500 GB | Samsung EVO Pro 850 - 250 GB Fractal Design R6 Black (Silent) | 3x FractalDesign Dynamic X2 GW-14 & 3x CoolerMaster 120mm "RGB"

Display(s): Samsung Oddesy G7 240hz/1ms, ACER Predator XB271H A 144hz/1ms. (Yeah i sold the Philips 273ELH to a friend XD)

Car(s): Volvo V70 D3 2016

Link to post
Share on other sites
4 minutes ago, MultiGamerClub said:

Got the same line on my phone, looks like physical damage to your screen.

But i literally didn't do anything to my laptop! I'm completely sure 

Link to post
Share on other sites

Things can just fail out of the blue...

F@H
Desktop: i7-5960X 4.4GHz, Noctua NH-D14, ASUS Rampage V, 32GB, RTX3080, 2TB NVMe SSD, 2x16TB HDD RAID0, Corsair HX1200, Thermaltake Overseer RX1, Samsung 4K curved 49" TV, 23" secondary

Mobile SFF rig: i9-9900K, Noctua NH-L9i, Asrock Z390 Phantom ITX-AC, 32GB, GTX1070, 2x1TB NVMe SSD RAID0, 2x5TB 2.5" HDD RAID0, Athena 500W Flex (Noctua fan), Custom 4.7l 3D printed case

 

Dell XPS 2 in 1 2019, 32GB, 1TB, 4K

 

GPD Win 2

Link to post
Share on other sites

I had a monitor a few years ago that the bottom half randomly stopped working, it'd been fine for 3 years or so and was never dropped, hit, etc. It's a physical problem with the screen, there's really nothing you can do other than get a new screen or ignore it. 

Is it plugged in? Is it turned on? Are you sure? No, really. 

Link to post
Share on other sites
4 hours ago, Slimshayan said:

But i literally didn't do anything to my laptop! I'm completely sure 

I buyed a literally brand new Samsung Odessy G7 and it has 1 dead pixel in the upper left screen and about half the people who buyed the same monitor as me has said the same thing at the exact same location.. Cant be a coincidence.

 

Some times it just happens or bad product quality degrades over time.. Who knows really, but you have to change the screen and if the laptop is old its not really worth the hassle.. Unless you want to or it has more personal value to you.

ASUS ROG STRIX B350-F Gaming | AMD Ryzen 3600 at 4GHz/1.2vMasterLiquid ML360R RGB | PNY Geforce RTX 2080 Super OC 8GB Gaming | Corsair Vengeance RGB 16GB DDR4 (2x 8GB) 3000 MHz | Fractal Design 750w Integra M | Intel 600p - 256 GB (M.2) | Samsung EVO 850 - 500 GB | Samsung EVO Pro 850 - 250 GB Fractal Design R6 Black (Silent) | 3x FractalDesign Dynamic X2 GW-14 & 3x CoolerMaster 120mm "RGB"

Display(s): Samsung Oddesy G7 240hz/1ms, ACER Predator XB271H A 144hz/1ms. (Yeah i sold the Philips 273ELH to a friend XD)

Car(s): Volvo V70 D3 2016

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×