Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

Forwarding ports does not work

Hello!

Before I star, this is the setup I use here at home:

setup.png.5ca41952971515a2e611bc43106fcd0e.png

M = Modem/router

W = Asus router I use for ONLY WIFI

S = Switch

PC = My computer
SERV = My server

 

I want to have my server port forward for game servers as I have always been that guy for my friends.
Port forwarding just doesnt work, I want to forward my server, the server has a static IP and is reserved in the modem.
I open the port in the modem the server is connected to and I make an exception in the Windows firewall for the same port. I have tried both as TCP and UDP. I have tried setting my server in DMZ mode, nothing I have tried works, I have asked friends that know some more than me and I called my ISP to see if they had any idea why it doenst work, and they said they could not see any problems.
I have two switches and have tried to use both.

Do any of you have any idea? Is there something I have missed in the modem settings? Is there more info you need to help me out?

Thank you.

Link to post
Share on other sites

On your modem/router does your WAN IP start with 10.x.x.x or 100.64.x.x through 100.127.x.x?

Current Network Layout:

Current Build Log/PC:

Prior Build Log/PC:

Link to post
Share on other sites

Make some screenshots of port forwarding screen. (Make sure to hide public IP's and such 😉 )

Love the diagram of your setup, makes things easier to understand.

 

Also how do you test if ports are open?
If you use gaming software there might be other reasons why it doesnt work, etc.

 

When everything is set up, try and use this to see if open, closed or stealthed.

https://www.yougetsignal.com/tools/open-ports/

When i ask for more specs, don't expect me to know the answer!
I'm just helping YOU to help YOURSELF!
(The more info you give the easier it is for others to help you out!)

Link to post
Share on other sites
1 minute ago, Lurick said:

On your modem/router does your WAN IP start with 10.x.x.x or 100.64.x.x through 100.127.x.x?

I cant find anywhere it says WAN IP, only that all my devices are on 192.168.0.1-255? I dont think the modem uses WAN since its the same box and it is connected with a TV cable, I am sorry if I misunderstood.

1 minute ago, HanZie82 said:

Make some screenshots of port forwarding screen. (Make sure to hide public IP's and such 😉 )

Love the diagram of your setup, makes things easier to understand.

 

Also how do you test if ports are open?
If you use gaming software there might be other reasons why it doesnt work, etc.

 

When everything is set up, try and use this to see if open, closed or stealthed.

https://www.yougetsignal.com/tools/open-ports/

image.thumb.png.af9095c42c45ed969c705eeaa536daf0.png

This is the only one I have ATM, I have tried to factory reset everyhting two times now haha. I have tried filling the external host with both 0.0.0.0 and nothing (then the star you see comes). 
Thank you for that, it looks amazing 😄

I have tested with https://www.canyouseeme.org/ and https://www.whatsmyip.org/port-scanner/

Link to post
Share on other sites
1 minute ago, Arnonymous said:

I cant find anywhere it says WAN IP, only that all my devices are on 192.168.0.1-255? I dont think the modem uses WAN since its the same box and it is connected with a TV cable, I am sorry if I misunderstood.

image.thumb.png.af9095c42c45ed969c705eeaa536daf0.png

This is the only one I have ATM, I have tried to factory reset everyhting two times now haha. I have tried filling the external host with both 0.0.0.0 and nothing (then the star you see comes). 
Thank you for that, it looks amazing 😄

I have tested with https://www.canyouseeme.org/ and https://www.whatsmyip.org/port-scanner/

WAN IP is your public (outside) IP.

 

Looks like you've set it up correctly as far as i can see.
It lo0oks like External host is either your own public IP (you might need to enter it in that case) or an IP you want to be the only one having option on that port forward.
Much depends on the software on the router/modem

When i ask for more specs, don't expect me to know the answer!
I'm just helping YOU to help YOURSELF!
(The more info you give the easier it is for others to help you out!)

Link to post
Share on other sites
2 minutes ago, Arnonymous said:

I cant find anywhere it says WAN IP, only that all my devices are on 192.168.0.1-255? I dont think the modem uses WAN since its the same box and it is connected with a TV cable, I am sorry if I misunderstood.

image.thumb.png.af9095c42c45ed969c705eeaa536daf0.png

This is the only one I have ATM, I have tried to factory reset everyhting two times now haha. I have tried filling the external host with both 0.0.0.0 and nothing (then the star you see comes). 
Thank you for that, it looks amazing 😄

I have tested with https://www.canyouseeme.org/ and https://www.whatsmyip.org/port-scanner/

WAN is your public IP address for the interface that connects to your ISP. If it's 10.x.x.x or 100.64.x.x through 100.127.x.x then you're behind what's known as CG-NAT (Carrier Grade NAT) and you can't port forward from the internet to your server directly.

Current Network Layout:

Current Build Log/PC:

Prior Build Log/PC:

Link to post
Share on other sites
9 minutes ago, HanZie82 said:

Make some screenshots of port forwarding screen. (Make sure to hide public IP's and such 😉 )

Love the diagram of your setup, makes things easier to understand.

 

Also how do you test if ports are open?
If you use gaming software there might be other reasons why it doesnt work, etc.

 

When everything is set up, try and use this to see if open, closed or stealthed.

https://www.yougetsignal.com/tools/open-ports/

Oh, forgot to answer the last part, I dont use any gaming software, and this is what your page says:image.png.2c7fe6a0a9817f1b62274b199590a716.png

Link to post
Share on other sites
Just now, Arnonymous said:

Oh, forgot to answer the last part, I dont use any gaming software, and this is what your page says:image.png.2c7fe6a0a9817f1b62274b199590a716.png

Closed... Thats not what i would think would happen. So the modem/router is activly blocking it.
Theres no other device between your setup and the internets? If not, then maybe the portforwarding is broken? Im out of idea's, im sorry.

When i ask for more specs, don't expect me to know the answer!
I'm just helping YOU to help YOURSELF!
(The more info you give the easier it is for others to help you out!)

Link to post
Share on other sites
Just now, Lurick said:

WAN is your public IP address for the interface that connects to your ISP. If it's 10.x.x.x or 100.64.x.x through 100.127.x.x then you're behind what's known as CG-NAT (Carrier Grade NAT) and you can't port forward from the internet to your server directly.

Oh ok, the WAN Public IP is 84.x.x.x

1 minute ago, HanZie82 said:

WAN IP is your public (outside) IP.

 

Looks like you've set it up correctly as far as i can see.
It lo0oks like External host is either your own public IP (you might need to enter it in that case) or an IP you want to be the only one having option on that port forward.
Much depends on the software on the router/modem

And I have tried entering that too in the External host option, but now the server has DMZ on it and still nothing.

Link to post
Share on other sites
Just now, Arnonymous said:

Oh ok, the WAN Public IP is 84.x.x.x

And I have tried entering that too in the External host option, but now the server has DMZ on it and still nothing.

ok, so long as the modem's public IP matches what you see on the port checker website then you're not behind CGNAT at least.

Current Network Layout:

Current Build Log/PC:

Prior Build Log/PC:

Link to post
Share on other sites
Just now, Arnonymous said:

And I have tried entering that too in the External host option, but now the server has DMZ on it and still nothing.

What the heck. Sounds like the port-forwarding is either broken or another device is blocking it, as DMZ should just open up everything...

When i ask for more specs, don't expect me to know the answer!
I'm just helping YOU to help YOURSELF!
(The more info you give the easier it is for others to help you out!)

Link to post
Share on other sites

 

Just now, HanZie82 said:

What the heck. Sounds like the port-forwarding is either broken or another device is blocking it, as DMZ should just open up everything...

Yeah, my ISP says it is not broken, so I am as lost haha 😛

Just now, Lurick said:

ok, so long as the modem's public IP matches what you see on the port checker website then you're not behind CGNAT at least.

Yeah it is the same, I read about that and my ISP confirmed it was not that.

Link to post
Share on other sites

With the server in DMZ and firewall turned off on the server (don't keep it that way, though!) it should work

as you remove all software blocks along the way.

 

If that still doesn't work I'd focus on the Asus wireless router.

It should be in "access point mode", DHCP services need to be disabled

and the cable from the modem needs to go into a LAN port, not the WAN.

This will eliminate that device as a possible cause of interference.

PC Specs - AMD Ryzen 5 5600X MSI B550M Mortar 16GB Crucial Ballistix DDR4-3600 @ CL15 - RX5700XT 660p 1TBGB & 256GB 600p Fractal Define Mini C CM V550 - Pop!_OS 20.04

Link to post
Share on other sites
1 minute ago, NelizMastr said:

With the server in DMZ and firewall turned off on the server (don't keep it that way, though!) it should work

as you remove all software blocks along the way.

 

If that still doesn't work I'd focus on the Asus wireless router.

It should be in "access point mode", DHCP services need to be disabled

and the cable from the modem needs to go into a LAN port, not the WAN.

This will eliminate that device as a possible cause of interference.

Oh, ok. I have the cable from the modem to the asus router in the WAN port. I will set the Asus router in AC mode.
If that can cause interference I cant see it being anything else, will report back soon.

Link to post
Share on other sites

 

5 minutes ago, NelizMastr said:

With the server in DMZ and firewall turned off on the server (don't keep it that way, though!) it should work

as you remove all software blocks along the way.

 

If that still doesn't work I'd focus on the Asus wireless router.

It should be in "access point mode", DHCP services need to be disabled

and the cable from the modem needs to go into a LAN port, not the WAN.

This will eliminate that device as a possible cause of interference.

I tried to check many ports when I had it in DMZ and turned the firewall off in windows and on the modem, every port in the portchecker said "Closed" Instead of timed out. This was 5 hours ago, so not something I did now.

Link to post
Share on other sites
16 minutes ago, NelizMastr said:

With the server in DMZ and firewall turned off on the server (don't keep it that way, though!) it should work

as you remove all software blocks along the way.

 

If that still doesn't work I'd focus on the Asus wireless router.

It should be in "access point mode", DHCP services need to be disabled

and the cable from the modem needs to go into a LAN port, not the WAN.

This will eliminate that device as a possible cause of interference.

I have done everything now, still nothing 😕

Link to post
Share on other sites
6 minutes ago, Arnonymous said:

I have done everything now, still nothing 😕

Then i would try disconnecting the wifi thing, connecting PC directly to modem and test again.
If that dont work the last solution i can think of it, to turn of all NAT stuff on modem, and let that work as pure modem.

Then use the ASUS thing as full-router and have the port forwarding done on that. I have my setup somewhat similar to that, as most ISP provided modem/routers are complete garbage.
But this might need some knowledge on some terminology.

When i ask for more specs, don't expect me to know the answer!
I'm just helping YOU to help YOURSELF!
(The more info you give the easier it is for others to help you out!)

Link to post
Share on other sites
1 minute ago, HanZie82 said:

Then i would try disconnecting the wifi thing, connecting PC directly to modem and test again.
If that dont work the last solution i can think of it, to turn of all NAT stuff on modem, and let that work as pure modem.

Then use the ASUS thing as full-router and have the port forwarding done on that. I have my setup somewhat similar to that, as most ISP provided modem/routers are complete garbage.
But this might need some knowledge on some terminology.

I dont have a cable long enough and I depend on remote desktop to use the server, in the process of adding a wifi card to the server now. I cant find the very strange displayadapter for the server haha. 
And yes, I did actually have that setup before with the modem bridged and the Asus router doing everything, I want that! Sometimes the port forwarding would work, sometimes it would just not work, exactly the same as now. That is why I tried using the setup I painted a few days ago, since that is the most direct connection I could make. 
I will try what you see and also go back to how I had it before, after resetting everything. I just want to host servers haha 😄

Link to post
Share on other sites
22 minutes ago, HanZie82 said:

Then i would try disconnecting the wifi thing, connecting PC directly to modem and test again.
If that dont work the last solution i can think of it, to turn of all NAT stuff on modem, and let that work as pure modem.

Then use the ASUS thing as full-router and have the port forwarding done on that. I have my setup somewhat similar to that, as most ISP provided modem/routers are complete garbage.
But this might need some knowledge on some terminology.

I removed my ISP provided modem immediately. From the fiber converter straight into a Ubiquiti USG and from there through managed switches throughout the house. Works great 🙂

A bridged connection would be ideal here. The modem will pass everything through to a router which controls all the various forwards and routing tasks.
Some modems don't properly support bridge mode, though, which is a pain. You'll end up with double NAT. Even single NAT doesn't appear to work here, which is very very odd.

PC Specs - AMD Ryzen 5 5600X MSI B550M Mortar 16GB Crucial Ballistix DDR4-3600 @ CL15 - RX5700XT 660p 1TBGB & 256GB 600p Fractal Define Mini C CM V550 - Pop!_OS 20.04

Link to post
Share on other sites
18 hours ago, NelizMastr said:

I removed my ISP provided modem immediately. From the fiber converter straight into a Ubiquiti USG and from there through managed switches throughout the house. Works great 🙂

A bridged connection would be ideal here. The modem will pass everything through to a router which controls all the various forwards and routing tasks.
Some modems don't properly support bridge mode, though, which is a pain. You'll end up with double NAT. Even single NAT doesn't appear to work here, which is very very odd.

Yeah, I bet ^^ 
I reset everything now and used the bridge connection now, and looks like this:
948510642_setupo2.png.ff2e3ead815784f476bb42b25f3c370b.png

M = Modem in bridge mode

W = Asus router now in router mode
S = Switch

PC = MY PC
Server = Server
TV PC = TV PC hehehe

 

So I tried to use the TV PC instead now, since it does not go through any switch, and I opend port 2456 and still its closed I also checked port 3389, I then turned on DMZ and 2456 was still closed, but 3389 was open! So something is working, I just dont understand why 2456 is still blocked.
This setup is what I had before, and it used to work sometimes on my server, but the TV PC is better and I mostly use the server for backup and data since I have a lot of storage on it. So I want to use the TV PC for servers. 🙂

Link to post
Share on other sites
2 hours ago, Arnonymous said:

So I tried to use the TV PC instead now, since it does not go through any switch, and I opend port 2456 and still its closed I also checked port 3389, I then turned on DMZ and 2456 was still closed, but 3389 was open! So something is working, I just dont understand why 2456 is still blocked.

This setup is what I had before, and it used to work sometimes on my server, but the TV PC is better and I mostly use the server for backup and data since I have a lot of storage on it. So I want to use the TV PC for servers. 🙂

Keep in mind a port will only report as being open when there's actually something listening on that port for connections.

If you enable remote desktop, that computer starts listening on port 3389 TCP. If you forward that port and check if it's open, it'll report as open.

If you don't have anything listening on port 2456, but still forward that port, it will report as closed.

PC Specs - AMD Ryzen 5 5600X MSI B550M Mortar 16GB Crucial Ballistix DDR4-3600 @ CL15 - RX5700XT 660p 1TBGB & 256GB 600p Fractal Define Mini C CM V550 - Pop!_OS 20.04

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Newegg

×