Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

Can You Help Me Fix This GPU ?

So i got a gtx1080 G1 (used) which i  used it for 2 years .There was a year of not cleaning the fan, lack of proper air flow  but still ,the card was running fine.

After i mailed my GPU via courier, during run time  the GPU fan would ramp up 100% with no display(40 min interval).
I re-apply thermal paste and clean the fan it work fine for 2 month.

Then i ran it on a poorly air flow case and the problem worsen, even after i change all pad and paste it is now  unusable.

Fan still running fine, gpu could still load. With the lack of stock on 30s and with how my gpu isn't exactly dead... any advice?
IM ONLY LEFT WITH THE OPTION OF COCKING IT AT 200C at the oven it seems  :v

Thankyou all, Im sorry if im using this site wrongly

Image_09.jpg

Link to post
Share on other sites

So..is it currently working? You could always try to re-apply paste and reseat the cooler. Maybe it has bad contact. Aside from that, it might be time for an upgrade.

Best of luck

Link to post
Share on other sites
41 minutes ago, jwwagner25 said:

So..is it currently working? You could always try to re-apply paste and reseat the cooler. Maybe it has bad contact. Aside from that, it might be time for an upgrade.

Best of luck

not working , it could turn on but soon in a couple of minute fan ramp up to 100% and display died .
yes its time to upgrade butt 30s stock T-T id probably have to wait 3 month here

ive decided to let pc's  repair guys have a look , they could somehow repair motherboard so i hope theyd be able to get more out of my dead card (atleast till i can get my hands on 30series )

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×