Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

Lubuntu doesn't recognize my gpu

Go to solution Solved by igormp,
21 minutes ago, Lord Szechenyi said:

how

I don't recommend using nvidia's drivers over the open source ones since your GPU is too old, unsupported and you'll have to use an older driver that may not be compatible with everything.

 

If you still want to do so, look around the menu for something called "Additional Drivers", this should bring you a window where you can select drivers to install without having to mess with the terminal.

 

I have a 9300m gs in my laptop, but lubuntu uses the igpu for some reason

how do i fix.

Link to post
Share on other sites

You can try with Nvidia drivers, but I would MUCH rather be using the integrated graphics while on Linux due to Nvidia drivers being kinda wonky on the OS.

Community Standards || Tech News Posting Guidelines

---======================================================================---

CPU: R5 3600 || GPU: GTX 1080 || Memory: 16GB @ 3200 || Cooler: Noctua D15 || PSU: 750W EVGA G2 || Case: Define C

Link to post
Share on other sites
1 minute ago, Slottr said:

but I would MUCH rather be using the integrated graphics while on Linux due to Nvidia drivers being kinda wonky on the OS.

understandable

Quote

You can try with Nvidia drivers,

yes, but im a total noob with the terminal (man i prefer cmd much more) and i have no idea how to run/execute the .run drivers.

Because it gives me a "nvidia-installer must be run as root error" 

Link to post
Share on other sites
Just now, Lord Szechenyi said:

understandable

yes, but im a total noob with the terminal (man i prefer cmd much more) and i have no idea how to run/execute the .run drivers.

Because it gives me a "nvidia-installer must be run as root error" 

You need to be running the terminal in root to do so

sudo -i

 

Then you will follow whichever steps to install the drivers

 

Be careful running the terminal in root, it gives you an extreme amount of room to move around with.

Community Standards || Tech News Posting Guidelines

---======================================================================---

CPU: R5 3600 || GPU: GTX 1080 || Memory: 16GB @ 3200 || Cooler: Noctua D15 || PSU: 750W EVGA G2 || Case: Define C

Link to post
Share on other sites

You have 2 potential problems.

  1. The last supported NVIDIA Driver for Linux was 340.108  - Dec 23, 2019. The latest version is 455.23.04 - September 17, 2020
    1. You can try seeing if 340.108 is available in Ubuntu's Additional Drivers. Keep in mind however that there have been quite a few kernel changes since then and things like DXVK target recent Drivers.
  2. Multi GPU support in Linux is fun, as in its not supported out of the box. You need to either disable the iGPU if the BIOS allows it or you can look at this https://wiki.archlinux.org/index.php/NVIDIA_Optimus
    1. I am not aware of workarounds for Systems that use Wayland and I am not sure if Lubuntu has made that switch.

You could try looking at PopOS!, they have some non standard configs for out of the box Multi GPU support, however I am not sure if it will work with the 9300m.

Link to post
Share on other sites
Just now, Slottr said:

Be careful running the terminal in root, it gives you an extreme amount of room to move around with.

Thanks

Yes, fully aware of that, thats why i dont really like using linux

Link to post
Share on other sites
1 minute ago, Lord Szechenyi said:

Thanks

Yes, fully aware of that, thats why i dont really like using linux

 

3 minutes ago, Slottr said:

You need to be running the terminal in root to do so


sudo -i

 

Then you will follow whichever steps to install the drivers

 

Be careful running the terminal in root, it gives you an extreme amount of room to move around with.

lmao it didnt work, still gives me same error

Link to post
Share on other sites
Quote

sudo -1

i did that, it gaves me some text, the i tried running the driver, and still same error message

Link to post
Share on other sites
9 minutes ago, Lord Szechenyi said:

i did that, it gaves me some text, the i tried running the driver, and still same error message

SS your terminal?

Community Standards || Tech News Posting Guidelines

---======================================================================---

CPU: R5 3600 || GPU: GTX 1080 || Memory: 16GB @ 3200 || Cooler: Noctua D15 || PSU: 750W EVGA G2 || Case: Define C

Link to post
Share on other sites
8 minutes ago, Slottr said:

SS your terminal?

 

6 minutes ago, Lord Szechenyi said:

how

taking a picture is quicker

 

20201202_233608.jpg

Link to post
Share on other sites
33 minutes ago, Lord Szechenyi said:

I have a 9300m gs in my laptop, but lubuntu uses the igpu for some reason

how do i fix.

Nouveau should be enabled by default, and GPU offloading should also be working out of the box. Do not install nvidias proprietary drivers for that GPU since it's not supported anymore, and you can get full acceleration with nouveau anyways. The iGPU is used by default due to power saving reasons, and any demanding application will switch to the dedicated GPU if needed.

 

You can read more about it here.

 

31 minutes ago, Slottr said:

You can try with Nvidia drivers, but I would MUCH rather be using the integrated graphics while on Linux due to Nvidia drivers being kinda wonky on the OS.

Nvidia drivers work flawlessly, what are you talking about?

 

28 minutes ago, Lord Szechenyi said:

understandable

yes, but im a total noob with the terminal (man i prefer cmd much more) and i have no idea how to run/execute the .run drivers.

Because it gives me a "nvidia-installer must be run as root error" 

You should NEVER install the drivers this way, it'll likely break your system. Always use the package manager from your distro.

 

26 minutes ago, Nayr438 said:

The last supported NVIDIA Driver for Linux was 340.108  - Dec 23, 2019. The latest version is 455.23.04 - September 17, 2020

That's wrong. 

image.png.1cfc916baa0d6bfc684e3f2e70c3da87.png

 

27 minutes ago, Nayr438 said:

Multi GPU support in Linux is fun, as in its not supported out of the box. You need to either disable the iGPU if the BIOS allows it or you can look at this https://wiki.archlinux.org/index.php/NVIDIA_Optimus

It is supported out of the box, specially if you only use the open source drivers.

FX6300 @ 4.2GHz | Gigabyte GA-78LMT-USB3 R2 | Hyper 212x | 3x 8GB + 1x 4GB @ 1600MHz | Gigabyte 2060 Super | Corsair CX650M | LG 43UK6520PSA
ASUS X550LN | i5 4210u | 12GB
Lenovo N23 Yoga

Link to post
Share on other sites
4 minutes ago, igormp said:

You should NEVER install the drivers this way, it'll likely break your system. Always use the package manager from your distro.

how

Link to post
Share on other sites
21 minutes ago, Lord Szechenyi said:

how

I don't recommend using nvidia's drivers over the open source ones since your GPU is too old, unsupported and you'll have to use an older driver that may not be compatible with everything.

 

If you still want to do so, look around the menu for something called "Additional Drivers", this should bring you a window where you can select drivers to install without having to mess with the terminal.

 

FX6300 @ 4.2GHz | Gigabyte GA-78LMT-USB3 R2 | Hyper 212x | 3x 8GB + 1x 4GB @ 1600MHz | Gigabyte 2060 Super | Corsair CX650M | LG 43UK6520PSA
ASUS X550LN | i5 4210u | 12GB
Lenovo N23 Yoga

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×