Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

Are ASUS purposely soft-bricking old motherboards?

So here's the story. I was moving my GPU up a slot since i was taking out my WiFi card and i had space to put it in, and it would give it better airflow. I turned it on and everything worked fine, and my temps went down by a little too.

So i decided to push my luck.

I updated my BIOS over the internet. After it updated, everything looked fine. So i turned on XMP and virtualisation, and my computer wouldn't boot to the ASUS logo. I opened up my PC, took out my GPU and re-inserted my CMOS battery to clear my CMOS. Everything worked fine again, until i tried to change any settings. I went to the ASUS Website and downloaded the latest BIOS for my B150M-C from here. But noticed something kinda fishy. When I clicked "see all downloads" i noticed that all of the other BIOS releases have some release notes, even if they're quick ones like "Improve system capability and stability", but the latest version didn't. I still thought something might have happened when I downloaded my BIOS over the internet, and decided to retry the latest BIOS version by flashing it onto my USB stick. I installed the latest BIOS version and it looked like everything worked fine, but i still couldn't enable XMP or Virtualisation. I downloaded the previous version of the bios and I could enable these settings. I think it's a pretty large co-incidence how there were no release notes and the latest version of the BIOS is broken, at the point where it feel kind of sketchy. I looked around other BIOS versions for the B150M-A and the B150M-K and i couldn't find any BIOS versions without any release notes. So here's what I think:

  1. ASUS made a very careless mistake and made it possible to easily softbrick your system with a bad BIOS, and didn't add any release notes.
  2. ASUS intentionally broke the BIOS version. It's a very budget motherboard for budget skylake CPUs and may be in a lot of pre-builts. In the manual it talks about a disk about "Antivirus software (OEM Version)". People who aren't to great with computers might update their BIOS and change settings in their BIOS based on google searches. They find out that they accidentally soft-bricked their system and might not know that they can clear their CMOS. This is more likely with a board like this as it's nowhere near enthusiast level and is very cheap, meaning people who don't know much about computers are more likely to get a budget pre-built with a mobo like this, or have a friend build it etc. They might think that their computer is broken, meaning that they might get a new one and asus gets more money for people getting their parts?

Number 2 is highly unlikely but considering how sketchy this feels it just might be true. Or maybe i'm just very paranoid. I'm curious to see what you think.

Link to post
Share on other sites

The Asus board I used for my FX CPU still works so there you go.

TuringMachine

Ryzen 5 3600x - Asus Strix B450-F - Asus ROG RTX 2060S Strix AD - HyperX Predator 3200 2x8 GB DDR4 - Phanteks P400S - Corsair RM 650x - BeQuiet! Dark Rock 4 - Kingston A2000 NVMe 1TB SSD - 2x Samsung QVO 1TB SSD (RAID 0) - Seagate Barracuda 3TB

 

Quote

"If the genius of invention were to reveal tomorrow the secret of immortality, of eternal beauty and youth, for which all humanity is aching, the same inexorable agents which prevent a mass from changing suddenly its velocity would likewise resist the force of the new knowledge until time gradually modifies human thought."

  -Nikola Tesla, New York, May 16, 1907
Link to post
Share on other sites

I had a very long and troublesome experience with Intel 4th gen refresh CPU's and Asus H81/H87/Z87 series boards. I had a HTPC in a compact case with a H87 board and I wanted to swap in a better CPU (i3 to i5) so I needed to update BIOS since it was a Haswell 'refresh' CPU, so I updated BIOS via USB stick and the BIOS updater built into the BIOS itself. Upon reboot all my settings were defaulted (correct), and the BIOS showed the new version number (correct), but when I installed the newer CPU the board would not post! Old CPU worked fine. New CPU did not. Tried another refresh 4th gen CPU, same results. Doubled checked the CPU compatibility list, all 3 CPU were on the list and compatible with this BIOS version. Went through ALL the trouble shooting, even contacted Asus support who informed me my board was defective, send it in, it'll be somewhere between $50 and $200 to repair with a 6-8 week turn around time *if* it was repairable. Hard pass. Go  back to using old CPU, pfft whatever I guess.

Until the same problem happened to another Z87 board from Asus with a refresh CPU, same process, same results.

And again with 2 H81 Asus boards witha  refresh CPU, same process, same results.

 

FINALLY after 6 months I found a reddit post. I had to use the Windows flash tool to ACTUALLY apply the BIOS, the tool in the BIOS did not work and would not write the whole BIOS just update the version number and set to defaults but not update the important parts. Asus had and probably still has no clue about this problem.

 

If the second most recent BIOS works properly just use that and count yourself lucky you can flash down a version and that things work correctly.

Link to post
Share on other sites

That sounds very annoying. I guess i'm lucky that i had to take my GPU out a couple of times to reach my CMOS battery when i tried to fix it.

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×