Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

adapted drive detected only on a specific second adapter.

I have a hitachi 44pin pata (ide) drive rated at 5v 1A, which I am trying to clone offline.

all the parts mentioned below have been individually tested to work on their own.

I have used this adapter to adapt the drive to sata https://www.amazon.com/gp/product/B085DJD9SQ

Then from there, facilitated by this sata extension cable (with slight trimming of the housing of the dock-end) https://www.amazon.com/gp/product/B07FK63BTV

I am trying to use the adapted drive with this usb dock fd2002 https://www.amazon.com/gp/product/B00N1KXE9K

but with the fd2002 it is only momentarily detected [yet detected correctly] during power-up/power-down.

If i use this usb dock's ( https://www.amazon.com/gp/product/B01NAUIA6G ) sata connector instead of the fd2002 dock, the drive is detected as expected (yes i know this unitek dock has a 44pin pata connector, but that is irrelevant to what I am attempting to discover/learn).

I bought this sata-data extension cable https://www.ebay.com/itm/12-SATA-7-Pin-Male-to-Female-Extension-Cable-FIA-L12R/280645965548

to be able to [with slight trimming of the housing of the extension cable end] use a secondary power supply to power the pata-to-sata adapter immediately connected to the pata drive (thinking that low amperage from the fd2002 to the pata-to-sata was the issue).

which yielded the same symptom of the drive only appearing briefly during power-up/power-down (while also attempting every variation of power-on & connection ordering).

so then I tried disconnecting the 3.3v line coming from the secondary power supply (being that neither the inateck [not working] nor the unitek [working] docks provide power on those pins), thinking it could be overwhelming the pata-to-sata adapter somehow, to no improvement.

so I have ruled out power/connection-ordering, and ruled out low amperage. Voltages check out, and each item otherwise individually works.

my current theory is the unitek adapter can access the adapted drive because it is otherwise able to connect pata drives.

To support this, i have tried this external usb/sata enclosure https://www.amazon.com/gp/product/B01M08LCXW in the roadmap of: enclosure > sata extension cable > sata-data extension cable > pata-to-sata adapter (powered by secondary power supply) > pata drive.. yielding the same result as seen with the fd2002 dock.



The endgame is pata to pata offline cloning. This is necessitated by equipment that can not natively accept the addition of [cloning] software, and cloning the bootable drive outside of original equipment has yielded unusable results which are attributed to the drive/OS configuration. I do not know of any offline clone capable dock that is also pata.

I would expect that not many have encountered this use-case before, but I would welcome any ideas.

And no the original equipment cannot boot off of anything other than pata, and the original equipment cannot be upgraded.

should amperage need to be revisited, that capability has been worked out here: https://linustechtips.com/main/topic/1253066-the-meter-that-doesnt-exist-for-upgradingreplacing-old-drives


the confrontation of this use-case may increase as owners/operators of specific systems realize that their equipment depends on drives of which the rate or mortality increases exponentially with advanced age.

Link to post
Share on other sites

@john_wayne Can you try connecting directly to a computer SATA port through the IDE -> SATA adapter, without any of the USB converters? I suspect the chips in them don't have complete support for IDE (I know i couldn't adapt a SATA optical drive (which relies on the IDE layer in SATA) using a HDD USB converter for the same reason).

Main System (Byarlant): Ryzen 5 1600X | Asus B350-F Strix | Corsair H80i V2 | 16GB G.Skill DDR4 3200MHz CAS-14 | XFX RX 5600 XT THICC II | Samsung 960 PRO 512GB / Samsung 970 EVO 500GB / Seagate 7200RPM 3TB | Corsair CX650M | Mellanox ConnectX-2 10G NIC | Anidees AI-07BW Case | Dell U3415W Monitor | Microsoft Modern Keyboard


FreeNAS Server (Veda): Core i3-4170 | Supermicro X10SLL-F | Corsair H60 | 32GB Micron DDR3L ECC 1600MHz | 4x 10TB WD Whites / 1x Samsung PM961 128GB SSD / 1x Kingston 16GB SSD | Corsair CX430M | Mellanox ConnectX-2 10G NIC | LSI 9207-8i LBA | Fractal Design Node 804 Case (side panels swapped to show off drives)


Media Center/Video Capture (Jesta): Core i7-2600 | Asus H77M-PRO | Stock Cooler | 8GB No-name DDR3 | EVGA GTX750Ti SC | Sandisk UltraII SSD 64GB / Seagate 1.5TB HDD | Corsair CX450M | Hauppauge ImpactVCB-PCIe | Syba USB3.1 Gen 2 Card | LG UH12NS30 BD-ROM | Silverstone Sugo SG-11 Case


Laptop (Narrative): Lenovo Flex 5 81X20005US | Ryzen 5 4500U | 16GB RAM (soldered) | Vega 6 Graphics | UMIS 256GB NVMe SSD | (all-around awesome machine)

Laptop (Rozen-ZuluSony VAIO VPCF13WFX | Core i7-740QM | 8GB Patriot DDR3 | GT 425M | Kingston 120GB SSD | Blu-ray Drive | (lived a good life, retired with honor)


Tablet (---): Samsung Galaxy Tab A 8" (crosses fingers)
Tablet (ReGZ)Asus T102HA (BIOS clock doesn't tick, loses time when sleep/off) (I kill tablets with disturbing regularity)

Tablet (Unicorn)Surface Pro 2 (battery will reset total capacity to current charge, leading Windows to think it's always 100% charged until it dies)

Tablet (Loto)Dell Venue 8 Pro (screen discoloration issues, wouldn't update to Windows 10)

Tablet: iPad 2 16GB (WiFi died, basically useless after that)


Testbed/Old Desktop (Kshatriya): Xeon X5470 @ 4.0GHz | ZALMAN CNPS9500 | Gigabyte EP45-UD3L | 8GB Nanya DDR2 400MHz | XFX HD6870 DD | OCZ Vertex 3 Max-IOPS 120GB | Corsair CX430M (?) | HooToo USB 3.0 PCIe Card | NZXT H230 Case


Camera: Sony ɑ7II (w/ Meike Grip) | Sony SEL24240 | Samyang 35mm ƒ/2.8 | Sony SEL50F18F | Sony SEL2870 (kit lens) | PNY Elite Perfomance SDXC cards

Link to post
Share on other sites
2 hours ago, AbydosOne said:

@john_wayne Can you try connecting directly to a computer SATA port through the IDE -> SATA adapter, without any of the USB converters? I suspect the chips in them don't have complete support for IDE (I know i couldn't adapt a SATA optical drive (which relies on the IDE layer in SATA) using a HDD USB converter for the same reason).

@AbydosOne yes that works, just as using the unitek usb->multi(using sata) adapter between a tertiary host computer and the ide->sata adapter does. The ide-sata adapter works exactly as it should when not behind either the inateck fd2002 dock or the orico enclosure. But as stated, using the sata port of a motherboard doesn't facilitate an offline clone of the drive, UNLESS there exists some distro which I am unaware of which would basically operate the motherboard as an offline clone machine (i.e.: clone the drive sector-by-sector WITHOUT mounting it, duplicating the boot sector and all). When I try to clone the ide drive as mounted as an external drive - the result is not usable. Your mention of "IDE layer in SATA" aligns with my theory as to why adding the fd2002 to the mix fails. Thanks for recommending the troubleshoot, and perhaps someone knows of a offline clone distro that I do not, which could be a viable change of direction. It is just puzzling/frustrating that the drive is momentarily properly detected with the "suspected-incompatible-to-scenario" dock in place during power-up/power-down. I would expect that a dock [chipset?] based incompatibility wouldn't be able to provide for such actually happening.


EDIT: Or based on what you experienced, Perhaps I can find a dual dock with an offline clone feature, which also supports optical drives (to gain that suspected-missing "IDE layer in SATA"). I will do some digging.


EDIT 2: the inateck fd2002 dock did not work with an optical drive. the unitek Y-3324 did work with an optical drive. so my 3 current roadmaps to move forward are: A.) find a offline cloning dual dock which supports optical drives (using 'optical' as an oversimplification to ferret out the "extended chipset" necessary to recognize the adapted drives). B.) find a distro that would operate [a pre-OS computer with two of the unitek Y-3324 adapters] as an offline cloning unit. C.) otherwise solve why specifically the fd2002 dock containing the adapted pata drive only gets detected momentarily at power-up/power-down.

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now