Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

PC won’t boot. Worked last night | QLed’s stick on green and white

I have had my computer for a couple of months now and today it was unable to boot. It was working not even 6 hours ago. Now, whenever I boot it gets stuck on the white QLED but everything turns on (fans, lights, peripherals, etc.) Although there is no video and the Qled doesn't go to green. Any tips or help would be appreciated.

 

Order is the following: orange, red, white, then white and green. 

 

Already tried different GPU, Resetting CMOS, and taking out 1 stick of ram at a time. 

Specs: 
ASUS TUF x-570 Plus (no wifi)
AMD Ryzen 3700x
Corsair 650M Power Supply 
Gigabyte Windforce 1660ti OC
Corsair Vengance RGB Pro 16gb 3600MHz

Link to comment
Share on other sites

Link to post
Share on other sites

Scan the board for anything out of the ordinary. Make sure all connections are solid and are in. You can try reseating the CPU and see if that helps, otherwise you just have to check all connectors and if nothing works you can see if you have a 2ndary bios (usually bios switch are on  the bottom of the board) and such. 

Link to comment
Share on other sites

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share


×