Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

Issues with "LANCache"

So recently I found and old computer laying around and was gonna use it as a Steam cache. I ordered a new network card and what not and used a docker software called LanCache. I followed   this tutorial. When I ping my cache from a windows machine, I get:

DNS request timed out.
timeout was 2 second
*** Request to Unknown timed-out

I have already set my default DNS to the cache and alternate to my router. I also tried using 1.1.1.1 as the alternate. I can get on the internet just fine, but when I ping it or try to download steam games, the server just doesn't respond, and the network usage on the server sits at around 600 bytes per second due to background tasks.

Link to comment
Share on other sites

Link to post
Share on other sites

2 minutes ago, Electronics Wizardy said:

are all the docker containers working?

 

Try using ns lookup to see if the server is really resolving dns queries

The docker containers are running. When I use nslookup, I get this:

Server:  UnKnown
Address:  10.0.0.169

*** UnKnown can't find steam.cache.lancache.net: No response from server

 

Link to comment
Share on other sites

Link to post
Share on other sites

have you made sure that the firewall on the docker host is set to allow UDP port 53 incoming? If you want to test, your can TEMPORARILY disable the firewall on the server.

Also, is the rest of your network (and in particular the computer you are testing from) using the 10.x.x.x subnet? If not then what, if any, routing has been set up?

Looking to buy GTX690, other multi-GPU cards, or single-slot graphics cards: 

 

Link to comment
Share on other sites

Link to post
Share on other sites

4 hours ago, brwainer said:

have you made sure that the firewall on the docker host is set to allow UDP port 53 incoming? If you want to test, your can TEMPORARILY disable the firewall on the server.

Also, is the rest of your network (and in particular the computer you are testing from) using the 10.x.x.x subnet? If not then what, if any, routing has been set up?

I don't really know much about networking and servers. My router and all of the devices IP address are 10.x.x.x. The IP for the server is something that I am struggling with. I just realized this, but when I give the server an IP address outside of the DHCP range of my router, it can't connect to the internet. The video that I watched suggests that I need an IP outside of the DHCP range so that it won't be dynamic. Making it static or dynamic doesn't make a difference on my main PC though, I tried both and go the same error. Is this true or what? Also I tried disabling the firewall within Linux and it made no difference. (The server runs Linux Mint)

Edited by TinsellyCone241
Link to comment
Share on other sites

Link to post
Share on other sites

5 hours ago, TinsellyCone241 said:

I don't really know much about networking and servers. My router and all of the devices IP address are 10.x.x.x. The IP for the server is something that I am struggling with. I just realized this, but when I give the server an IP address outside of the DHCP range of my router, it can't connect to the internet. The video that I watched suggests that I need an IP outside of the DHCP range so that it won't be dynamic. Making it static or dynamic doesn't make a difference on my main PC though, I tried both and go the same error. Is this true or what? Also I tried disabling the firewall within Linux and it made no difference. (The server runs Linux Mint)

Setting a server to use a static IP is a good practice, because devices on DHCP might change IPs from time to time, and that would mess up any port forwarding or other IP-specific settings you make in your router.

If set properly there is no difference in connectivity between static IP and DHCP. Most likely, when setting it to static IP, you have put in the subnet mask and/or gateway wrong, or not set a DNS server.

Looking to buy GTX690, other multi-GPU cards, or single-slot graphics cards: 

 

Link to comment
Share on other sites

Link to post
Share on other sites

4 hours ago, brwainer said:

Setting a server to use a static IP is a good practice, because devices on DHCP might change IPs from time to time, and that would mess up any port forwarding or other IP-specific settings you make in your router.

If set properly there is no difference in connectivity between static IP and DHCP. Most likely, when setting it to static IP, you have put in the subnet mask and/or gateway wrong, or not set a DNS server.

That would explain it. I just put in 24 for the subnet mask. I watched some videos now but I still don’t really know what the correct subnet mask would be.

Link to comment
Share on other sites

Link to post
Share on other sites

2 hours ago, TinsellyCone241 said:

That would explain it. I just put in 24 for the subnet mask. I watched some videos now but I still don’t really know what the correct subnet mask would be.

While the computer is on DHCP, run “ipconfig /all” to see the subnet mask and gateway. Use those same numbers when setting it static. If you have problems, paste the ipconfig /all here (put it in a Spoiler block) and a screenshot of what you put in for the static settings.

 

Looking to buy GTX690, other multi-GPU cards, or single-slot graphics cards: 

 

Link to comment
Share on other sites

Link to post
Share on other sites

So the server runs Linux, so IP config doesn't work, but I did some research and I ran IFconfig instead. My understanding is that the two are very similar. But then when I ran it it has multiple IP addresses and stuff like that. Here is what it said: (I am using a Realtek ethernet card, and tried a few of the netmasks with no results)

Spoiler

(My Username)@(Server's Name):~$ ifconfig
br-26f272cf32a5: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
        inet 172.18.0.1  netmask 255.255.0.0  broadcast 172.18.255.255
        inet6 fe80::42:71ff:fe88:a33f  prefixlen 64  scopeid 0x20<link>
        ether 02:42:71:88:a3:3f  txqueuelen 0  (Ethernet)
        RX packets 25  bytes 1859 (1.8 KB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 188  bytes 29219 (29.2 KB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

docker0: flags=4099<UP,BROADCAST,MULTICAST>  mtu 1500
        inet 172.17.0.1  netmask 255.255.0.0  broadcast 172.17.255.255
        ether 02:42:30:c5:26:01  txqueuelen 0  (Ethernet)
        RX packets 0  bytes 0 (0.0 B)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 0  bytes 0 (0.0 B)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

enp3s0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
        inet 10.0.0.169  netmask 255.255.255.0  broadcast 10.0.0.255
        inet6 2601:840:8200:fd50:36e8:94ff:fef8:78df  prefixlen 64  scopeid 0x0<global>
        inet6 fe80::36e8:94ff:fef8:78df  prefixlen 64  scopeid 0x20<link>
        ether 34:e8:94:f8:78:df  txqueuelen 1000  (Ethernet)
        RX packets 14768  bytes 16261796 (16.2 MB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 8041  bytes 931416 (931.4 KB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

enp4s0: flags=4099<UP,BROADCAST,MULTICAST>  mtu 1500
        ether 00:12:3f:77:fb:c1  txqueuelen 1000  (Ethernet)
        RX packets 0  bytes 0 (0.0 B)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 0  bytes 0 (0.0 B)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0
        device interrupt 17  memory 0xefae0000-efb00000  

lo: flags=73<UP,LOOPBACK,RUNNING>  mtu 65536
        inet 127.0.0.1  netmask 255.0.0.0
        inet6 ::1  prefixlen 128  scopeid 0x10<host>
        loop  txqueuelen 1000  (Local Loopback)
        RX packets 2292  bytes 193198 (193.1 KB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 2292  bytes 193198 (193.1 KB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

veth94cf6c7: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
        inet6 fe80::ecea:2ff:fe84:9866  prefixlen 64  scopeid 0x20<link>
        ether ee:ea:02:84:98:66  txqueuelen 0  (Ethernet)
        RX packets 0  bytes 0 (0.0 B)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 257  bytes 26070 (26.0 KB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

veth997a591: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
        inet6 fe80::180a:ddff:fe7f:f9df  prefixlen 64  scopeid 0x20<link>
        ether 1a:0a:dd:7f:f9:df  txqueuelen 0  (Ethernet)
        RX packets 25  bytes 2209 (2.2 KB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 264  bytes 37467 (37.4 KB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

 

Link to comment
Share on other sites

Link to post
Share on other sites

8 minutes ago, TinsellyCone241 said:

So the server runs Linux, so IP config doesn't work, but I did some research and I ran IFconfig instead. My understanding is that the two are very similar. But then when I ran it it has multiple IP addresses and stuff like that. Here is what it said: (I am using a Realtek ethernet card, and tried a few of the netmasks with no results)

  Hide contents

(My Username)@(Server's Name):~$ ifconfig
br-26f272cf32a5: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
        inet 172.18.0.1  netmask 255.255.0.0  broadcast 172.18.255.255
        inet6 fe80::42:71ff:fe88:a33f  prefixlen 64  scopeid 0x20<link>
        ether 02:42:71:88:a3:3f  txqueuelen 0  (Ethernet)
        RX packets 25  bytes 1859 (1.8 KB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 188  bytes 29219 (29.2 KB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

docker0: flags=4099<UP,BROADCAST,MULTICAST>  mtu 1500
        inet 172.17.0.1  netmask 255.255.0.0  broadcast 172.17.255.255
        ether 02:42:30:c5:26:01  txqueuelen 0  (Ethernet)
        RX packets 0  bytes 0 (0.0 B)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 0  bytes 0 (0.0 B)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

enp3s0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
        inet 10.0.0.169  netmask 255.255.255.0  broadcast 10.0.0.255
        inet6 2601:840:8200:fd50:36e8:94ff:fef8:78df  prefixlen 64  scopeid 0x0<global>
        inet6 fe80::36e8:94ff:fef8:78df  prefixlen 64  scopeid 0x20<link>
        ether 34:e8:94:f8:78:df  txqueuelen 1000  (Ethernet)
        RX packets 14768  bytes 16261796 (16.2 MB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 8041  bytes 931416 (931.4 KB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

enp4s0: flags=4099<UP,BROADCAST,MULTICAST>  mtu 1500
        ether 00:12:3f:77:fb:c1  txqueuelen 1000  (Ethernet)
        RX packets 0  bytes 0 (0.0 B)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 0  bytes 0 (0.0 B)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0
        device interrupt 17  memory 0xefae0000-efb00000  

lo: flags=73<UP,LOOPBACK,RUNNING>  mtu 65536
        inet 127.0.0.1  netmask 255.0.0.0
        inet6 ::1  prefixlen 128  scopeid 0x10<host>
        loop  txqueuelen 1000  (Local Loopback)
        RX packets 2292  bytes 193198 (193.1 KB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 2292  bytes 193198 (193.1 KB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

veth94cf6c7: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
        inet6 fe80::ecea:2ff:fe84:9866  prefixlen 64  scopeid 0x20<link>
        ether ee:ea:02:84:98:66  txqueuelen 0  (Ethernet)
        RX packets 0  bytes 0 (0.0 B)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 257  bytes 26070 (26.0 KB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

veth997a591: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
        inet6 fe80::180a:ddff:fe7f:f9df  prefixlen 64  scopeid 0x20<link>
        ether 1a:0a:dd:7f:f9:df  txqueuelen 0  (Ethernet)
        RX packets 25  bytes 2209 (2.2 KB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 264  bytes 37467 (37.4 KB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

 

Apologies, for some reason I thought your first post said the server is Windows, and I didn’t see your edit somewhere else that it is using Mint.

 

enp3s0 is your ethernet port. enp4s0 appwars to be another ethernet port which is not connected. The rest of the interfaces are related to docker.

 

was this ifconfig collected when the interface was set to DHCP, or static? Please share the following:

-”ifconfig” and “route” while on DHCP

-the static settings you are putting in (screenshot)

Looking to buy GTX690, other multi-GPU cards, or single-slot graphics cards: 

 

Link to comment
Share on other sites

Link to post
Share on other sites

16 minutes ago, brwainer said:

Apologies, for some reason I thought your first post said the server is Windows, and I didn’t see your edit somewhere else that it is using Mint.

 

enp3s0 is your ethernet port. enp4s0 appwars to be another ethernet port which is not connected. The rest of the interfaces are related to docker.

 

was this ifconfig collected when the interface was set to DHCP, or static? Please share the following:

-”ifconfig” and “route” while on DHCP

-the static settings you are putting in (screenshot)

You're good! I am using an old desktop computer that has a 56 kb/s ethernet port so I got a new gigabit network card. Here is the info you asked for. The commands are from the auto network settings which will allow me to connect to the internet. The screenshot is what I typed in. My router's DHCP range is 10.0.0.2-10.0.0.253. The router's IP is 10.0.0.1. 

Spoiler

ROUTE 

 

Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
default         _gateway        0.0.0.0         UG    100    0        0 enp3s0
10.0.0.0        0.0.0.0         255.255.255.0   U     100    0        0 enp3s0
link-local      0.0.0.0         255.255.0.0     U     1000   0        0 enp3s0
172.17.0.0      0.0.0.0         255.255.0.0     U     0      0        0 docker0
172.18.0.0      0.0.0.0         255.255.0.0     U     0      0        0 br-26f272cf32a5

Spoiler

IFCONFIG

 

(My Username)@(Server's Name):~$ ifconfig
br-26f272cf32a5: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
        inet 172.18.0.1  netmask 255.255.0.0  broadcast 172.18.255.255
        inet6 fe80::42:71ff:fe88:a33f  prefixlen 64  scopeid 0x20<link>
        ether 02:42:71:88:a3:3f  txqueuelen 0  (Ethernet)
        RX packets 25  bytes 1859 (1.8 KB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 188  bytes 29219 (29.2 KB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

docker0: flags=4099<UP,BROADCAST,MULTICAST>  mtu 1500
        inet 172.17.0.1  netmask 255.255.0.0  broadcast 172.17.255.255
        ether 02:42:30:c5:26:01  txqueuelen 0  (Ethernet)
        RX packets 0  bytes 0 (0.0 B)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 0  bytes 0 (0.0 B)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

enp3s0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
        inet 10.0.0.169  netmask 255.255.255.0  broadcast 10.0.0.255
        inet6 2601:840:8200:fd50:36e8:94ff:fef8:78df  prefixlen 64  scopeid 0x0<global>
        inet6 fe80::36e8:94ff:fef8:78df  prefixlen 64  scopeid 0x20<link>
        ether 34:e8:94:f8:78:df  txqueuelen 1000  (Ethernet)
        RX packets 14768  bytes 16261796 (16.2 MB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 8041  bytes 931416 (931.4 KB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

enp4s0: flags=4099<UP,BROADCAST,MULTICAST>  mtu 1500
        ether 00:12:3f:77:fb:c1  txqueuelen 1000  (Ethernet)
        RX packets 0  bytes 0 (0.0 B)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 0  bytes 0 (0.0 B)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0
        device interrupt 17  memory 0xefae0000-efb00000  

lo: flags=73<UP,LOOPBACK,RUNNING>  mtu 65536
        inet 127.0.0.1  netmask 255.0.0.0
        inet6 ::1  prefixlen 128  scopeid 0x10<host>
        loop  txqueuelen 1000  (Local Loopback)
        RX packets 2292  bytes 193198 (193.1 KB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 2292  bytes 193198 (193.1 KB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

veth94cf6c7: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
        inet6 fe80::ecea:2ff:fe84:9866  prefixlen 64  scopeid 0x20<link>
        ether ee:ea:02:84:98:66  txqueuelen 0  (Ethernet)
        RX packets 0  bytes 0 (0.0 B)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 257  bytes 26070 (26.0 KB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

veth997a591: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
        inet6 fe80::180a:ddff:fe7f:f9df  prefixlen 64  scopeid 0x20<link>
        ether 1a:0a:dd:7f:f9:df  txqueuelen 0  (Ethernet)
        RX packets 25  bytes 2209 (2.2 KB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 264  bytes 37467 (37.4 KB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

 

Network Settings.pngEdit: in my router's settings there is a subnet dropdown which says 255.255.255.0 currently, I put that in as the subnet range and nothing happened again.

Link to comment
Share on other sites

Link to post
Share on other sites

6 minutes ago, TinsellyCone241 said:

You're good! I am using an old desktop computer that has a 56 kb/s ethernet port so I got a new gigabit network card. Here is the info you asked for. The commands are from the auto network settings which will allow me to connect to the internet. The screenshot is what I typed in. My router's DHCP range is 10.0.0.2-10.0.0.253. The router's IP is 10.0.0.1. 

  Hide contents

ROUTE 

 

Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
default         _gateway        0.0.0.0         UG    100    0        0 enp3s0
10.0.0.0        0.0.0.0         255.255.255.0   U     100    0        0 enp3s0
link-local      0.0.0.0         255.255.0.0     U     1000   0        0 enp3s0
172.17.0.0      0.0.0.0         255.255.0.0     U     0      0        0 docker0
172.18.0.0      0.0.0.0         255.255.0.0     U     0      0        0 br-26f272cf32a5

  Hide contents

IFCONFIG

 

(My Username)@(Server's Name):~$ ifconfig
br-26f272cf32a5: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
        inet 172.18.0.1  netmask 255.255.0.0  broadcast 172.18.255.255
        inet6 fe80::42:71ff:fe88:a33f  prefixlen 64  scopeid 0x20<link>
        ether 02:42:71:88:a3:3f  txqueuelen 0  (Ethernet)
        RX packets 25  bytes 1859 (1.8 KB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 188  bytes 29219 (29.2 KB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

docker0: flags=4099<UP,BROADCAST,MULTICAST>  mtu 1500
        inet 172.17.0.1  netmask 255.255.0.0  broadcast 172.17.255.255
        ether 02:42:30:c5:26:01  txqueuelen 0  (Ethernet)
        RX packets 0  bytes 0 (0.0 B)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 0  bytes 0 (0.0 B)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

enp3s0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
        inet 10.0.0.169  netmask 255.255.255.0  broadcast 10.0.0.255
        inet6 2601:840:8200:fd50:36e8:94ff:fef8:78df  prefixlen 64  scopeid 0x0<global>
        inet6 fe80::36e8:94ff:fef8:78df  prefixlen 64  scopeid 0x20<link>
        ether 34:e8:94:f8:78:df  txqueuelen 1000  (Ethernet)
        RX packets 14768  bytes 16261796 (16.2 MB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 8041  bytes 931416 (931.4 KB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

enp4s0: flags=4099<UP,BROADCAST,MULTICAST>  mtu 1500
        ether 00:12:3f:77:fb:c1  txqueuelen 1000  (Ethernet)
        RX packets 0  bytes 0 (0.0 B)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 0  bytes 0 (0.0 B)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0
        device interrupt 17  memory 0xefae0000-efb00000  

lo: flags=73<UP,LOOPBACK,RUNNING>  mtu 65536
        inet 127.0.0.1  netmask 255.0.0.0
        inet6 ::1  prefixlen 128  scopeid 0x10<host>
        loop  txqueuelen 1000  (Local Loopback)
        RX packets 2292  bytes 193198 (193.1 KB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 2292  bytes 193198 (193.1 KB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

veth94cf6c7: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
        inet6 fe80::ecea:2ff:fe84:9866  prefixlen 64  scopeid 0x20<link>
        ether ee:ea:02:84:98:66  txqueuelen 0  (Ethernet)
        RX packets 0  bytes 0 (0.0 B)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 257  bytes 26070 (26.0 KB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

veth997a591: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
        inet6 fe80::180a:ddff:fe7f:f9df  prefixlen 64  scopeid 0x20<link>
        ether 1a:0a:dd:7f:f9:df  txqueuelen 0  (Ethernet)
        RX packets 25  bytes 2209 (2.2 KB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 264  bytes 37467 (37.4 KB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

 

Network Settings.png

So from the ifconfig while on DHCP, we can see that the router is using 255.255.255.0 as the netmask. That means that the network of the router will only treat 10.0.0.1 - 10.0.0.254 as valid IP addresses (the first and last IP in a subnet are unusable - 0 and 255 for this case). That is why when you set the computer to use 10.0.0.255 as the IP it doesn't work. The only usable IP that isn't in the DHCP range is 10.0.0.254, so you could use that (and also change the Netmask to 255.255.255.0). Alternatively you can reduce the DHCP range of the router - maybe make it start at 10.0.0.20, giving you .2 through .19 to assign statically.

Looking to buy GTX690, other multi-GPU cards, or single-slot graphics cards: 

 

Link to comment
Share on other sites

Link to post
Share on other sites

4 minutes ago, brwainer said:

So from the ifconfig which on DHCP, we can see that the router is using 255.255.255.0 as the netmask. That means that the network of the router will only treat 10.0.0.1 - 10.0.0.254 as valid IP addresses (the first and last IP in a subnet are unusable - 0 and 255 for this case). That is why when you set the computer to use 10.0.0.255 as the IP it doesn't work. The only usable IP that isn't in the DHCP range is 10.0.0.254, so you could use that (and also change the Netmask to 255.255.255.0). Alternatively you can reduce the DHCP range of the router - maybe make it start at 10.0.0.20, giving you .2 through .19 to assign statically.

You are a genius! It did connect to the internet now, but when I set the new IP adress as my DNS for my windows PC and try to use NS lookup on it, I get this: (it did find the correct IP adress tho)

 
 
🤝
 
Spoiler

(Me)>nslookup cache.steamcache.lancache.net

Server:  UnKnown
Address:  10.0.0.254

*** UnKnown can't find cache.steamcache.lancache.net: No response from server

 

Link to comment
Share on other sites

Link to post
Share on other sites

On 5/15/2020 at 2:24 PM, brwainer said:

So from the ifconfig while on DHCP, we can see that the router is using 255.255.255.0 as the netmask. That means that the network of the router will only treat 10.0.0.1 - 10.0.0.254 as valid IP addresses (the first and last IP in a subnet are unusable - 0 and 255 for this case). That is why when you set the computer to use 10.0.0.255 as the IP it doesn't work. The only usable IP that isn't in the DHCP range is 10.0.0.254, so you could use that (and also change the Netmask to 255.255.255.0). Alternatively you can reduce the DHCP range of the router - maybe make it start at 10.0.0.20, giving you .2 through .19 to assign statically.

i am still getting this from NSlookup.

Spoiler

(Me)>nslookup cache.steamcache.lancache.net

Server:  UnKnown
Address:  10.0.0.254

*** UnKnown can't find cache.steamcache.lancache.net: No response from server

 

Link to comment
Share on other sites

Link to post
Share on other sites

2 hours ago, TinsellyCone241 said:

i am still getting this from NSlookup.

  Reveal hidden contents

(Me)>nslookup cache.steamcache.lancache.net

Server:  UnKnown
Address:  10.0.0.254

*** UnKnown can't find cache.steamcache.lancache.net: No response from server

 

Are you setting 10.0.0.X as your DNS on your pc? That's not a nameserver or DNS server..

Link to comment
Share on other sites

Link to post
Share on other sites

21 minutes ago, AbsoluteFool said:

Are you setting 10.0.0.X as your DNS on your pc? That's not a nameserver or DNS server..

10.0.0.254 is my LanCache server, and it redirects all traffic to my router except for steam games, windows updates etc. (I think) Apparently I need to set the Lancache server's IP as the DNS on my main PC.

Link to comment
Share on other sites

Link to post
Share on other sites

9 hours ago, TinsellyCone241 said:

10.0.0.254 is my LanCache server, and it redirects all traffic to my router except for steam games, windows updates etc. (I think) Apparently I need to set the Lancache server's IP as the DNS on my main PC.

Just making sure, you have both the lancache and lancache-dns containers running? Because the “lancache” container on its own doesn’t do DNS.

Looking to buy GTX690, other multi-GPU cards, or single-slot graphics cards: 

 

Link to comment
Share on other sites

Link to post
Share on other sites

2 hours ago, brwainer said:

Just making sure, you have both the lancache and lancache-dns containers running? Because the “lancache” container on its own doesn’t do DNS.

The 3 containers running are:

Lancache DNS

Lancache Sniproxy

Lancache Monolithic

Link to comment
Share on other sites

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share


×