Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

Possible Brick out of the box?

So I built my first pc and everything worked! (For about 2 minutes)

unfortunately after installing Windows and setting up to update everything my computer died. To be clear it did not die while installing anything (to my knowledge). I did not tell the pc to download anything, when I pressed check for updates the system crashed and now has the same problem - won’t post. 
I’ve tried resetting all the ports, but nothing. I get power to everything, all fans on, gpu on cpu warming up, but no post no beeps. No display. Tried multiple monitors, tried removing the cmos battery, so far so not good. What to do now? I’m trying to see if I can RMA the mobo..... but I don’t want to wait another 2-3 weeks 😭 I’m thinking of trying to flash the bios but idk how to do that. 

 

asrock x570 taichi

amd ryzen 3700x

geforce rtx 2070 super

gskill ripjaws 3600 ddr4 (2x8)

Noctua d15 cooler

Link to comment
Share on other sites

Link to post
Share on other sites

I also tried hooking hdmi directly to board without gpu attaches, no dice

Link to comment
Share on other sites

Link to post
Share on other sites

I just read something on the forum that claims Microsoft has set it up so “check for updates” on effectively turns users into beta testers.  You may possibly have some sort of crap update on there.

Life is like a bowl of chocolates: there are all these little crinkly paper cups everywhere.

Link to comment
Share on other sites

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share


×