Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

Mouse stops holding left click

Shiniontv
 Share

Hello everyone

 

I have this problem with my mouse, which is, when I hold down the left click button, sometimes, the mouse stops holding it down on the computer, even though I still hold it down on the mouse itself.

 

Please help as soon as possible, as this is very annoying in competitive games.

 

Thanks in advance,

Shinion

Link to comment
Share on other sites

Link to post
Share on other sites

1 minute ago, Shiniontv said:

Hello everyone

 

I have this problem with my mouse, which is, when I hold down the left click button, sometimes, the mouse stops holding it down on the computer, even though I still hold it down on the mouse itself.

 

Please help as soon as possible, as this is very annoying in competitive games.

 

Thanks in advance,

Shinion

Very informative.. What kind of mouse it is?

Link to comment
Share on other sites

Link to post
Share on other sites

10 minutes ago, noxdeouroboros said:

Very informative.. What kind of mouse it is?

Logitech G303 Daedalus Apex. 

Link to comment
Share on other sites

Link to post
Share on other sites

5 minutes ago, Shiniontv said:

Logitech G303 Daedalus Apex. 

No warranty left? RMA it if possible, I would not fuck around with a pricey mouse myself.

Link to comment
Share on other sites

Link to post
Share on other sites

19 minutes ago, noxdeouroboros said:

No warranty left? RMA it if possible, I would not fuck around with a pricey mouse myself.

I just want to know the cause

Link to comment
Share on other sites

Link to post
Share on other sites

1 minute ago, Shiniontv said:

I just want to know the cause

It might be some dust build up, it was in my case, but you have to  disassemble the mouse and void warranty. Or try to clean it while assembled by using this : s-l500.jpg 

Link to comment
Share on other sites

Link to post
Share on other sites

8 minutes ago, noxdeouroboros said:

It might be some dust build up, it was in my case, but you have to  disassemble the mouse and void warranty. Or try to clean it while assembled by using this : s-l500.jpg 

Okay, thanks

Link to comment
Share on other sites

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share


×