Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

RDC Port Forwarding Issue

bubuie
 Share

Hey guys, here the thing , I am trying to set up a RDC from my office to my home PC , at home I have a Tenda F3 router , found a port forwarding section and added my IPv4 address there with 3389 port , allowed remote connection to PC, but when i am trying to connect from another network with my public IP i get an error that connection could not be made.

 

image.png.b908e9d13194667b79fc1631f482e85c.png

 

 

Am i doing something wrong here?

Link to comment
Share on other sites

Link to post
Share on other sites

If you just want to remote into the office desktop you know Google and Teamviewer have options available that don't require opening ports. Or does your office have rules against the installation of 3rd party software?

Link to comment
Share on other sites

Link to post
Share on other sites

1 minute ago, Windows7ge said:

If you just want to remote into the office desktop you know Google and Teamviewer have options available that don't require opening ports. Or does your office have rules against the installation of 3rd party software?

exactly that the problem, before they renew the team viewer subscription or whatever it is , i have to use this one

Link to comment
Share on other sites

Link to post
Share on other sites

2 minutes ago, bubuie said:

exactly that the problem, before they renew the team viewer subscription or whatever it is , i have to use this one

What version of Windows do you have? If you're on 10 Pro, you need to enable RDP connections.

 

Go on to Control Panel ---> System On the left hand side there should be this click on Remote settings then a box will open, on the bottom it should say Allow remote connections to this computer and also untick the box underneath it.

 

Windows 10 PRO

 

ed152fcf750a551a5daf49abea122ee0.png

 

Windows 10 Home

 

If you're using Windows 10 follow this guide because RDP is not available for Windows 10 and if it still not working follow the guide for Windows 10 Pro

 

 

 

 

 

CPU: AMD Ryzen 5 5600X | CPU Cooler: Stock AMD Cooler | Motherboard: Asus ROG STRIX B550-F GAMING (WI-FI) | RAM: Corsair Vengeance LPX 16 GB (2 x 8 GB) DDR4-3000 CL16 | GPU: Nvidia GTX 1060 6GB Zotac Mini | Case: K280 Case | PSU: Cooler Master B600 Power supply | SSD: 1TB  | HDDs: 1x 250GB & 1x 1TB WD Blue | Monitors: 24" Acer S240HLBID + 24" Samsung  | OS: Win 10 Pro

 

Audio: Behringer Q802USB Xenyx 8 Input Mixer |  U-PHORIA UMC204HD | Behringer XM8500 Dynamic Cardioid Vocal Microphone | Sound Blaster Audigy Fx PCI-E card

 

Home Lab:  Lenovo ThinkCenter M82 ESXi 6.7 | Lenovo M93 Tiny Exchange 2019 | TP-LINK TL-SG1024D 24-Port Gigabit | Cisco ASA 5506 firewall  | Cisco Catalyst 3750 Gigabit Switch | Cisco 2960C-LL | HP MicroServer G8 NAS | Dell PowerEdge R210 II SCCM Server

 

 

Link to comment
Share on other sites

Link to post
Share on other sites

19 minutes ago, Abdul201588 said:

What version of Windows do you have? If you're on 10 Pro, you need to enable RDP connections.

 

Go on to Control Panel ---> System On the left hand side there should be this click on Remote settings then a box will open, on the bottom it should say Allow remote connections to this computer and also untick the box underneath it.

 

Windows 10 PRO

 

ed152fcf750a551a5daf49abea122ee0.png

 

Windows 10 Home

 

If you're using Windows 10 follow this guide because RDP is not available for Windows 10 and if it still not working follow the guide for Windows 10 Pro

 

 

 

 

 

i have already done that . I am on Window Pro 10 , when i am checking my IP online for ports it says that 3389 port is closed, however i have it enabled from router settings.

Link to comment
Share on other sites

Link to post
Share on other sites

2 minutes ago, bubuie said:

i have already done that . I am on Window Pro 10 , when i am checking my IP online for ports it says that 3389 port is closed, however i have it enabled from router settings.

What are you entering when you try to RDP. IP address, hostname? 

 

EDIT: BTW; RDP uses UDP not TCP.

CPU: AMD Ryzen 5 5600X | CPU Cooler: Stock AMD Cooler | Motherboard: Asus ROG STRIX B550-F GAMING (WI-FI) | RAM: Corsair Vengeance LPX 16 GB (2 x 8 GB) DDR4-3000 CL16 | GPU: Nvidia GTX 1060 6GB Zotac Mini | Case: K280 Case | PSU: Cooler Master B600 Power supply | SSD: 1TB  | HDDs: 1x 250GB & 1x 1TB WD Blue | Monitors: 24" Acer S240HLBID + 24" Samsung  | OS: Win 10 Pro

 

Audio: Behringer Q802USB Xenyx 8 Input Mixer |  U-PHORIA UMC204HD | Behringer XM8500 Dynamic Cardioid Vocal Microphone | Sound Blaster Audigy Fx PCI-E card

 

Home Lab:  Lenovo ThinkCenter M82 ESXi 6.7 | Lenovo M93 Tiny Exchange 2019 | TP-LINK TL-SG1024D 24-Port Gigabit | Cisco ASA 5506 firewall  | Cisco Catalyst 3750 Gigabit Switch | Cisco 2960C-LL | HP MicroServer G8 NAS | Dell PowerEdge R210 II SCCM Server

 

 

Link to comment
Share on other sites

Link to post
Share on other sites

1 minute ago, Abdul201588 said:

What are you entering when you try to RDP?

my IP address, public one, and tried with my IP:port, and without port but still same

Link to comment
Share on other sites

Link to post
Share on other sites

Just now, bubuie said:

my IP address, public one, and tried with my IP:port, and without port but still same

Okay. You need also change from TCP to UDP. RDP uses UDP. Also check your firewall on the PC you're trying to connect to make sure RDP is allowed through it.

CPU: AMD Ryzen 5 5600X | CPU Cooler: Stock AMD Cooler | Motherboard: Asus ROG STRIX B550-F GAMING (WI-FI) | RAM: Corsair Vengeance LPX 16 GB (2 x 8 GB) DDR4-3000 CL16 | GPU: Nvidia GTX 1060 6GB Zotac Mini | Case: K280 Case | PSU: Cooler Master B600 Power supply | SSD: 1TB  | HDDs: 1x 250GB & 1x 1TB WD Blue | Monitors: 24" Acer S240HLBID + 24" Samsung  | OS: Win 10 Pro

 

Audio: Behringer Q802USB Xenyx 8 Input Mixer |  U-PHORIA UMC204HD | Behringer XM8500 Dynamic Cardioid Vocal Microphone | Sound Blaster Audigy Fx PCI-E card

 

Home Lab:  Lenovo ThinkCenter M82 ESXi 6.7 | Lenovo M93 Tiny Exchange 2019 | TP-LINK TL-SG1024D 24-Port Gigabit | Cisco ASA 5506 firewall  | Cisco Catalyst 3750 Gigabit Switch | Cisco 2960C-LL | HP MicroServer G8 NAS | Dell PowerEdge R210 II SCCM Server

 

 

Link to comment
Share on other sites

Link to post
Share on other sites

21 minutes ago, Abdul201588 said:

Okay. You need also change from TCP to UDP. RDP uses UDP. Also check your firewall on the PC you're trying to connect to make sure RDP is allowed through it.

Are you sure about that?

 

Make sure inbound 3389 is permitted in windows firewall and any applicable router firewall.

PC : 3600 · Crosshair VI WiFi · 2x16GB RGB 3200 · 1080Ti SC2 · 1TB WD SN750 · EVGA 1600G2 · Define C 

Link to comment
Share on other sites

Link to post
Share on other sites

24 minutes ago, Abdul201588 said:

Okay. You need also change from TCP to UDP. RDP uses UDP. Also check your firewall on the PC you're trying to connect to make sure RDP is allowed through it.

Changed that aswell, Disabled firewall completely not to face that issue aswell,

 

when i am trying to check Port number on my IP it says this

Port 3389 is closed on (MY IP)

Link to comment
Share on other sites

Link to post
Share on other sites

14 minutes ago, bubuie said:

Changed that aswell, Disabled firewall completely not to face that issue aswell,

 

when i am trying to check Port number on my IP it says this

Port 3389 is closed on (MY IP)

No need to put the port number it's already open from the port forwarding.

 

17 minutes ago, beersykins said:

Are you sure about that?

Fail It uses both. Fail. :D 

CPU: AMD Ryzen 5 5600X | CPU Cooler: Stock AMD Cooler | Motherboard: Asus ROG STRIX B550-F GAMING (WI-FI) | RAM: Corsair Vengeance LPX 16 GB (2 x 8 GB) DDR4-3000 CL16 | GPU: Nvidia GTX 1060 6GB Zotac Mini | Case: K280 Case | PSU: Cooler Master B600 Power supply | SSD: 1TB  | HDDs: 1x 250GB & 1x 1TB WD Blue | Monitors: 24" Acer S240HLBID + 24" Samsung  | OS: Win 10 Pro

 

Audio: Behringer Q802USB Xenyx 8 Input Mixer |  U-PHORIA UMC204HD | Behringer XM8500 Dynamic Cardioid Vocal Microphone | Sound Blaster Audigy Fx PCI-E card

 

Home Lab:  Lenovo ThinkCenter M82 ESXi 6.7 | Lenovo M93 Tiny Exchange 2019 | TP-LINK TL-SG1024D 24-Port Gigabit | Cisco ASA 5506 firewall  | Cisco Catalyst 3750 Gigabit Switch | Cisco 2960C-LL | HP MicroServer G8 NAS | Dell PowerEdge R210 II SCCM Server

 

 

Link to comment
Share on other sites

Link to post
Share on other sites

On 12/27/2018 at 2:03 PM, Abdul201588 said:

Fail It uses both. Fail

Please elaborate on your stance and what specific rdp functions rely on udp, because udp forwarding is not the reason it's failing.

PC : 3600 · Crosshair VI WiFi · 2x16GB RGB 3200 · 1080Ti SC2 · 1TB WD SN750 · EVGA 1600G2 · Define C 

Link to comment
Share on other sites

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share


×