Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

Motherboard doesn’t turn on

Fredster5000
 Share

So guys,

my first pc build didnt turn on, so i took apart everything, i just have the motherboard connected to the PSU,

however, when i turn the PSU on, the motherboard flashes but doesn’t stay on, does that mean its broken?

Link to comment
Share on other sites

Link to post
Share on other sites

What mobo and psu?

PC: CPU: i5-9600k - CPU Cooler: be quiet! Dark Rock Pro 4 - GPU: Sapphire Radeon RX 5700 XT 8GB GDDR6 - Motherboard: ASRock - Z370 Extreme4 - RAM: Team - T-Force Delta RGB 16 GB DDR4-3000 - PSU: Corsair - TXM Gold 550 W 80+ Gold Certified Semi-Modular ATX Power Supply - Case: Thermaltake - Core G21 TG

Link to comment
Share on other sites

Link to post
Share on other sites

2 minutes ago, immaguy1234 said:

The mobo will not post without a cpu, ram, and storage. (some mobos require a gpu)

some cpu's*

 

asus boards can do without, but that's as far as I know pattented

Link to comment
Share on other sites

Link to post
Share on other sites

 

8 minutes ago, Fredster5000 said:

Every slot just flashes, nothing remains turn on

Did it do this with everything in it? And don't forget to quote or @ people, or else they wont know you responded

PC: CPU: i5-9600k - CPU Cooler: be quiet! Dark Rock Pro 4 - GPU: Sapphire Radeon RX 5700 XT 8GB GDDR6 - Motherboard: ASRock - Z370 Extreme4 - RAM: Team - T-Force Delta RGB 16 GB DDR4-3000 - PSU: Corsair - TXM Gold 550 W 80+ Gold Certified Semi-Modular ATX Power Supply - Case: Thermaltake - Core G21 TG

Link to comment
Share on other sites

Link to post
Share on other sites

1 minute ago, lmeneses said:

 

Did it do this with everything in it? And don't forget to quote or @ people, or else they wont know you responded

im guessing it did it with nothing in it

Link to comment
Share on other sites

Link to post
Share on other sites

Just now, Fredster5000 said:

Anyways, do i also have to power the cpu etc? Or can i just connect only the mobo to the psu?

@immaguy1234

 

 

 

you also need to power the cpu

Link to comment
Share on other sites

Link to post
Share on other sites

1 minute ago, Fredster5000 said:

Anyways, do i also have to power the cpu etc? Or can i just connect only the mobo to the psu?

@immaguy1234

 

 

 

nope. the memory and cpu should be enough to get into the bios. add your hdd or ssd for the os if you want to go to that step. but first, bios time

Link to comment
Share on other sites

Link to post
Share on other sites

2 minutes ago, LukeSavenije said:

nope. the memory and cpu should be enough to get into the bios. add your hdd or ssd for the os if you want to go to that step. but first, bios time

mine required storage, idk about his

Link to comment
Share on other sites

Link to post
Share on other sites

Just now, immaguy1234 said:

mine required storage, idk about his

to go into the bios? really? that's kinda weird

Link to comment
Share on other sites

Link to post
Share on other sites

Just now, Fredster5000 said:

But it should turn on without cooler right?

it should turn on w/o a cooler, but try it with a cooler

Link to comment
Share on other sites

Link to post
Share on other sites

Just now, Fredster5000 said:

But it should turn on without cooler right?

well, it might actually have a security for that too

Link to comment
Share on other sites

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share


×