Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

NVME M.2 SSD Showing up in bios but not on Windows, not even at device management

Vitreovz
 Share

So as said on the title, i have an Acer Predator Helios 300 G3-572. Machine was running fine, however i purchased a new windows license and therefor i wanted to perform a clean installation process.

I used the windows media creation tool to make a bootable device, I booted into windows installation and everything was going perfectly. When I’m asked to pick which drive I want to install windows at, both my SSD and HDD appeared, however, since I used them and i wanted a clean installation, i formatted them
both, i saw the SSD was partitioned into “system reserved” and the actual main SSD area” and I actually deleted both partitions. Expecting to create a newer one with the Unallocated space, we’ll, didn’t happened, after deleting the SSD system reserved and SSD partition, it never showed up again, only the 1Tb hdd showed up.

SSD does show up at the BIOS so drive is not dead, however windows won’t detect it, not even device management, CMd diskpart and list disk won’t show anything either.

im assuming that I deleted some sort of driver that allowed the PC nvme connect to the OS. I installed windows on my hdd through UEFI, just to try and install some drivers to maybe make the SSD available again but I was not successful.

Im desperate because it does show up at bios but not at windows, never happened to me before, I’ve been trying to fix this since yesterday’s morning so I’m pretty much out of ideas.

im gonna list a couple thing I’ve done so far:
-Updated bios to newest version without any success
-Installed AHCI and SATA drivers through acers website
-Installed IO drivers and chipset drivers as well
-Tried to use diskpart and list disk commands
-Ran memory diagnostic tool
-cleared TPM TCM state
-uninstalled SATA AHCI driver and rebooted pc
- used Linux Ubuntu through live usb to try to make the drive work through gpart but it wouldn’t show up there neither
-disabled/enabled secure boot at bios
-Checked if both sata devices were enabled, they were




I guess it’s some drivers issue, since I wiped the drive that may have the drivers contained in it. I tried to install Samsung’s nvme driver, newest version, but won’t work because it says that no drive is connected.


What can I do? Any ideas?
I saw a post in here I which the bios have them the option to whether use AHCI or RTS optane, but I can’t find that option anywhere on my bios.


my model is a Acer Predator helios 300 g3-572

any help is appreciated

Link to comment
Share on other sites

Link to post
Share on other sites

check diskmgmt.msc (disk management) then

CPU: i7-2600K 4751MHz 1.44V (software) --> 1.47V at the back of the socket Motherboard: Asrock Z77 Extreme4 (BCLK: 103.3MHz) CPU Cooler: Noctua NH-D15 RAM: Adata XPG 2x8GB DDR3 (XMP: 2133MHz 10-11-11-30 CR2, custom: 2203MHz 10-11-10-26 CR1 tRFC:230 tREFI:14000) GPU: Asus GTX 1070 Dual (Super Jetstream vbios, +70(2025-2088MHz)/+400(8.8Gbps)) SSD: Samsung 840 Pro 256GB (main boot drive), Transcend SSD370 128GB PSU: Seasonic X-660 80+ Gold Case: Antec P110 Silent, 5 intakes 1 exhaust Monitor: AOC G2460PF 1080p 144Hz (150Hz max w/ DP, 121Hz max w/ HDMI) TN panel Keyboard: Logitech G610 Orion (Cherry MX Blue) with SteelSeries Apex M260 keycaps Mouse: BenQ Zowie FK1

 

Model: HP Omen 17 17-an110ca CPU: i7-8750H (0.125V core & cache, 50mV SA undervolt) GPU: GTX 1060 6GB Mobile (+80/+450, 1650MHz~1750MHz 0.78V~0.85V) RAM: 8+8GB DDR4-2400 18-17-17-39 2T Storage: 1TB HP EX920 PCIe x4 M.2 SSD + 1TB Seagate 7200RPM 2.5" HDD (ST1000LM049-2GH172), 128GB Toshiba PCIe x2 M.2 SSD (KBG30ZMV128G) gone cooking externally Monitor: 1080p 126Hz IPS G-sync

 

Desktop benching:

Cinebench R15 Single thread:168 Multi-thread: 833 

SuperPi (v1.5 from Techpowerup, PI value output) 16K: 0.100s 1M: 8.255s 32M: 7m 45.93s

Link to comment
Share on other sites

Link to post
Share on other sites

12 minutes ago, Jurrunio said:

check diskmgmt.msc (disk management) then

Just did, with no success. Only hard drive unit is displayed

Link to comment
Share on other sites

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share


×