Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
dotalover

40 fps on Apex Legends with 1660ti on low settings, Help!

Recommended Posts

Posted · Original PosterOP

Since this morning I'm getting only 40 to 50 fps on Apex legends while on low settings. I have an asus laptop running a ryzen 7 3750h with a 1660ti max q with 16 gigs of ram on dual channel. I really enjoy apex legends and I used to get some 70 80 fps on fairly low settings but it has been dropping for the past week  and since today it's on 40 fps which is unbearable. Need help 

Link to post
Share on other sites
Posted · Original PosterOP
8 minutes ago, boggy77 said:

is the laptop plugged in? are you sure you're running the game with the dedicated gpu and not with the igpu? how are the temperatures?

Yes. It is plugged in. Set on high performance mode. With the nvidia GPU in use. Temps are around 86°C but I did notice the GPU utilization being low,around  40 50%

Link to post
Share on other sites
7 minutes ago, dotalover said:

Temps are around 86°C

if that's the gpu temp, that's most likely the issue. most nvidia gpus start throttling at 85 by default. try to clean the fans a bit and maybe use a cooling pad. you can also install msi afterburner and try a more aggressive fan curve and a bit of undervolting

Link to post
Share on other sites
9 minutes ago, boggy77 said:

if that's the gpu temp, that's most likely the issue. most nvidia gpus start throttling at 85 by default. try to clean the fans a bit and maybe use a cooling pad. you can also install msi afterburner and try a more aggressive fan curve and a bit of undervolting

Yes. Mobile GPUs in particular are more thermally bound their desktop counterparts, because high temps affect the entire system more acutely.

Link to post
Share on other sites
Posted · Original PosterOP
21 minutes ago, Chris Pratt said:

Yes. Mobile GPUs in particular are more thermally bound their desktop counterparts, because high temps affect the entire system more acutely.

It was fine just yesterday and now today its potato. I dont think it's the temp only. Even before the gpu hits 80 the fps is already pretty low. It's not like the fps gets lower as tge tends rises

Link to post
Share on other sites
Posted · Original PosterOP
32 minutes ago, boggy77 said:

if that's the gpu temp, that's most likely the issue. most nvidia gpus start throttling at 85 by default. try to clean the fans a bit and maybe use a cooling pad. you can also install msi afterburner and try a more aggressive fan curve and a bit of undervolting

My fans are already turbo ing at max and maybe I should try to clean up a bit 

Link to post
Share on other sites
1 hour ago, dotalover said:

It was fine just yesterday and now today its potato. I dont think it's the temp only. Even before the gpu hits 80 the fps is already pretty low. It's not like the fps gets lower as tge tends rises

Yes. That's exactly how it is. As temps get higher, the more it thermal throttles. It will keep throttling back until temps return to acceptable ranges.

Link to post
Share on other sites

-> Moved to PC Gaming


^^^^ That's my post ^^^^
<-- This is me --- That's your scrollbar -->
vvvv Who's there? vvvv

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×