Jump to content
To encourage social distancing, you must leave two blank lines at the start and end of every post, and before and after every quote. Failure to comply may result in non-essential parts of the forum closing. Click for more details. ×
Search In
  • More options...
Find results that contain...
Find results in...
phongle123

Any external enclosure that fully supports 4TB SSD?

Recommended Posts

Posted · Original PosterOP

I'm looking for an external enclosure that fully supports a Samsung 860 EVO 4TB SSD.

 

I have 2 SABRENT Enclosures that keep corrupting my SSD from folder corruption to whole FS corruption. The below are the enclosures I have used. 

 

1) https://www.amazon.com/Sabrent-Tool-free-Enclosure-Optimized-EC-UASP/dp/B00OJ3UJ2S - Corruption problem on 4TB Samsung 860 EVO SSD but no problem for my 2TB Micron SSD.

2) https://www.amazon.com/dp/B07NF6JQQ4 - Same problem as above

3) https://www.amazon.com/gp/product/B07FDTY299 - Did not support >2TB Capacity.

 

Can anyone with experience link me to a better enclosure that supports a 4TB SAMSUNG 860 EVO SSD without any hitches. 

Link to post
Share on other sites

Hello and welcome.

 

What USB controller are you using in your PC?


AMD Ryzen 3900X  |  Fractal Design S36 360 AIO w/3 Corsair SP120L and 3 Noctua NF-F12 3000 fans  |  Asus Crosshair VII WiFi X470  |  G.SKILL TridentZ 3600CL15 2x8GB @ 3800MHz 14-15-14-14-30  |  EVGA 1070 Ti SC GAMING ACX 3.0 Black w/NZXT Kraken G12 Cooler  |  Samsung 970 EVO M.2 NVMe 500GB - Boot Drive  |  Samsung 850 EVO SSD 1TB - Game Drive  |  Seagate 1TB HDD - Media Drive  |  EVGA 650 G3 PSU | Thermaltake Core P3 Case 

Link to post
Share on other sites
Posted · Original PosterOP
Just now, nick name said:

Hello and welcome.

 

What USB controller are you using in your PC?

IDK but it occurs on the latest Ryzen x570 MB and the latest Razer Blade 15". So it's the enclosure.

Link to post
Share on other sites
Just now, phongle123 said:

IDK but it occurs on the latest Ryzen x570 MB and the latest Razer Blade 15". So it's the enclosure.

Perhaps they use the same USB controller?  I only think to ask because of a recent video by HardwareCanucks.

 

Do you think it might be that the USB port can't supply the drive enough power?  Perhaps a powered enclosure is needed?  Or a powered USB hub?


AMD Ryzen 3900X  |  Fractal Design S36 360 AIO w/3 Corsair SP120L and 3 Noctua NF-F12 3000 fans  |  Asus Crosshair VII WiFi X470  |  G.SKILL TridentZ 3600CL15 2x8GB @ 3800MHz 14-15-14-14-30  |  EVGA 1070 Ti SC GAMING ACX 3.0 Black w/NZXT Kraken G12 Cooler  |  Samsung 970 EVO M.2 NVMe 500GB - Boot Drive  |  Samsung 850 EVO SSD 1TB - Game Drive  |  Seagate 1TB HDD - Media Drive  |  EVGA 650 G3 PSU | Thermaltake Core P3 Case 

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×