Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
TheYonderGod

AMD driver 300mhz bug

Recommended Posts

Posted · Original PosterOP

1. Stock settings runs 100% perfect. At idle GPU clock speed goes down to 450mhz, everything is fine. 

 

2. Change either clock setting. Doesn't matter if it's even just 1mhz or an underclock. Idle clock speed goes down to 300mhz. This causes artifacts: screens flashing/flickering.  

 

I've googled and seen it talked about but I can't find a proper solution. It happens with 2 different GPUs I have; r9 270x and HD7970.

 

I tried disabling ULPS in MSI Afterburner. Nothing changes. 

Someone mentioned swaping my bios for one that is stock overclocked, but then I read it's not supported starting on this series of GPU?

The best solution I can come up with is to enable game specific overclocking but this still has problems when the game is loading or in menus sometimes or when alt-tabbing.

 

Interestingly if I lower the resolution and/or refresh rate of my monitors it flickers less, and almost stops at the lowest possible setting. 

 


My Rig: CPU: 3570k@4.4Ghz | GPU: XFX r9 270x | Mobo: Asrock Z77 Extreme 4 | RAM: 16GB DDR3 2133 | Cooler: Hyper 212+

PSU: OCZ 700w | Sound Card: Creative Sound Blaster Z | Headphones: AD700 | Case: NZXT M59 | Monitor: 144hz 1080p

Link to post
Share on other sites
3 hours ago, TheYonderGod said:

 

 

Interestingly if I lower the resolution and/or refresh rate of my monitors it flickers less, and almost stops at the lowest possible setting. 

 

I believe this part has something to do with sync.  Do you have enhanced sync enabled, if so disable it and see if that helps with the flickering.  Also, if your using Freesync, try disabling freesync as well. I know I have huge issues with flickering each and every time I try to use Freesync, to the point where I have given up on ever using Freesync on my current monitor/GPU combo. 

Link to post
Share on other sites
Posted · Original PosterOP
16 hours ago, Midnitewolf said:

I believe this part has something to do with sync.  Do you have enhanced sync enabled, if so disable it and see if that helps with the flickering.  Also, if your using Freesync, try disabling freesync as well. I know I have huge issues with flickering each and every time I try to use Freesync, to the point where I have given up on ever using Freesync on my current monitor/GPU combo. 

No I do not have enhanced sync or Freesync. 


My Rig: CPU: 3570k@4.4Ghz | GPU: XFX r9 270x | Mobo: Asrock Z77 Extreme 4 | RAM: 16GB DDR3 2133 | Cooler: Hyper 212+

PSU: OCZ 700w | Sound Card: Creative Sound Blaster Z | Headphones: AD700 | Case: NZXT M59 | Monitor: 144hz 1080p

Link to post
Share on other sites
Posted · Original PosterOP

I seem to have accidentally found a work around. No idea why this changes it, but if I switch profiles in MSI afterburner with hotkeys instead of clicking apply. Idle clock stays at 450. No more problems. 


My Rig: CPU: 3570k@4.4Ghz | GPU: XFX r9 270x | Mobo: Asrock Z77 Extreme 4 | RAM: 16GB DDR3 2133 | Cooler: Hyper 212+

PSU: OCZ 700w | Sound Card: Creative Sound Blaster Z | Headphones: AD700 | Case: NZXT M59 | Monitor: 144hz 1080p

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×