Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
DominicNikon

Fps issue in Battlefield 4

34 minutes ago, Vishera said:

Try right click on game EXE>Properties>Compability tab>Disable fullscreen optimizations>Click "Apply"

ok so i went back to the previous windows insider build 18999 and my fps is back to normal and i made a feedback post on microsoft that 19002  messed up game performance

Recommended Posts

Posted · Original PosterOP

Hello, i have this issue that started after the latest windows insider build where battlefield 4 is stuck at 60fps even though all my settings are the same and my gpu drivers are update to date. Anyone know how to fix this or is it a issue with windows 10 build 19002?

if needed my specs are:

I5 4670k, GTX 980, 16gb ram

Link to post
Share on other sites

Do you have V-sync on?


Main Desktop: Cpu - I7-8700k @5ghz | Mobo - Asus ROG STRIX Z390-E | Gpu - Asus ROG STRIX 2080ti OC Ram - G.Skill Trident Z RGB 16GB 3200mhz | Aio - H100i Pro RGB | Psu - Evga 850 GQ | Case - Fractal Design Meshify C White | Storage - Samsung 970 Pro M.2 NVME SSD 1x 1TB 1x 512GB / 1x Seagate Ironwolf Pro 4TB HDD |

 

TV Streaming PC: Intel Nuc CPU - i7 8th Gen | RAM - 16GB DDR4 2666mhz | Storage - 256GB WD Black M.2 NVME SSD |

 

Phone: Samsung Galaxy S10+ - Ceramic White 512GB |

 

If you ask for a Mid Tower case recommend, I will 90% of the time recommend the Fractal Design Meshify C or S2.

Link to post
Share on other sites
Posted · Original PosterOP
3 minutes ago, SpookyCitrus said:

Do you have V-sync on?

no i do not. it is off in game settings. 

Also a restart of both the game and PC did not help

Link to post
Share on other sites

Try a DDU and a reinstall of the drivers through Geforce Experience. Also check your nvidia control panel to see if V-sync is enabled in there.


Main Desktop: Cpu - I7-8700k @5ghz | Mobo - Asus ROG STRIX Z390-E | Gpu - Asus ROG STRIX 2080ti OC Ram - G.Skill Trident Z RGB 16GB 3200mhz | Aio - H100i Pro RGB | Psu - Evga 850 GQ | Case - Fractal Design Meshify C White | Storage - Samsung 970 Pro M.2 NVME SSD 1x 1TB 1x 512GB / 1x Seagate Ironwolf Pro 4TB HDD |

 

TV Streaming PC: Intel Nuc CPU - i7 8th Gen | RAM - 16GB DDR4 2666mhz | Storage - 256GB WD Black M.2 NVME SSD |

 

Phone: Samsung Galaxy S10+ - Ceramic White 512GB |

 

If you ask for a Mid Tower case recommend, I will 90% of the time recommend the Fractal Design Meshify C or S2.

Link to post
Share on other sites

Maybe micro$ft added a FPS limiter in this build and it's bugged or turned on by default,that's why it's not recommended to use insider builds.

 

Anyway Windows 10 is full of crap,I prefer Windows Server 2019 with Windows desktop environment or even Windows 7 than to use Windows 10,

Windows Server 2019 doesn't have bloatware,and bloated features,no ads,no "one cloud" or any of that crap.it's clean and performs better than Windows 10,

Windows Server 2019 even supports DXR,DX12 and is more reliable due to it's Enterprise market target,so no problematic updates,less telemetry.


A PC Enthusiast since 2011
AMD Ryzen 5 2600@4GHz | GIGABYTE GTX 1660 GAMING OC @ Core 2040MHz Memory 5000MHz
Cinebench R15: 1382cb | Unigine Superposition 1080p Extreme: 3439
Link to post
Share on other sites
Posted · Original PosterOP
13 minutes ago, SpookyCitrus said:

Try a DDU and a reinstall of the drivers through Geforce Experience. Also check your nvidia control panel to see if V-sync is enabled in there.

ok, I reinstalled the graphic drivers and  V-Sync is off in the Nvidia control panel but the game is still stuck at 60 fps

Link to post
Share on other sites
Posted · Original PosterOP
3 minutes ago, Vishera said:

Maybe micro$ft added a FPS limiter in this build and it's bugged or turned on by default,that's why it's not recommended to use insider builds.

 

Anyway Windows 10 is full of crap,I prefer Windows Server 2019 with Windows desktop environment or even Windows 7 than to use Windows 10,

Windows Server 2019 doesn't have bloatware,and bloated features,no ads,no "one cloud" or any of that crap.it's clean and performs better than Windows 10,

Windows Server 2019 even supports DXR,DX12 and is more reliable due to it's Enterprise market target,so no problematic updates,less telemetry.

oh ok, i've been a windows insider for a little while now

Link to post
Share on other sites
1 minute ago, DominicNikon said:

oh ok, i've been a windows insider for a little while now

Try right click on game EXE>Properties>Compability tab>Disable fullscreen optimizations>Click "Apply"


A PC Enthusiast since 2011
AMD Ryzen 5 2600@4GHz | GIGABYTE GTX 1660 GAMING OC @ Core 2040MHz Memory 5000MHz
Cinebench R15: 1382cb | Unigine Superposition 1080p Extreme: 3439
Link to post
Share on other sites
Posted · Original PosterOP · Best Answer
34 minutes ago, Vishera said:

Try right click on game EXE>Properties>Compability tab>Disable fullscreen optimizations>Click "Apply"

ok so i went back to the previous windows insider build 18999 and my fps is back to normal and i made a feedback post on microsoft that 19002  messed up game performance

Link to post
Share on other sites
Just now, DominicNikon said:

ok so i went back to the previous windows insider build 18999 and my fps is back to normal and i made a feedback post on microsoft that 19002  messed up game performance

I am glad it's working now :D

Insider builds are just untested versions of Windows so problems tend to happen with those builds.


A PC Enthusiast since 2011
AMD Ryzen 5 2600@4GHz | GIGABYTE GTX 1660 GAMING OC @ Core 2040MHz Memory 5000MHz
Cinebench R15: 1382cb | Unigine Superposition 1080p Extreme: 3439
Link to post
Share on other sites
Posted · Original PosterOP
5 minutes ago, Vishera said:

I am glad it's working now :D

Insider builds are just untested versions of Windows so problems tend to happen with those builds.

yeah its basically beta testing

Link to post
Share on other sites
Posted · Original PosterOP
14 hours ago, Vishera said:

I am glad it's working now :D

Insider builds are just untested versions of Windows so problems tend to happen with those builds.

just thought i would tell you. on my feedback post to windows insider many other people are having the same fps issue on build 19002 

Link to post
Share on other sites
1 hour ago, DominicNikon said:

just thought i would tell you. on my feedback post to windows insider many other people are having the same fps issue on build 19002 

It's nice of you to update me on this,Thanks :D


A PC Enthusiast since 2011
AMD Ryzen 5 2600@4GHz | GIGABYTE GTX 1660 GAMING OC @ Core 2040MHz Memory 5000MHz
Cinebench R15: 1382cb | Unigine Superposition 1080p Extreme: 3439
Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×