Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
LeviathanUK

CPU-Z showing my RAM is default clocked

Recommended Posts

Posted · Original PosterOP

Hi! I recently upgraded my rig to a 3700x x570 Taichi and 32gb 16x2 3466 Dominator Platinum RGB - I was in the bios and enabled overclocking for the RAM and set the frequency to 3466 and whenever I go into the bios it displays that it is still 3466 but my CPU-Z is showing that my RAM  Frequency is at 1066mhz, I know it's halved on there meaning it's showing 2133mhz instead of 3466, I was going to try changing it with Ryzen Master but seen loads of people saying to only overclock in the bios, i'm kind of lost and not sure if CPU-Z is wrong or if it's just not overclocking properly and I may be losing performance since it's a 3700x.

Link to post
Share on other sites

what does task manager say the ram is running at?


Current Rig=  AMD Ryzen 5 2600x, Asus Prime x470-pro, Asus strix gtx 1070 ti, 32gb Corsair Vengence Pro RGB 3000hz White, EVGA 750 P2 PSU, 500gb samsung 860 evo, 2tb seagate firecuda sshd,  NZXT H700i, EK Supremacy evo am4 RGB, EK strix 1080 full cover block, EK X-Res 140 d4 pump, EK CE 240mm Rad, EK CE 280mm Rad

Link to post
Share on other sites
Posted · Original PosterOP

What do you mean? @COUPER MILLAR This is my first time using AMD so I'm very new to it.

Also I'll add that my CAM software for my Hue+ ( and old kraken) Does display that I'm using 32GB of Ram but it doesn't show my speed:
77d881f01c97dbcc8984dcaa2395474b.png
https://gyazo.com/77d881f01c97dbcc8984dcaa2395474b

Also my iCUE software for my headset shows this:
fc778794e358904d44d85a30285488de.png
https://gyazo.com/fc778794e358904d44d85a30285488de

Link to post
Share on other sites

In the bios you should be able to go to the oc tab and adjust the memory speed. Instead of just selecting the stock xmp profile set the memory speed to say 3200mhz. If you haven't done so already reseat your ram too. And finally not judging but review your mobo manual and make sure that you have installed the ram in the correct slots

Link to post
Share on other sites
Posted · Original PosterOP

I did adjust the speed to 3466 and whenever I go back into the bios it still shows 3466 on the OC tab. Also i have them in the first and third slots "A1 and A2". Should they be in A1 and B1? I know with Intel it's usually 1 and 3.

Link to post
Share on other sites

I think you need to go into the bios and enable XMP. Otherwise the RAM wil run at the JEDEC speeds on 2133.

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×