Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
cluelessgenius

[CluelessBuilds] Fragile Investment - Glas, Chrome and only the thiccest Rads

Recommended Posts

Posted · Original PosterOP
3 hours ago, For Science! said:

uhhh, are you adding water to the reservoir in the back? you know, where the pump is? Pump only pushes water and is fed by gravity.

:) i just notoced how it might seem im stupid. but no. i filled the res above the pump completely. i just thought since the pump aint wotking i might aswell test if the fittings in the front leak or not and poured in water through the top rad directly. i aint that dumb.... i hope


"I know its stupidly overdone and unreasonably unneccesary but wouldnt it be awesome if ..."

 

CPU: Delidded i7 7700k (watercooled) Cooling: 3x 360 rads by Alphacool  MB: ASUS z270i  RAM: G.Skill Trident Z RGB 16GB  GPU: MSI GTX1080 Ti Aero (watercooled)  DISPLAY: LG 34UC88-B 21:9 1440p SSD(OS): Samsung 960 EVO 250GB SSD(Games): Corsair MP510 960GB SSD(Applikations): Samsung 840 EVO 250GB  HDD(Scratch): WD Blue 500GB HDD(Downloads): WD Blue 320GB HDD(Long-term): WD Green 2TB (external)   PSU: Corsair SF600 Case: Lian Li PC-O11 D Mouse: Logitech MX Master Keyboard: Logitech G513 Carbon

 

Link to post
Share on other sites
Just now, cluelessgenius said:

:) i just notoced how it might seem im stupid. but no. i filled the res above the pump completely. i just thought since the pump aint wotking i might aswell test if the fittings in the front leak or not and poured in water through the top rad directly. i aint that dumb.... i hope

I wouldn't be too suprised if the water doesn't just "flow" since you have effectively an airlock in the system, you do have to push the fluid through the block to displace the air in the system. 

 

You've never shown the back of your system, care to share with use how its plumbed in? Maybe there is something obvious we can spot.

Link to post
Share on other sites
Posted · Original PosterOP
12 minutes ago, For Science! said:

I wouldn't be too suprised if the water doesn't just "flow" since you have effectively an airlock in the system, you do have to push the fluid through the block to displace the air in the system. 

 

You've never shown the back of your system, care to share with use how its plumbed in? Maybe there is something obvious we can spot.

Sure will do.... Tommorrow im tired


"I know its stupidly overdone and unreasonably unneccesary but wouldnt it be awesome if ..."

 

CPU: Delidded i7 7700k (watercooled) Cooling: 3x 360 rads by Alphacool  MB: ASUS z270i  RAM: G.Skill Trident Z RGB 16GB  GPU: MSI GTX1080 Ti Aero (watercooled)  DISPLAY: LG 34UC88-B 21:9 1440p SSD(OS): Samsung 960 EVO 250GB SSD(Games): Corsair MP510 960GB SSD(Applikations): Samsung 840 EVO 250GB  HDD(Scratch): WD Blue 500GB HDD(Downloads): WD Blue 320GB HDD(Long-term): WD Green 2TB (external)   PSU: Corsair SF600 Case: Lian Li PC-O11 D Mouse: Logitech MX Master Keyboard: Logitech G513 Carbon

 

Link to post
Share on other sites
Posted · Original PosterOP
On ‎9‎/‎8‎/‎2019 at 1:56 AM, For Science! said:

 

sooo sunday didnt happen had some stuff coming up with the family. ill make a short video about it today. i realized with video its way easier to "show and tell" and explain stuff.

 

anyway i have tested the pump outside the loop with just a tube attached to the outlet feeding into a bucket. filled up the res powered it on - nothing. so im pretty sure at this point the pump got a problem and i have contacted aqua computer about it already.

 

or do i just not understand how pumps work. i have heard things about if theres even a tiny bit of air in there it wont spin and stuff like that but i think i made pretty sure theres no air in there also looking at the mechnism im wondering why it shouldnt. 

it seems to be just a magnetically susspended impeller piece and then i asume its spun by changing the magnetic fiel electrically inside the pump. what am i missing. i guess i need to look at some diagrams.


"I know its stupidly overdone and unreasonably unneccesary but wouldnt it be awesome if ..."

 

CPU: Delidded i7 7700k (watercooled) Cooling: 3x 360 rads by Alphacool  MB: ASUS z270i  RAM: G.Skill Trident Z RGB 16GB  GPU: MSI GTX1080 Ti Aero (watercooled)  DISPLAY: LG 34UC88-B 21:9 1440p SSD(OS): Samsung 960 EVO 250GB SSD(Games): Corsair MP510 960GB SSD(Applikations): Samsung 840 EVO 250GB  HDD(Scratch): WD Blue 500GB HDD(Downloads): WD Blue 320GB HDD(Long-term): WD Green 2TB (external)   PSU: Corsair SF600 Case: Lian Li PC-O11 D Mouse: Logitech MX Master Keyboard: Logitech G513 Carbon

 

Link to post
Share on other sites
1 minute ago, cluelessgenius said:

 

I've seen at least one case of each where the pump housing was pinching the power cable, and another case where the molex power cables were inverted and needed to flipped. Make sure these things are okay, especially for a new unit.

Link to post
Share on other sites
Posted · Original PosterOP
1 minute ago, For Science! said:

I've seen at least one case of each where the pump housing was pinching the power cable, and another case where the molex power cables were inverted and needed to flipped. Make sure these things are okay, especially for a new unit.

you mean i need to try switching the 2 moelx pins? you sure thats save? i dont want my researching the problem be the reason i definitly break it. also what do you mean the pump housing is pinching the cables? you want me to try and take it apart completly?


"I know its stupidly overdone and unreasonably unneccesary but wouldnt it be awesome if ..."

 

CPU: Delidded i7 7700k (watercooled) Cooling: 3x 360 rads by Alphacool  MB: ASUS z270i  RAM: G.Skill Trident Z RGB 16GB  GPU: MSI GTX1080 Ti Aero (watercooled)  DISPLAY: LG 34UC88-B 21:9 1440p SSD(OS): Samsung 960 EVO 250GB SSD(Games): Corsair MP510 960GB SSD(Applikations): Samsung 840 EVO 250GB  HDD(Scratch): WD Blue 500GB HDD(Downloads): WD Blue 320GB HDD(Long-term): WD Green 2TB (external)   PSU: Corsair SF600 Case: Lian Li PC-O11 D Mouse: Logitech MX Master Keyboard: Logitech G513 Carbon

 

Link to post
Share on other sites
Just now, cluelessgenius said:

 

the cables are colored, so if they match the molex pinout, don't do it. To investigate whether the cables are pinched internally, yes you will have to take the pump out of the housing.

 

Apart from that, these are the usual checks:

- Do you have the PSU plugged in

- Are you jumpering the 24-pin cable

- Is the molex power connected to both the pump and the PSU

 

If these things are okay, then I assume its a problem with the pump. If under warranty maybe going through that is easier for you. 

Link to post
Share on other sites
Posted · Original PosterOP
3 minutes ago, For Science! said:

the cables are colored, so if they match the molex pinout, don't do it. To investigate whether the cables are pinched internally, yes you will have to take the pump out of the housing.

alright. i think they are fine but ill double check later thanks.

Quote

Apart from that, these are the usual checks:

- Do you have the PSU plugged in

- Are you jumpering the 24-pin cable

- Is the molex power connected to both the pump and the PSU

-.- really? do you have the the psu plugged in? dude. yes its all plugged in and jumpered. the psu fan turns on noticably for a second when i flick the power switch on the psu and i even tested the molex with a psu tester. there should be power.

Quote

If these things are okay, then I assume its a problem with the pump. If under warranty maybe going through that is easier for you. 

yeah its right on the edge of its warranty since i planned this build so long ago. but it should be covered lets see what they say before i start opening stuff up.


"I know its stupidly overdone and unreasonably unneccesary but wouldnt it be awesome if ..."

 

CPU: Delidded i7 7700k (watercooled) Cooling: 3x 360 rads by Alphacool  MB: ASUS z270i  RAM: G.Skill Trident Z RGB 16GB  GPU: MSI GTX1080 Ti Aero (watercooled)  DISPLAY: LG 34UC88-B 21:9 1440p SSD(OS): Samsung 960 EVO 250GB SSD(Games): Corsair MP510 960GB SSD(Applikations): Samsung 840 EVO 250GB  HDD(Scratch): WD Blue 500GB HDD(Downloads): WD Blue 320GB HDD(Long-term): WD Green 2TB (external)   PSU: Corsair SF600 Case: Lian Li PC-O11 D Mouse: Logitech MX Master Keyboard: Logitech G513 Carbon

 

Link to post
Share on other sites
Posted · Original PosterOP

@For Science! alright i just got word from aqua computer as so often with this build already theres a chance that i might have just derped here again. they asked me to lubricate it slightly and then turn it on as is for just a second to see if it spins up. basically what you have been suggesting. so ill test that.

but also more importantly they mentioned that the res combo might be on there too tight and that made me realize that i did put the pump oring over the pump and around the circumference of it when maybe i shouldve just put it on the face of the pump moving it futrther away from the res combo. i mean the tolarances where just so perfect it fit so nicely like this but i will check both the dry run and the oring placement later today. maybe this thing isnt dead after all. 

wouldnt be the first time i derped on this one and may not even be the last time. it is my first time doing a custom loop after all.


"I know its stupidly overdone and unreasonably unneccesary but wouldnt it be awesome if ..."

 

CPU: Delidded i7 7700k (watercooled) Cooling: 3x 360 rads by Alphacool  MB: ASUS z270i  RAM: G.Skill Trident Z RGB 16GB  GPU: MSI GTX1080 Ti Aero (watercooled)  DISPLAY: LG 34UC88-B 21:9 1440p SSD(OS): Samsung 960 EVO 250GB SSD(Games): Corsair MP510 960GB SSD(Applikations): Samsung 840 EVO 250GB  HDD(Scratch): WD Blue 500GB HDD(Downloads): WD Blue 320GB HDD(Long-term): WD Green 2TB (external)   PSU: Corsair SF600 Case: Lian Li PC-O11 D Mouse: Logitech MX Master Keyboard: Logitech G513 Carbon

 

Link to post
Share on other sites
Posted · Original PosterOP

@For Science!

just noticed i said aqua tuning but of course i mean aqua computer


"I know its stupidly overdone and unreasonably unneccesary but wouldnt it be awesome if ..."

 

CPU: Delidded i7 7700k (watercooled) Cooling: 3x 360 rads by Alphacool  MB: ASUS z270i  RAM: G.Skill Trident Z RGB 16GB  GPU: MSI GTX1080 Ti Aero (watercooled)  DISPLAY: LG 34UC88-B 21:9 1440p SSD(OS): Samsung 960 EVO 250GB SSD(Games): Corsair MP510 960GB SSD(Applikations): Samsung 840 EVO 250GB  HDD(Scratch): WD Blue 500GB HDD(Downloads): WD Blue 320GB HDD(Long-term): WD Green 2TB (external)   PSU: Corsair SF600 Case: Lian Li PC-O11 D Mouse: Logitech MX Master Keyboard: Logitech G513 Carbon

 

Link to post
Share on other sites
3 hours ago, cluelessgenius said:

@For Science!

just noticed i said aqua tuning but of course i mean aqua computer

The two sleeved cables (on the D5), which color cable goes to which side on the molex side?

Basically I've seen some pumps in the past where the 12 V cable (red normally) that is suppsoed to be on the outside of the molex pinout was inserted into the ground instead, and pumps wouldn't turn on until you pulled the cables out of the molex connector and flip them around.

 

This isn't the exact thread that I helped out in (I think it may have even be a private skype call I addressed)

Some other D5 threads that I helped out in the past.

 

Link to post
Share on other sites
Posted · Original PosterOP
6 hours ago, For Science! said:

The two sleeved cables (on the D5), which color cable goes to which side on the molex side?

Basically I've seen some pumps in the past where the 12 V cable (red normally) that is suppsoed to be on the outside of the molex pinout was inserted into the ground instead, and pumps wouldn't turn on until you pulled the cables out of the molex connector and flip them around.

 

This isn't the exact thread that I helped out in (I think it may have even be a private skype call I addressed)

Some other D5 threads that I helped out in the past.

 

thanks will read through later but molex seems to be hooked up right. also heres the insidesSavedImage_20190910_095215_01.thumb.jpg.38d969eed1ca27995a2bf29677dfbd65.jpg20190910_094753.thumb.jpg.57348925043f2fae808979122702e2c1.jpg20190910_094844.thumb.jpg.14910706867a7c2dc257f6a9efccba96.jpg20190910_095152_HDR.thumb.jpg.32619245bf93f2331bc3f0919d91bb88.jpg


"I know its stupidly overdone and unreasonably unneccesary but wouldnt it be awesome if ..."

 

CPU: Delidded i7 7700k (watercooled) Cooling: 3x 360 rads by Alphacool  MB: ASUS z270i  RAM: G.Skill Trident Z RGB 16GB  GPU: MSI GTX1080 Ti Aero (watercooled)  DISPLAY: LG 34UC88-B 21:9 1440p SSD(OS): Samsung 960 EVO 250GB SSD(Games): Corsair MP510 960GB SSD(Applikations): Samsung 840 EVO 250GB  HDD(Scratch): WD Blue 500GB HDD(Downloads): WD Blue 320GB HDD(Long-term): WD Green 2TB (external)   PSU: Corsair SF600 Case: Lian Li PC-O11 D Mouse: Logitech MX Master Keyboard: Logitech G513 Carbon

 

Link to post
Share on other sites
Posted · Original PosterOP

@For Science!

alright i have spent the last 15 minutes cussing. heres the stupid situation. i found the problem. i thought i had checked the molex - turns out i had the molex connected to the 5v line and now it does turn. heres the stupid part. it almost fell off the table and in me catching it the ribbon cable tore off. 447628473_Capture_2019-09-10-10-31-13.thumb.png.238dbbd0fe53b033eb03ee48621a0115.png

 

so i think aqua computer might not cover that even though they told me to open it. soo im probably gonna solder in some cavles to replace the ribbon and test the usb connection. 12v is fine but ill have no controls if i cant repair the data lines. 


"I know its stupidly overdone and unreasonably unneccesary but wouldnt it be awesome if ..."

 

CPU: Delidded i7 7700k (watercooled) Cooling: 3x 360 rads by Alphacool  MB: ASUS z270i  RAM: G.Skill Trident Z RGB 16GB  GPU: MSI GTX1080 Ti Aero (watercooled)  DISPLAY: LG 34UC88-B 21:9 1440p SSD(OS): Samsung 960 EVO 250GB SSD(Games): Corsair MP510 960GB SSD(Applikations): Samsung 840 EVO 250GB  HDD(Scratch): WD Blue 500GB HDD(Downloads): WD Blue 320GB HDD(Long-term): WD Green 2TB (external)   PSU: Corsair SF600 Case: Lian Li PC-O11 D Mouse: Logitech MX Master Keyboard: Logitech G513 Carbon

 

Link to post
Share on other sites

Oof....well at least you found the issue....somehow pin swapping is more common than it should be on these molex connectors. 

Link to post
Share on other sites
Posted · Original PosterOP
1 hour ago, For Science! said:

Oof....well at least you found the issue....somehow pin swapping is more common than it should be on these molex connectors. 

well stupid me had some cable sleeves left over and thought it would be a good idea to do the pump molex cables. so had i never touched those cables it wouldve been fine. jesus christ i hope i can repair those data lines. the soldering points do look pretty big so getting some cables in there hopefully works. luckily the casing offers enough room for some thin extra cables.

lets hope i can pull it off.


"I know its stupidly overdone and unreasonably unneccesary but wouldnt it be awesome if ..."

 

CPU: Delidded i7 7700k (watercooled) Cooling: 3x 360 rads by Alphacool  MB: ASUS z270i  RAM: G.Skill Trident Z RGB 16GB  GPU: MSI GTX1080 Ti Aero (watercooled)  DISPLAY: LG 34UC88-B 21:9 1440p SSD(OS): Samsung 960 EVO 250GB SSD(Games): Corsair MP510 960GB SSD(Applikations): Samsung 840 EVO 250GB  HDD(Scratch): WD Blue 500GB HDD(Downloads): WD Blue 320GB HDD(Long-term): WD Green 2TB (external)   PSU: Corsair SF600 Case: Lian Li PC-O11 D Mouse: Logitech MX Master Keyboard: Logitech G513 Carbon

 

Link to post
Share on other sites
Posted · Original PosterOP

so in the latest response i got from them they said that sadly they dont have that cable in stock anymore since that modell of pump is not produced anymore. but funnily enough he also advised me to just solder 4 thin cables on there (which i was planning on doing anyway) and that they used to just solder cables there in the early models aswell before they switched to the ribbon cable. still feel stupid that i even had to have this problem but at least its a fix that i feel is doable for me.

oh man im so hyped again now. i never had a watercooled system (aside from aio a long time ago) and with the number of rad space im so curious about temps and most of all how far will that 1080 ti go ? my pulse is getting dangerous right now. i need to calm down before i fuck up again in my euphoria


"I know its stupidly overdone and unreasonably unneccesary but wouldnt it be awesome if ..."

 

CPU: Delidded i7 7700k (watercooled) Cooling: 3x 360 rads by Alphacool  MB: ASUS z270i  RAM: G.Skill Trident Z RGB 16GB  GPU: MSI GTX1080 Ti Aero (watercooled)  DISPLAY: LG 34UC88-B 21:9 1440p SSD(OS): Samsung 960 EVO 250GB SSD(Games): Corsair MP510 960GB SSD(Applikations): Samsung 840 EVO 250GB  HDD(Scratch): WD Blue 500GB HDD(Downloads): WD Blue 320GB HDD(Long-term): WD Green 2TB (external)   PSU: Corsair SF600 Case: Lian Li PC-O11 D Mouse: Logitech MX Master Keyboard: Logitech G513 Carbon

 

Link to post
Share on other sites
Posted · Original PosterOP

sorry its so long but believe it or not its already at 1.5x speed. i was just cautious about it and nervous and took my time. next up im gonna drain it again and put EKs cryfuel in there


"I know its stupidly overdone and unreasonably unneccesary but wouldnt it be awesome if ..."

 

CPU: Delidded i7 7700k (watercooled) Cooling: 3x 360 rads by Alphacool  MB: ASUS z270i  RAM: G.Skill Trident Z RGB 16GB  GPU: MSI GTX1080 Ti Aero (watercooled)  DISPLAY: LG 34UC88-B 21:9 1440p SSD(OS): Samsung 960 EVO 250GB SSD(Games): Corsair MP510 960GB SSD(Applikations): Samsung 840 EVO 250GB  HDD(Scratch): WD Blue 500GB HDD(Downloads): WD Blue 320GB HDD(Long-term): WD Green 2TB (external)   PSU: Corsair SF600 Case: Lian Li PC-O11 D Mouse: Logitech MX Master Keyboard: Logitech G513 Carbon

 

Link to post
Share on other sites
Posted · Original PosterOP

going in boys

20190911_210204_HDR.thumb.jpg.2bc32f77d67dd4583ec51bc5abd0d930.jpg


"I know its stupidly overdone and unreasonably unneccesary but wouldnt it be awesome if ..."

 

CPU: Delidded i7 7700k (watercooled) Cooling: 3x 360 rads by Alphacool  MB: ASUS z270i  RAM: G.Skill Trident Z RGB 16GB  GPU: MSI GTX1080 Ti Aero (watercooled)  DISPLAY: LG 34UC88-B 21:9 1440p SSD(OS): Samsung 960 EVO 250GB SSD(Games): Corsair MP510 960GB SSD(Applikations): Samsung 840 EVO 250GB  HDD(Scratch): WD Blue 500GB HDD(Downloads): WD Blue 320GB HDD(Long-term): WD Green 2TB (external)   PSU: Corsair SF600 Case: Lian Li PC-O11 D Mouse: Logitech MX Master Keyboard: Logitech G513 Carbon

 

Link to post
Share on other sites
Posted · Original PosterOP

20190911_225128.thumb.jpg.839811d0557e8ef8b1b9112059ccede6.jpg

 


"I know its stupidly overdone and unreasonably unneccesary but wouldnt it be awesome if ..."

 

CPU: Delidded i7 7700k (watercooled) Cooling: 3x 360 rads by Alphacool  MB: ASUS z270i  RAM: G.Skill Trident Z RGB 16GB  GPU: MSI GTX1080 Ti Aero (watercooled)  DISPLAY: LG 34UC88-B 21:9 1440p SSD(OS): Samsung 960 EVO 250GB SSD(Games): Corsair MP510 960GB SSD(Applikations): Samsung 840 EVO 250GB  HDD(Scratch): WD Blue 500GB HDD(Downloads): WD Blue 320GB HDD(Long-term): WD Green 2TB (external)   PSU: Corsair SF600 Case: Lian Li PC-O11 D Mouse: Logitech MX Master Keyboard: Logitech G513 Carbon

 

Link to post
Share on other sites
Posted · Original PosterOP

 


"I know its stupidly overdone and unreasonably unneccesary but wouldnt it be awesome if ..."

 

CPU: Delidded i7 7700k (watercooled) Cooling: 3x 360 rads by Alphacool  MB: ASUS z270i  RAM: G.Skill Trident Z RGB 16GB  GPU: MSI GTX1080 Ti Aero (watercooled)  DISPLAY: LG 34UC88-B 21:9 1440p SSD(OS): Samsung 960 EVO 250GB SSD(Games): Corsair MP510 960GB SSD(Applikations): Samsung 840 EVO 250GB  HDD(Scratch): WD Blue 500GB HDD(Downloads): WD Blue 320GB HDD(Long-term): WD Green 2TB (external)   PSU: Corsair SF600 Case: Lian Li PC-O11 D Mouse: Logitech MX Master Keyboard: Logitech G513 Carbon

 

Link to post
Share on other sites
Posted · Original PosterOP
On ‎7‎/‎22‎/‎2019 at 10:26 AM, For Science! said:

Is this not just because you took an X99 block? My normal supremacy evo didn't have any problems on the z370i,

hey do you know why this picture gets selected as the preview image when im trying post a link to this thread somewhere? can you maybe put it in a spoiler?


"I know its stupidly overdone and unreasonably unneccesary but wouldnt it be awesome if ..."

 

CPU: Delidded i7 7700k (watercooled) Cooling: 3x 360 rads by Alphacool  MB: ASUS z270i  RAM: G.Skill Trident Z RGB 16GB  GPU: MSI GTX1080 Ti Aero (watercooled)  DISPLAY: LG 34UC88-B 21:9 1440p SSD(OS): Samsung 960 EVO 250GB SSD(Games): Corsair MP510 960GB SSD(Applikations): Samsung 840 EVO 250GB  HDD(Scratch): WD Blue 500GB HDD(Downloads): WD Blue 320GB HDD(Long-term): WD Green 2TB (external)   PSU: Corsair SF600 Case: Lian Li PC-O11 D Mouse: Logitech MX Master Keyboard: Logitech G513 Carbon

 

Link to post
Share on other sites

No idea, guess im just too important 😛

 

ive put it in a spoiler but maybe ask a mod about it.

Link to post
Share on other sites
Posted · Original PosterOP

stress test coming up next

 

oh yeah and i just did the pcpartpickerlist with the actual numbers i paid (link in my bio) and this thing has now cost me almost 3k ...jesus effin christ. 


"I know its stupidly overdone and unreasonably unneccesary but wouldnt it be awesome if ..."

 

CPU: Delidded i7 7700k (watercooled) Cooling: 3x 360 rads by Alphacool  MB: ASUS z270i  RAM: G.Skill Trident Z RGB 16GB  GPU: MSI GTX1080 Ti Aero (watercooled)  DISPLAY: LG 34UC88-B 21:9 1440p SSD(OS): Samsung 960 EVO 250GB SSD(Games): Corsair MP510 960GB SSD(Applikations): Samsung 840 EVO 250GB  HDD(Scratch): WD Blue 500GB HDD(Downloads): WD Blue 320GB HDD(Long-term): WD Green 2TB (external)   PSU: Corsair SF600 Case: Lian Li PC-O11 D Mouse: Logitech MX Master Keyboard: Logitech G513 Carbon

 

Link to post
Share on other sites
Posted · Original PosterOP

 


"I know its stupidly overdone and unreasonably unneccesary but wouldnt it be awesome if ..."

 

CPU: Delidded i7 7700k (watercooled) Cooling: 3x 360 rads by Alphacool  MB: ASUS z270i  RAM: G.Skill Trident Z RGB 16GB  GPU: MSI GTX1080 Ti Aero (watercooled)  DISPLAY: LG 34UC88-B 21:9 1440p SSD(OS): Samsung 960 EVO 250GB SSD(Games): Corsair MP510 960GB SSD(Applikations): Samsung 840 EVO 250GB  HDD(Scratch): WD Blue 500GB HDD(Downloads): WD Blue 320GB HDD(Long-term): WD Green 2TB (external)   PSU: Corsair SF600 Case: Lian Li PC-O11 D Mouse: Logitech MX Master Keyboard: Logitech G513 Carbon

 

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Buy VPN

×