Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

Liquid metal on socket pins :(

kazuma
 Share

Question! Is there a good way to remove a small amount of thermal grizzly's conductonaut on a cpu socket? I accidentally dropped a small amount on the edge of the socket.

 

(Warning: Cringy photo below)

 

i1yvw7ol.jpg

 

I've already tried sucking it out using the syringe that came with it, was able to remove a small amount but still. Im guessing my Z270i Strix will see the beyond now?

Link to comment
Share on other sites

Link to post
Share on other sites

You shouldn't have left me and this world behind into your so called reality

 

you can try using a solder wick, but that's quite expensive

CPU: i7-2600K 4751MHz 1.44V (software) --> 1.47V at the back of the socket Motherboard: Asrock Z77 Extreme4 (BCLK: 103.3MHz) CPU Cooler: Noctua NH-D15 RAM: Adata XPG 2x8GB DDR3 (XMP: 2133MHz 10-11-11-30 CR2, custom: 2203MHz 10-11-10-26 CR1 tRFC:230 tREFI:14000) GPU: Asus GTX 1070 Dual (Super Jetstream vbios, +70(2025-2088MHz)/+400(8.8Gbps)) SSD: Samsung 840 Pro 256GB (main boot drive), Transcend SSD370 128GB PSU: Seasonic X-660 80+ Gold Case: Antec P110 Silent, 5 intakes 1 exhaust Monitor: AOC G2460PF 1080p 144Hz (150Hz max w/ DP, 121Hz max w/ HDMI) TN panel Keyboard: Logitech G610 Orion (Cherry MX Blue) with SteelSeries Apex M260 keycaps Mouse: BenQ Zowie FK1

 

Model: HP Omen 17 17-an110ca CPU: i7-8750H (0.125V core & cache, 50mV SA undervolt) GPU: GTX 1060 6GB Mobile (+80/+450, 1650MHz~1750MHz 0.78V~0.85V) RAM: 8+8GB DDR4-2400 18-17-17-39 2T Storage: 1TB HP EX920 PCIe x4 M.2 SSD + 1TB Seagate 7200RPM 2.5" HDD (ST1000LM049-2GH172), 128GB Toshiba PCIe x2 M.2 SSD (KBG30ZMV128G) gone cooking externally Monitor: 1080p 126Hz IPS G-sync

 

Desktop benching:

Cinebench R15 Single thread:168 Multi-thread: 833 

SuperPi (v1.5 from Techpowerup, PI value output) 16K: 0.100s 1M: 8.255s 32M: 7m 45.93s

Link to comment
Share on other sites

Link to post
Share on other sites

2 minutes ago, Jurrunio said:

You shouldn't have left me and this world behind into your so called reality

 

you can try using a solder wick, but that's quite expensive

Sorry for the dumb-dumb question, but how would I use that? 

Link to comment
Share on other sites

Link to post
Share on other sites

20 minutes ago, kazuma said:

Sorry for the dumb-dumb question, but how would I use that? 

just wipe it off with the solder wick itself. Liquid metal is already liquid so you need not apply heat to it with a heat gun.

CPU: i7-2600K 4751MHz 1.44V (software) --> 1.47V at the back of the socket Motherboard: Asrock Z77 Extreme4 (BCLK: 103.3MHz) CPU Cooler: Noctua NH-D15 RAM: Adata XPG 2x8GB DDR3 (XMP: 2133MHz 10-11-11-30 CR2, custom: 2203MHz 10-11-10-26 CR1 tRFC:230 tREFI:14000) GPU: Asus GTX 1070 Dual (Super Jetstream vbios, +70(2025-2088MHz)/+400(8.8Gbps)) SSD: Samsung 840 Pro 256GB (main boot drive), Transcend SSD370 128GB PSU: Seasonic X-660 80+ Gold Case: Antec P110 Silent, 5 intakes 1 exhaust Monitor: AOC G2460PF 1080p 144Hz (150Hz max w/ DP, 121Hz max w/ HDMI) TN panel Keyboard: Logitech G610 Orion (Cherry MX Blue) with SteelSeries Apex M260 keycaps Mouse: BenQ Zowie FK1

 

Model: HP Omen 17 17-an110ca CPU: i7-8750H (0.125V core & cache, 50mV SA undervolt) GPU: GTX 1060 6GB Mobile (+80/+450, 1650MHz~1750MHz 0.78V~0.85V) RAM: 8+8GB DDR4-2400 18-17-17-39 2T Storage: 1TB HP EX920 PCIe x4 M.2 SSD + 1TB Seagate 7200RPM 2.5" HDD (ST1000LM049-2GH172), 128GB Toshiba PCIe x2 M.2 SSD (KBG30ZMV128G) gone cooking externally Monitor: 1080p 126Hz IPS G-sync

 

Desktop benching:

Cinebench R15 Single thread:168 Multi-thread: 833 

SuperPi (v1.5 from Techpowerup, PI value output) 16K: 0.100s 1M: 8.255s 32M: 7m 45.93s

Link to comment
Share on other sites

Link to post
Share on other sites

2 minutes ago, Jurrunio said:

just wipe it off with the solder wick itself. Liquid metal is already liquid so you need not apply heat to it with a heat gun.

Thanks! I might try that although it still makes me nervous. I've accidentally bent a socket pin before and I don't wanna go through that nightmare again. :P
You RMA will be an option? I doubt it though.

Link to comment
Share on other sites

Link to post
Share on other sites

1 minute ago, kazuma said:

You RMA will be an option?

Not an option. Heck RMA doesnt work even if it's normal thermal paste that got in there.

CPU: i7-2600K 4751MHz 1.44V (software) --> 1.47V at the back of the socket Motherboard: Asrock Z77 Extreme4 (BCLK: 103.3MHz) CPU Cooler: Noctua NH-D15 RAM: Adata XPG 2x8GB DDR3 (XMP: 2133MHz 10-11-11-30 CR2, custom: 2203MHz 10-11-10-26 CR1 tRFC:230 tREFI:14000) GPU: Asus GTX 1070 Dual (Super Jetstream vbios, +70(2025-2088MHz)/+400(8.8Gbps)) SSD: Samsung 840 Pro 256GB (main boot drive), Transcend SSD370 128GB PSU: Seasonic X-660 80+ Gold Case: Antec P110 Silent, 5 intakes 1 exhaust Monitor: AOC G2460PF 1080p 144Hz (150Hz max w/ DP, 121Hz max w/ HDMI) TN panel Keyboard: Logitech G610 Orion (Cherry MX Blue) with SteelSeries Apex M260 keycaps Mouse: BenQ Zowie FK1

 

Model: HP Omen 17 17-an110ca CPU: i7-8750H (0.125V core & cache, 50mV SA undervolt) GPU: GTX 1060 6GB Mobile (+80/+450, 1650MHz~1750MHz 0.78V~0.85V) RAM: 8+8GB DDR4-2400 18-17-17-39 2T Storage: 1TB HP EX920 PCIe x4 M.2 SSD + 1TB Seagate 7200RPM 2.5" HDD (ST1000LM049-2GH172), 128GB Toshiba PCIe x2 M.2 SSD (KBG30ZMV128G) gone cooking externally Monitor: 1080p 126Hz IPS G-sync

 

Desktop benching:

Cinebench R15 Single thread:168 Multi-thread: 833 

SuperPi (v1.5 from Techpowerup, PI value output) 16K: 0.100s 1M: 8.255s 32M: 7m 45.93s

Link to comment
Share on other sites

Link to post
Share on other sites

Just now, Jurrunio said:

Not an option. Heck RMA doesnt work even if it's normal thermal paste that got in there.

LMAO! Just what i thought. :P It just freaks me out whenever my hands go near a socket full of pins. I mean dropping the processor, no problem, but seeing an socket for 2 minutes, without anything covering it, just freaks the hell outta me. 

Link to comment
Share on other sites

Link to post
Share on other sites

9 hours ago, Howitz said:

is liquid metal attracted to magnets? neodynium kind?

Already gave  that a try. It didn't work. :(

Link to comment
Share on other sites

Link to post
Share on other sites

1 hour ago, kazuma said:

Already gave  that a try. It didn't work. :(

Okay i think i have an idea, get some isopropyl and an hair dryer and some cotton swabs, put a drop of isopropyl on the liquid metal drop, heat the liquid metal with the hair dryer so it becomes "more liquid i guess is that how it works"? And try to swipe it off carefully with the cotton swab, (might be a slow and long process) also there is this arctic stuff that you use to dissolve thermal paste that works great.

Link to comment
Share on other sites

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share


×