Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

Motherboard Replacement Z170

So I have an ASUS Maximus VIII Hero motherboard that I'm less than thrilled with (other components in sig). I'm starting to think the motherboard is going bad and now I'm in need of a new one. I'm not upgrading the cpu. 

 

Which board would you recommend? I've been an advocate for ASUS products over the years but their support web page is garbage. Half the time their download site is down. 

 

My only prerequisites I can think of would be a USB c header on mobo for my case and an m.2 pcie slot. More USB slots on the i/o wouldn't be bad either. 

 

Thank you all

Intel i7 6700k|Asus Maximus VIII Hero|Asus Strix 1080|Gskill DDR4 3200|950 Pro M.2|Corsair RM750|Corsair OBSIDIAN 500D|Corsair K65\G65|SteelSeries Arctis 5|Asus PB277Q|PG279Q

Link to comment
Share on other sites

Link to post
Share on other sites

If it's possibly software problem, try uninstall everything you downloaded from the official site (except the BIOS) and let Windows grab the drivers instead.

 

what kind of cooling do you have?

CPU: i7-2600K 4751MHz 1.44V (software) --> 1.47V at the back of the socket Motherboard: Asrock Z77 Extreme4 (BCLK: 103.3MHz) CPU Cooler: Noctua NH-D15 RAM: Adata XPG 2x8GB DDR3 (XMP: 2133MHz 10-11-11-30 CR2, custom: 2203MHz 10-11-10-26 CR1 tRFC:230 tREFI:14000) GPU: Asus GTX 1070 Dual (Super Jetstream vbios, +70(2025-2088MHz)/+400(8.8Gbps)) SSD: Samsung 840 Pro 256GB (main boot drive), Transcend SSD370 128GB PSU: Seasonic X-660 80+ Gold Case: Antec P110 Silent, 5 intakes 1 exhaust Monitor: AOC G2460PF 1080p 144Hz (150Hz max w/ DP, 121Hz max w/ HDMI) TN panel Keyboard: Logitech G610 Orion (Cherry MX Blue) with SteelSeries Apex M260 keycaps Mouse: BenQ Zowie FK1

 

Model: HP Omen 17 17-an110ca CPU: i7-8750H (0.125V core & cache, 50mV SA undervolt) GPU: GTX 1060 6GB Mobile (+80/+450, 1650MHz~1750MHz 0.78V~0.85V) RAM: 8+8GB DDR4-2400 18-17-17-39 2T Storage: 1TB HP EX920 PCIe x4 M.2 SSD + 1TB Seagate 7200RPM 2.5" HDD (ST1000LM049-2GH172), 128GB Toshiba PCIe x2 M.2 SSD (KBG30ZMV128G) gone cooking externally Monitor: 1080p 126Hz IPS G-sync

 

Desktop benching:

Cinebench R15 Single thread:168 Multi-thread: 833 

SuperPi (v1.5 from Techpowerup, PI value output) 16K: 0.100s 1M: 8.255s 32M: 7m 45.93s

Link to comment
Share on other sites

Link to post
Share on other sites

2 hours ago, Jurrunio said:

If it's possibly software problem, try uninstall everything you downloaded from the official site (except the BIOS) and let Windows grab the drivers instead.

 

what kind of cooling do you have?

I have an EKWB custom loop for cooling. I am having tons of problems with the computer turning back when I turn it off, not posting at all in some cases, and issues with "surge" protections being tripped on the mobo. I also have a weird issue where the computer will pull power from any cable connected to it (display port) and feed the mobo lights when unplugged from the wall. 

 

I did a fresh installation of windows and because the Asus website was down I used windows update to install everything. I'm at the point where I wanna say screw it and throw some new hardware at it. 

Intel i7 6700k|Asus Maximus VIII Hero|Asus Strix 1080|Gskill DDR4 3200|950 Pro M.2|Corsair RM750|Corsair OBSIDIAN 500D|Corsair K65\G65|SteelSeries Arctis 5|Asus PB277Q|PG279Q

Link to comment
Share on other sites

Link to post
Share on other sites

21 minutes ago, Vigilante505 said:

I have an EKWB custom loop for cooling. I am having tons of problems with the computer turning back when I turn it off, not posting at all in some cases, and issues with "surge" protections being tripped on the mobo. I also have a weird issue where the computer will pull power from any cable connected to it (display port) and feed the mobo lights when unplugged from the wall. 

 

I did a fresh installation of windows and because the Asus website was down I used windows update to install everything. I'm at the point where I wanna say screw it and throw some new hardware at it. 

well, then it's still the same high end Z170 and Z270 boards from the major brands then.

CPU: i7-2600K 4751MHz 1.44V (software) --> 1.47V at the back of the socket Motherboard: Asrock Z77 Extreme4 (BCLK: 103.3MHz) CPU Cooler: Noctua NH-D15 RAM: Adata XPG 2x8GB DDR3 (XMP: 2133MHz 10-11-11-30 CR2, custom: 2203MHz 10-11-10-26 CR1 tRFC:230 tREFI:14000) GPU: Asus GTX 1070 Dual (Super Jetstream vbios, +70(2025-2088MHz)/+400(8.8Gbps)) SSD: Samsung 840 Pro 256GB (main boot drive), Transcend SSD370 128GB PSU: Seasonic X-660 80+ Gold Case: Antec P110 Silent, 5 intakes 1 exhaust Monitor: AOC G2460PF 1080p 144Hz (150Hz max w/ DP, 121Hz max w/ HDMI) TN panel Keyboard: Logitech G610 Orion (Cherry MX Blue) with SteelSeries Apex M260 keycaps Mouse: BenQ Zowie FK1

 

Model: HP Omen 17 17-an110ca CPU: i7-8750H (0.125V core & cache, 50mV SA undervolt) GPU: GTX 1060 6GB Mobile (+80/+450, 1650MHz~1750MHz 0.78V~0.85V) RAM: 8+8GB DDR4-2400 18-17-17-39 2T Storage: 1TB HP EX920 PCIe x4 M.2 SSD + 1TB Seagate 7200RPM 2.5" HDD (ST1000LM049-2GH172), 128GB Toshiba PCIe x2 M.2 SSD (KBG30ZMV128G) gone cooking externally Monitor: 1080p 126Hz IPS G-sync

 

Desktop benching:

Cinebench R15 Single thread:168 Multi-thread: 833 

SuperPi (v1.5 from Techpowerup, PI value output) 16K: 0.100s 1M: 8.255s 32M: 7m 45.93s

Link to comment
Share on other sites

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share


×