Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

TT Sync Controller not working

Hey guys really hope someone can help.

I recently got the Thermaltake TT Sync controller with 3 of the Thermaltake Riing premium RGB fans.

So after I got everything connected the fans spin up just fine but there is absolutely no LED's firing up on the fans.

I did everything according to instructions and connected it to 5V addressable RGB header on my X470 Taichi but still no LED's fire up on the fans. I have tried literally everything and through the ASRock RGB software I can see the controller is picking up but I cant change anything color-wise literally nothing is happening. Been struggling for 3 days now and I have no idea what to do anymore. Am I missing something?

Link to comment
Share on other sites

Link to post
Share on other sites

Yeah probably should have mentioned that the fans work fine on the normal controller that came with the fans but its just a spinning rainbow at the moment cause the usb interface broke off meaning I have no control over the fan LED's so its just cycling through colors. Thats why I got the TT Sync controller to actually be able to control my LED's cause the rainbow is making me crazy. Also doubt it's the controller cause I tested a friend's exact same one and it also doesnt work it does the same thing. So obviously its the interface between my motherboard and the controller is what I am guessing but I can't seem to figure out if I have done something wrong or not because my motherboard is on the compatibility list for this controller and plugged into the 5V RGB header so everything SHOULD work but I just cant solve this...

 

Link to comment
Share on other sites

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share


×