Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

problems with link to MS account, forgot which account

dgsddfgdfhgs
 Share

So I got all my PCs upgraded to Win10 and linked to MS account, and I am trying to RMA a mobo tmr and licence may be gone if I dont back it up.

 

the steps I have done to all PC/ laptops,

upgraded win10 from win7, linked to MS account. 

But requires stupid login every time, so reinstalled Win10 and it is automatically activated.

 

Now some after long time, I forgot which MS accounts were linked to which PC. (forgot most login details....)

What should I do?

shall I create new MS account and link? (one PC linked to two accounts, assuming only new account works?)

what If I link a PC to an existing account which already Linked another PC?

 

Link to comment
Share on other sites

Link to post
Share on other sites

Go to https://account.microsoft.com/account/connect-devices

Sign in and check Devices - it will show the computer name its linked with. You can even click on Device Info and it will show you the hardware so you can be certain which PC it is. 

Spoiler

Desktop: Ryzen9 5950X | ASUS ROG Crosshair VIII Hero (Wifi) | EVGA RTX 3080Ti FTW3 | 32GB (2x16GB) Corsair Dominator Platinum RGB Pro 3600Mhz | EKWB EK-AIO 360D-RGB | EKWB EK-Vardar RGB Fans | 1TB Samsung 980 Pro, 4TB Samsung 980 Pro | Corsair 5000D Airflow | Corsair HX850 Platinum PSU | LG 32" 32GK850G Monitor x2 | Ducky DK2108 Keyboard | Steel Series Sensei Ten | MicroLab Solo 7C Speakers | Audio-Technica ATH-M50xBT2 LE Headphones | TC-Helicon GoXLR | Audio-Technica AT2035 | LTT Desk Mat | XBOS-X Controller | Windows 11 Pro

 

Spoiler

Server: Fractal Design Define R6 | Ryzen 3950x | ASRock X570 Taichi | EVGA GTX1070 FTW | 64GB (4x16GB) Corsair Vengeance LPX 3000Mhz | Corsair RM850v2 PSU | Fractal S36 Triple AIO | 10 x 8TB HGST Ultrastar He10 (WD Whitelabel) | 500GB Aorus Gen4 NVMe | 2 x 1TB Crucial P1 NVMe | LSI 9211-8i HBA

 

Link to comment
Share on other sites

Link to post
Share on other sites

8 minutes ago, Jarsky said:

Sign in and check Devices - it will show the computer name its linked with. You can even click on Device Info and it will show you the hardware so you can be certain which PC it is. 

I think I lost a few of those accounts and some of those old pc died, 2 licence gone~~

Link to comment
Share on other sites

Link to post
Share on other sites

now have RMA a mobo, Asus B350plus replaced by B350 F, and licence cannot be link back to same account as before. Device not shown, but I am able to link to a account created by virtual machine......

guess I will have to leave it unactivated 

Link to comment
Share on other sites

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share


×