Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

Bios won't load

Hello,

I write this thread with a hope of getting assistance from you guys. Let me briefly explain the situation:

I have gotten my hands on a new hard drive so I thought I would try to install Linux (Fedora 28) as Dual boot with Windows 10. This was my HDD setup at the time:
SSD - Win 10
HDD1 - Data
HDD2 - Empty

I have proceeded with creating a usb bootable drive with an .iso image to install from. Installation went fine, I created a partition on HDD2 which i selected during the installation. After installation finished, I rebooted the PC but it went straight to Windows. I rebooted into Bios, checked boot order but i couldn't see the Linux drive in there. I have proceeded with setting grub as the default bootloader in windows as advised here:
https://itsfoss.com/no-grub-windows-linux/


This time, I got 2 choice after reboot, and both were Fedora. I chose one of them, but it went straight to Windows again. This time, after I rebooted, all i got was a black screen. And this persists. I am aware that I have someone screwed up my system files. I have tried almost everything. Here is my setup:

MB: MSI Z97 GAMING 5
CPU: Intel Core i5-4690K
PSU: Seasonic SS-620GM2 Evo 620W

Now, the things I've tried:
1) Pressing all kinds of buttons during boot, but keyboard nor mouse wont even light up
2) Remove all HDD/SSD and boot
3) Restart CMOS - remove battery, short JBAT1
4) Remove one of the RAM slots
Motherboard 2digit display keeps looping codes.

I am really desperate, do you guys have any additional suggestions?

Thanks!

Link to comment
Share on other sites

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share


×