Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

'Failed To Create D3D Device'

jiyeon
 Share

Go to solution Solved by jiyeon,

Nevermind, I solved it myself.

 

Solution was to key in '-w 1920 -h 1080' into my CSGO's launch options to force it into 1920x1080 fullscreen.

Hi, so I was altering my CSGO settings and specifically my resolution, I went from windowed 1024x768 to fullscreen 1920x1080 (native) and my screen flickered several times before it finally gave me an error saying "Failed to ceate D3D device!" so I'm highly concerned and bewildered as to what to do.

 

So far, I have:
1) Updated to latest Nvidia drivers through GeForce Experience

2) Restarted my PC

3) Entered '-dxlevel 90' into my CSGO launch options as Steam recommended on the support page

... And none of these have solved it.

 

Could I get a little help please?

 

Specs in signature.

mechanical keyboard switches aficionado & hi-fi audio enthusiast

switch reviews  how i lube mx-style keyboard switches

Link to comment
Share on other sites

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share


×